PDFjam, by David Firth, is a small collection of shell scripts
which provide a simple interface to some of the functionality of the pdfpages package (by Andreas Matthias) for pdfLaTeX. PR: ports/78921 Submitted by: Paul Chvostek <paul+ports@it.ca>
This commit is contained in:
parent
ddf82d3d29
commit
307a9ae2c3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131594
@ -163,6 +163,7 @@
|
||||
SUBDIR += passivetex
|
||||
SUBDIR += pcal
|
||||
SUBDIR += pclprint
|
||||
SUBDIR += pdfjam
|
||||
SUBDIR += pdflib
|
||||
SUBDIR += pdflib-perl
|
||||
SUBDIR += pdfmerge
|
||||
|
49
print/pdfjam/Makefile
Normal file
49
print/pdfjam/Makefile
Normal file
@ -0,0 +1,49 @@
|
||||
# New ports collection makefile for: pdfjam
|
||||
# Date created: Tue Mar 15 17:50:34 EST 2005
|
||||
# Whom: Paul Chvostek <paul@it.ca>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pdfjam
|
||||
PORTVERSION= 1.20
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www2.warwick.ac.uk/fac/sci/statistics/staff/academic/firth/software/pdfjam/ \
|
||||
http://www.it.ca/~paul/src/
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= paul+ports@it.ca
|
||||
COMMENT= Shell scripts to manipulate PDF files
|
||||
|
||||
RUN_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
MAN1= pdfjoin.1 pdf90.1 pdfnup.1
|
||||
PLIST_FILES= bin/pdfjoin bin/pdf90 bin/pdfnup
|
||||
PORTDOCS= PDFjam-README.html pdfdroplets.png
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
post-patch:
|
||||
@${LN} -s scripts ${WRKSRC}/bin
|
||||
.for FILE in ${PLIST_FILES}
|
||||
@${SED} -i '' "1s:^#! /bin/sh:#!${SH}:;s:__LOCALBASE__:${LOCALBASE}:" ${WRKSRC}/${FILE}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
.for FILE in ${PLIST_FILES}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/${FILE} ${PREFIX}/bin
|
||||
.endfor
|
||||
.for FILE in ${MAN1}
|
||||
${INSTALL_MAN} ${WRKSRC}/man1/${FILE} ${PREFIX}/man/man1
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for FILE in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
print/pdfjam/distinfo
Normal file
2
print/pdfjam/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (pdfjam_1.20.tgz) = 3e443fd2c0063330313c1c079053e622
|
||||
SIZE (pdfjam_1.20.tgz) = 52814
|
11
print/pdfjam/files/patch-scripts-pdf90
Normal file
11
print/pdfjam/files/patch-scripts-pdf90
Normal file
@ -0,0 +1,11 @@
|
||||
--- scripts/pdf90.orig Tue Jan 25 14:19:21 2005
|
||||
+++ scripts/pdf90 Wed Mar 16 09:16:35 2005
|
||||
@@ -23,7 +23,7 @@
|
||||
##
|
||||
## First say where your "pdflatex" program lives:
|
||||
##
|
||||
-pdflatex=pdflatex
|
||||
+pdflatex=__LOCALBASE__/bin/pdflatex
|
||||
#pdflatex="pdflatex.exe" ## this for Windows computers
|
||||
##
|
||||
## Next a permitted location for temporary files on your system:
|
11
print/pdfjam/files/patch-scripts-pdfjoin
Normal file
11
print/pdfjam/files/patch-scripts-pdfjoin
Normal file
@ -0,0 +1,11 @@
|
||||
--- scripts/pdfjoin.orig Tue Jan 25 14:19:21 2005
|
||||
+++ scripts/pdfjoin Wed Mar 16 09:16:42 2005
|
||||
@@ -23,7 +23,7 @@
|
||||
##
|
||||
## First say where your "pdflatex" program lives:
|
||||
##
|
||||
-pdflatex=pdflatex
|
||||
+pdflatex=__LOCALBASE__/bin/pdflatex
|
||||
#pdflatex="pdflatex.exe" ## this for Windows computers
|
||||
##
|
||||
## Next a permitted location for temporary files on your system:
|
11
print/pdfjam/files/patch-scripts-pdfnup
Normal file
11
print/pdfjam/files/patch-scripts-pdfnup
Normal file
@ -0,0 +1,11 @@
|
||||
--- scripts/pdfnup.orig Tue Jan 25 14:19:21 2005
|
||||
+++ scripts/pdfnup Wed Mar 16 09:17:40 2005
|
||||
@@ -23,7 +23,7 @@
|
||||
##
|
||||
## First say where your "pdflatex" program lives:
|
||||
##
|
||||
-pdflatex=pdflatex
|
||||
+pdflatex=__LOCALBASE__/bin/pdflatex
|
||||
#pdflatex="pdflatex.exe" ## this for Windows computers
|
||||
##
|
||||
## Next a permitted location for temporary files on your system:
|
14
print/pdfjam/pkg-descr
Normal file
14
print/pdfjam/pkg-descr
Normal file
@ -0,0 +1,14 @@
|
||||
PDFjam, by David Firth, is a small collection of shell scripts which provide a
|
||||
simple interface to some of the functionality of the excellent pdfpages package
|
||||
(by Andreas Matthias) for pdfLaTeX. At present the utilities available are:
|
||||
|
||||
* pdfnup, which allows PDF files to be "n-upped" in roughly the way that psnup
|
||||
does for PostScript files.
|
||||
* pdfjoin, which concatenates the pages of multiple PDF files together into a
|
||||
single file
|
||||
* pdf90, which rotates the pages of one or more PDF files through 90 degrees
|
||||
(anti-clockwise).
|
||||
|
||||
- Paul Chvostek <paul+ports@it.ca>
|
||||
|
||||
WWW: http://www.warwick.ac.uk/go/pdfjam
|
Loading…
Reference in New Issue
Block a user