Update to 1.5.3.
Sponsored by: Absolight
This commit is contained in:
parent
944f9d514a
commit
301bcff8e2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=349143
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mirall
|
||||
PORTVERSION= 1.5.0
|
||||
PORTVERSION= 1.5.3
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= http://download.owncloud.com/desktop/stable/
|
||||
|
||||
@ -15,27 +15,27 @@ LIB_DEPENDS= libocsync.so:${PORTSDIR}/net/owncloud-csync \
|
||||
libinotify.so:${PORTSDIR}/devel/libinotify \
|
||||
libqtkeychain.so:${PORTSDIR}/security/qtkeychain
|
||||
|
||||
USES= cmake:outsource pkgconfig gmake compiler:c++11-lang
|
||||
USE_BZIP2=
|
||||
USES= cmake:outsource pkgconfig gmake compiler:c++11-lang tar:bzip2
|
||||
USE_QT4= corelib dbus gui linguist moc network qmake qtestlib rcc uic webkit xml
|
||||
CMAKE_ENV= CSYNC_DIR=${LOCALBASE} INOTIFY_LIB=${LOCALBASE}/lib
|
||||
CMAKE_ARGS= -DCSYNC_INCLUDE_PATH:STRING=${LOCALBASE}/include/ocsync/
|
||||
USE_LDCONFIG= yes
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
ALL_TARGET= all
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
|
||||
DOCS_USE= TEX=latex:build
|
||||
DOCS_CMAKE_ON= WITH_DOC=true
|
||||
DOCS_ALL_TARGET= doc-html doc-pdf
|
||||
|
||||
PLIST_SUB+= VERSION=${PORTVERSION}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
CMAKE_ARGS+= WITH_DOC=TRUE
|
||||
ALL_TARGET= all doc-html doc-pdf
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (mirall-1.5.0.tar.bz2) = 64532680da1c452b7b591550d07f25b554283ec65d448d41366ea2105b959a18
|
||||
SIZE (mirall-1.5.0.tar.bz2) = 1318514
|
||||
SHA256 (mirall-1.5.3.tar.bz2) = a50f235eba7a24915e583c3c5bb68ccd86171296151a9520f5a375842b3ced8e
|
||||
SIZE (mirall-1.5.3.tar.bz2) = 7841424
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- ./src/CMakeLists.txt.orig 2013-12-12 18:20:45.000000000 +0100
|
||||
+++ ./src/CMakeLists.txt 2014-01-09 19:53:06.000000000 +0100
|
||||
@@ -118,6 +118,7 @@
|
||||
set(libsync_SRCS ${libsync_SRCS} mirall/folderwatcher_inotify.cpp)
|
||||
set(libsync_HEADERS ${libsync_HEADERS} mirall/inotify.h)
|
||||
set(libsync_HEADERS ${libsync_HEADERS} mirall/folderwatcher_inotify.h)
|
||||
--- ./src/CMakeLists.txt.orig 2014-03-10 12:22:06.000000000 +0100
|
||||
+++ ./src/CMakeLists.txt 2014-03-18 17:12:29.000000000 +0100
|
||||
@@ -136,6 +136,7 @@
|
||||
IF( NOT WIN32 AND NOT APPLE )
|
||||
set(libsync_SRCS ${libsync_SRCS} mirall/folderwatcher_linux.cpp)
|
||||
set(libsync_HEADERS ${libsync_HEADERS} mirall/folderwatcher_linux.h)
|
||||
+ link_directories($ENV{INOTIFY_LIB})
|
||||
ENDIF()
|
||||
IF( WIN32 )
|
||||
|
11
deskutils/mirall/files/patch-src__mirall__folderwatcher.cpp
Normal file
11
deskutils/mirall/files/patch-src__mirall__folderwatcher.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./src/mirall/folderwatcher.cpp.orig 2014-03-10 12:22:06.000000000 +0100
|
||||
+++ ./src/mirall/folderwatcher.cpp 2014-03-24 14:18:20.000000000 +0100
|
||||
@@ -29,7 +29,7 @@
|
||||
#include "mirall/folderwatcher_win.h"
|
||||
#elif defined(Q_OS_MAC)
|
||||
#include "mirall/folderwatcher_mac.h"
|
||||
-#elif defined(Q_OS_LINUX)
|
||||
+#elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
|
||||
#include "mirall/folderwatcher_linux.h"
|
||||
#endif
|
||||
|
@ -21,13 +21,15 @@ lib/libowncloudsync.so.0
|
||||
lib/libowncloudsync.so.%%VERSION%%
|
||||
share/applications/owncloud.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/folderwizard_local.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/folderwizard_remote.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/icon.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/ignored_files_editor.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/menu.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/settings_account.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/settings_activity.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/settings_general.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/settings_network.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/sync_protocol.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/wizard_overview.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/wizard_targetfolder.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_images/wizard_url.png
|
||||
@ -35,6 +37,7 @@ share/applications/owncloud.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/accountsetup.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/advancedusage.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/architecture.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/autoupdate.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/building.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/conffile.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/glossary.txt
|
||||
@ -68,6 +71,7 @@ share/applications/owncloud.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/accountsetup.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/advancedusage.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/architecture.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/autoupdate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/building.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/conffile.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
|
||||
|
Loading…
Reference in New Issue
Block a user