Add xosd 0.7.0, X On-Screen-Display Library and XMMS plug-in.
PR: 27015 Submitted by: Hye-Shik Chang <perky@python.or.kr>
This commit is contained in:
parent
b3d3733eb1
commit
2ff756d78e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42778
@ -178,6 +178,7 @@
|
||||
SUBDIR += xenmenu
|
||||
SUBDIR += xgas
|
||||
SUBDIR += xless
|
||||
SUBDIR += xosd
|
||||
SUBDIR += xpns
|
||||
SUBDIR += xquote
|
||||
SUBDIR += xtail
|
||||
|
36
misc/xosd/Makefile
Normal file
36
misc/xosd/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# New ports collection makefile for: xosd
|
||||
# Date created: 2 May 2001
|
||||
# Whom: Hye-Shik Chang <perky@python.or.kr>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xosd
|
||||
PORTVERSION= 0.7.0
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.ignavus.net/ \
|
||||
http://www3.kr.freebsd.org/~perky/distfiles/
|
||||
|
||||
MAINTAINER= perky@python.or.kr
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
.if defined(WITH_XMMS)
|
||||
LIB_DEPENDS+= xmms.1:${PORTSDIR}/audio/xmms
|
||||
.endif
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MAKE_ENV= CFLAGS='${CFLAGS}' PREFIX='${PREFIX}'
|
||||
|
||||
MAN1= osd_cat.1
|
||||
MAN3= xosd.3
|
||||
|
||||
.if defined(WITH_XMMS)
|
||||
MAKE_ENV+= XMMS_PLUGINDIR=${X11BASE}/lib/xmms
|
||||
PLIST_SUB+= WITH_XMMS=""
|
||||
.else
|
||||
PLIST_SUB+= WITH_XMMS="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
misc/xosd/distinfo
Normal file
1
misc/xosd/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (xosd-0.7.0.tar.gz) = ff80b31ea3ee52e33855b9723642b8a6
|
62
misc/xosd/files/patch-aa
Normal file
62
misc/xosd/files/patch-aa
Normal file
@ -0,0 +1,62 @@
|
||||
diff -ruN Makefile.orig Makefile
|
||||
--- Makefile.orig Fri Mar 23 09:11:14 2001
|
||||
+++ Makefile Wed May 2 05:30:30 2001
|
||||
@@ -5,20 +5,18 @@
|
||||
LIBRARY_VERSION=0
|
||||
VERSION=0.7.0
|
||||
|
||||
-PREFIX=/usr/local
|
||||
EXEC_PREFIX=$(PREFIX)
|
||||
BINDIR=$(EXEC_PREFIX)/bin
|
||||
LIBDIR=$(EXEC_PREFIX)/lib
|
||||
MANDIR=$(PREFIX)/man
|
||||
INCLUDEDIR=$(PREFIX)/include
|
||||
-XMMS_PLUGINDIR=$(HOME)/.xmms
|
||||
|
||||
CC=gcc
|
||||
INSTALL=/usr/bin/install -c
|
||||
INSTALL_DATA=$(INSTALL) -m 644
|
||||
|
||||
-CFLAGS=-O2 -Wall -pipe -I. -DXOSD_VERSION=\"$(VERSION)\" -I/usr/X11R6/include
|
||||
-LDFLAGS=-L. -L/usr/X11R6/lib -lX11 -lXext -lpthread -lXt
|
||||
+CFLAGS+=-I. -DXOSD_VERSION=\"$(VERSION)\" -I/usr/X11R6/include -I/usr/local/include
|
||||
+LDFLAGS=-lc_r -L. -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -pthread -lXt -lgnugetopt
|
||||
|
||||
XOSDLIBS=-lxosd
|
||||
|
||||
@@ -66,9 +64,11 @@
|
||||
$(INSTALL) libxosd.so $(LIBDIR)/libxosd.so.$(LIBRARY_VERSION)
|
||||
rm -f $(PREFIX)/lib/libxosd.so
|
||||
ln -s $(PREFIX)/lib/libxosd.so.$(LIBRARY_VERSION) $(PREFIX)/lib/libxosd.so
|
||||
- mkdir -p $(XMMS_PLUGINDIR)/Plugins/General
|
||||
- rm -f $(XMMS_PLUGINDIR)/Plugins/General/libxmms_osd.so
|
||||
- cp -a libxmms_osd.so $(XMMS_PLUGINDIR)/Plugins/General
|
||||
+ if [ "$(XMMS_PLUGINDIR)" ]; then \
|
||||
+ mkdir -p $(XMMS_PLUGINDIR)/General; \
|
||||
+ rm -f $(XMMS_PLUGINDIR)/General/libxmms_osd.so; \
|
||||
+ cp -pf libxmms_osd.so $(XMMS_PLUGINDIR)/General; \
|
||||
+ fi
|
||||
$(INSTALL) osd_cat $(BINDIR)
|
||||
mkdir -p $(MANDIR)/man1 $(MANDIR)/man3
|
||||
$(INSTALL_DATA) osd_cat.1 $(MANDIR)/man1/
|
||||
diff -ruN xosd.c.orig xosd.c
|
||||
--- xosd.c.orig Fri Mar 23 08:55:45 2001
|
||||
+++ xosd.c Wed May 2 04:34:44 2001
|
||||
@@ -270,7 +270,7 @@
|
||||
if (!XCheckWindowEvent (osd->display, osd->window, ExposureMask, &report))
|
||||
{
|
||||
MUTEX_RELEASE ();
|
||||
- usleep (500);
|
||||
+ usleep (100000);
|
||||
continue;
|
||||
}
|
||||
MUTEX_RELEASE ();
|
||||
@@ -304,7 +304,7 @@
|
||||
|
||||
while (!osd->done)
|
||||
{
|
||||
- usleep (1000);
|
||||
+ usleep (200000);
|
||||
MUTEX_GET ();
|
||||
if (osd->timeout != -1 &&
|
||||
osd->mapped &&
|
1
misc/xosd/pkg-comment
Normal file
1
misc/xosd/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
X On-Screen-Display Library and XMMS plug-in
|
8
misc/xosd/pkg-descr
Normal file
8
misc/xosd/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
XOSD displays text on your screen, sounds simple right?
|
||||
The difference is it is unmanaged and shaped, so it appears
|
||||
transparent. This gives the effect of an On Screen Display,
|
||||
like your TV/VCR etc.. The package also includes an xmms
|
||||
plugin, which automatically displays various interesting
|
||||
things as they change (song name, volume etc...)
|
||||
|
||||
WWW: http://www.ignavus.net/software.html
|
4
misc/xosd/pkg-plist
Normal file
4
misc/xosd/pkg-plist
Normal file
@ -0,0 +1,4 @@
|
||||
bin/osd_cat
|
||||
lib/libxosd.so
|
||||
lib/libxosd.so.0
|
||||
%%WITH_XMMS%%lib/xmms/General/libxmms_osd.so
|
Loading…
Reference in New Issue
Block a user