Pass -fPIC when building the port's static libraries.

This makes it possible to use those libraries with shared libraries on at least
amd64.

While here, set LICENSE and drop MAKE_JOBS_UNSAFE.

PR:		209982
Submitted by:	Jason Bacon <bacon4000@gmail.com> (maintainer)
MFH:		2016Q4
This commit is contained in:
Raphael Kubo da Costa 2016-12-28 14:54:37 +00:00
parent efbb9aafac
commit 2fc2a89f33
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429778
4 changed files with 16 additions and 15 deletions

View File

@ -3,13 +3,14 @@
PORTNAME= nifticlib
PORTVERSION= 2.0.0
PORTREVISION= 1
CATEGORIES= science graphics
MASTER_SITES= SF/niftilib/nifticlib/nifticlib_2_0_0
MAINTAINER= bacon4000@gmail.com
COMMENT= Neuroimaging Informatics Technology Initiative data format
# LICENSE= public domain
LICENSE= PD
USES= gmake
@ -17,7 +18,7 @@ USES= gmake
# nifti bins by itself.
CONFLICTS= afni-[0-9]* dbh-[0-9]*
MAKE_JOBS_UNSAFE= yes
CFLAGS+= -fPIC
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2010-07-20 19:18:58.000000000 +0200
+++ Makefile 2014-02-20 23:32:52.000000000 +0100
@@ -17,21 +17,21 @@
--- Makefile.orig 2010-07-20 17:18:58 UTC
+++ Makefile
@@ -17,21 +17,21 @@ TARFILE_NAME = nifticlib-2.0.0
## Compiler defines
@ -17,7 +17,7 @@
+AR ?= ar
+RANLIB ?= ranlib
+DEPENDFLAGS ?= -MM
+GNU_ANSI_FLAGS ?= -Wall -ansi -pedantic
+GNU_ANSI_FLAGS ?= -ansi -pedantic
+ANSI_FLAGS += ${GNU_ANSI_FLAGS}
+CFLAGS += $(ANSI_FLAGS)
@ -34,7 +34,7 @@
## Installation
@@ -41,9 +41,9 @@
@@ -41,9 +41,9 @@ INSTALL_INC_DIR = include
## Zlib defines
@ -47,7 +47,7 @@
##############################################################
# platform specific redefines (to use, set ARCH appropriately)
@@ -116,33 +116,33 @@
@@ -116,33 +116,33 @@ clean_all: clean regress_clean_all insta
znz:
echo "arch is $(ARCH)"
@ -87,7 +87,7 @@
@echo Utility programs built.
@echo ""
@@ -152,7 +152,7 @@
@@ -152,7 +152,7 @@ doc:
@echo ""
regress_data:
@ -96,7 +96,7 @@
@echo ""
@echo Regression testing data installed.
@echo See Testing/README_regress for details.
@@ -167,25 +167,25 @@
@@ -167,25 +167,25 @@ $(INSTALL_INC_DIR):
$(INSTALL_LIB_DIR):
mkdir -p $@
@ -126,7 +126,7 @@
($(CP) $(FSLIO)/*.a $(INSTALL_LIB_DIR); $(CP) $(FSLIO)/*.h $(INSTALL_INC_DIR);)
$(RANLIB) $(INSTALL_LIB_DIR)/*.a
@echo " $(FSLIO) installed."
@@ -212,19 +212,19 @@
@@ -212,19 +212,19 @@ fslio_clean:
(cd $(FSLIO); $(RM) -f *.o *.a core; $(RM) -f depend.mk;)
examples_clean:

View File

@ -1,5 +1,5 @@
--- examples/Makefile.orig 2013-10-29 15:56:43.000000000 -0500
+++ examples/Makefile 2013-10-29 15:56:48.000000000 -0500
--- examples/Makefile.orig 2009-04-14 14:47:16 UTC
+++ examples/Makefile
@@ -1,4 +1,4 @@
-CC = gcc
+CC ?= gcc

View File

@ -1,5 +1,5 @@
--- utils/Makefile.orig 2007-05-17 15:18:44.000000000 -0500
+++ utils/Makefile 2013-10-29 15:55:12.000000000 -0500
--- utils/Makefile.orig 2007-05-17 20:18:44 UTC
+++ utils/Makefile
@@ -1,5 +1,5 @@
-CC = gcc
-CFLAGS = -ansi -pedantic