Unbreak on 4.x

PR:		ports/84406
Submitted by:	Ports Fury
This commit is contained in:
Renato Botelho 2005-08-01 12:50:02 +00:00
parent f911fb6aa5
commit 2fa12ea571
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140653
3 changed files with 19 additions and 21 deletions

View File

@ -19,29 +19,18 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_GNOME= gnomehack gnometarget intlhack pkgconfig
USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
LDFLAGS="-L${LOCALBASE}/lib" \
ac_cv_prog_DOC_TO_MAN=""
INSTALLS_SHLIB= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB= GETTEXT=""
.else
PLIST_SUB= GETTEXT="@comment "
.endif
.include <bsd.port.pre.mk>
.if (${OSVERSION} < 500000)
BROKEN= Doesn't build on < 5.x
.endif
post-configure:
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} -E 's|(SUBDIRS = data include src) po|\1|' \
${WRKSRC}/Makefile
CONFIGURE_ENV+= ac_cv_header_libintl_h=no
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,10 @@
--- src/pslib.c.orig Wed Jul 27 15:08:15 2005
+++ src/pslib.c Fri Jul 29 01:56:04 2005
@@ -29,6 +29,7 @@
#include <strings.h>
#include <time.h>
#include <math.h>
+#include <sys/types.h>
#include <sys/select.h>
#include <sys/stat.h>
#ifndef WIN32

View File

@ -6,8 +6,7 @@ lib/libps.a
lib/libps.so
lib/libps.so.2
libdata/pkgconfig/libps.pc
%%GETTEXT%%share/locale/de/LC_MESSAGES/pslib.mo
%%GETTEXT%%@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
%%NLS%%share/locale/de/LC_MESSAGES/pslib.mo
%%DATADIR%%/draft.ps
%%DATADIR%%/exectime.ps
%%DATADIR%%/grid.ps