math/mfem: Update 4.0 -> 4.1

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2020-03-11 15:58:53 +00:00
parent 71aeec5be2
commit 2fa0c9e8d4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=528234
4 changed files with 34 additions and 7 deletions

View File

@ -2,8 +2,7 @@
PORTNAME= mfem
DISTVERSIONPREFIX= v
DISTVERSION= 4.0
PORTREVISION= 1
DISTVERSION= 4.1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1558803243
SHA256 (mfem-mfem-v4.0_GH0.tar.gz) = 19797052fe65cc02b848366cf2366ff1fa348dbf7b7060f381ba84251ab11731
SIZE (mfem-mfem-v4.0_GH0.tar.gz) = 5364416
TIMESTAMP = 1583908718
SHA256 (mfem-mfem-v4.1_GH0.tar.gz) = 88cc7f1f8a0f3d050041ddaef8da09d1216e2c7d75a4c08c3aaad6a0565aa90e
SIZE (mfem-mfem-v4.1_GH0.tar.gz) = 8275547

View File

@ -0,0 +1,11 @@
--- general/zstr.hpp.orig 2020-03-11 15:50:47 UTC
+++ general/zstr.hpp
@@ -69,7 +69,7 @@ static std::string strerror()
{
buff = "Unknown error";
}
-#elif (_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE || defined(__APPLE__)
+#elif (_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE || defined(__APPLE__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
// XSI-compliant strerror_r()
if (strerror_r(errno, &buff[0], buff.size()) != 0)
{

View File

@ -6,6 +6,7 @@ include/mfem/fem/bilinearform.hpp
include/mfem/fem/bilinearform_ext.hpp
include/mfem/fem/bilininteg.hpp
include/mfem/fem/coefficient.hpp
include/mfem/fem/complex_fem.hpp
include/mfem/fem/conduitdatacollection.hpp
include/mfem/fem/datacollection.hpp
include/mfem/fem/eltrans.hpp
@ -16,17 +17,26 @@ include/mfem/fem/fem.hpp
include/mfem/fem/fespace.hpp
include/mfem/fem/geom.hpp
include/mfem/fem/gridfunc.hpp
include/mfem/fem/gslib.hpp
include/mfem/fem/hybridization.hpp
include/mfem/fem/intrules.hpp
include/mfem/fem/libceed/ceed.hpp
include/mfem/fem/libceed/diffusion.hpp
include/mfem/fem/libceed/mass.hpp
include/mfem/fem/linearform.hpp
include/mfem/fem/lininteg.hpp
include/mfem/fem/nonlinearform.hpp
include/mfem/fem/nonlinearform_ext.hpp
include/mfem/fem/nonlininteg.hpp
include/mfem/fem/pbilinearform.hpp
include/mfem/fem/pfespace.hpp
include/mfem/fem/pgridfunc.hpp
include/mfem/fem/plinearform.hpp
include/mfem/fem/pnonlinearform.hpp
include/mfem/fem/prestriction.hpp
include/mfem/fem/quadinterpolator.hpp
include/mfem/fem/quadinterpolator_face.hpp
include/mfem/fem/restriction.hpp
include/mfem/fem/sidredatacollection.hpp
include/mfem/fem/staticcond.hpp
include/mfem/fem/tbilinearform.hpp
@ -38,6 +48,7 @@ include/mfem/fem/tfe.hpp
include/mfem/fem/tfespace.hpp
include/mfem/fem/tintrules.hpp
include/mfem/fem/tmop.hpp
include/mfem/fem/tmop_tools.hpp
include/mfem/general/array.hpp
include/mfem/general/binaryio.hpp
include/mfem/general/communication.hpp
@ -46,8 +57,8 @@ include/mfem/general/device.hpp
include/mfem/general/error.hpp
include/mfem/general/forall.hpp
include/mfem/general/globals.hpp
include/mfem/general/gzstream.hpp
include/mfem/general/hash.hpp
include/mfem/general/hip.hpp
include/mfem/general/isockstream.hpp
include/mfem/general/mem_alloc.hpp
include/mfem/general/mem_manager.hpp
@ -63,16 +74,20 @@ include/mfem/general/tassign.hpp
include/mfem/general/text.hpp
include/mfem/general/tic_toc.hpp
include/mfem/general/version.hpp
include/mfem/general/zstr.hpp
include/mfem/linalg/blockmatrix.hpp
include/mfem/linalg/blockoperator.hpp
include/mfem/linalg/blockvector.hpp
include/mfem/linalg/complex_operator.hpp
include/mfem/linalg/densemat.hpp
include/mfem/linalg/dtensor.hpp
include/mfem/linalg/ginkgo.hpp
include/mfem/linalg/handle.hpp
include/mfem/linalg/hiop.hpp
include/mfem/linalg/hypre.hpp
include/mfem/linalg/hypre_parcsr.hpp
include/mfem/linalg/invariants.hpp
include/mfem/linalg/kernels.hpp
include/mfem/linalg/linalg.hpp
include/mfem/linalg/matrix.hpp
include/mfem/linalg/ode.hpp
@ -95,6 +110,7 @@ include/mfem/mesh/mesh_headers.hpp
include/mfem/mesh/mesh_operators.hpp
include/mfem/mesh/mesquite.hpp
include/mfem/mesh/ncmesh.hpp
include/mfem/mesh/ncmesh_tables.hpp
include/mfem/mesh/nurbs.hpp
include/mfem/mesh/pmesh.hpp
include/mfem/mesh/pncmesh.hpp
@ -106,6 +122,7 @@ include/mfem/mesh/tetrahedron.hpp
include/mfem/mesh/tmesh.hpp
include/mfem/mesh/triangle.hpp
include/mfem/mesh/vertex.hpp
include/mfem/mesh/vtk.hpp
include/mfem/mesh/wedge.hpp
include/mfem/mfem-performance.hpp
include/mfem/mfem.hpp
@ -114,6 +131,6 @@ lib/cmake/mfem/MFEMConfigVersion.cmake
lib/cmake/mfem/MFEMTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/mfem/MFEMTargets.cmake
lib/libmfem.so
lib/libmfem.so.4.0
lib/libmfem.so.4.1.0
%%DATADIR%%/config.mk
%%DATADIR%%/test.mk