sysutils/netevent: add new port

PR:		238993
Submitted by:	Greg V <greg@unrelenting.technology>
This commit is contained in:
Jan Beich 2019-07-05 19:08:08 +00:00
parent 9f8eeb670e
commit 2f675b417b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=505908
6 changed files with 62 additions and 0 deletions

View File

@ -727,6 +727,7 @@
SUBDIR += ncdu
SUBDIR += ndmpd
SUBDIR += neofetch
SUBDIR += netevent
SUBDIR += nfcutils
SUBDIR += nfsping
SUBDIR += nitrogen

View File

@ -0,0 +1,39 @@
# $FreeBSD$
PORTNAME= netevent
DISTVERSION= 0.2.1-79
DISTVERSIONSUFFIX= -g37c47a4
CATEGORIES= sysutils
MAINTAINER= greg@unrelenting.technology
COMMENT= Tool for sharing uinput devices with other machines
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
USES= compiler:c++14-lang gmake localbase
USE_GITHUB= yes
GH_ACCOUNT= Blub
HAS_CONFIGURE= yes
CPPFLAGS+= -D_WITH_GETLINE # XXX Remove after FreeBSD 11 EOL
OPTIONS_DEFINE= EXAMPLES MANPAGES
OPTIONS_DEFAULT= EXAMPLES MANPAGES
OPTIONS_SUB= MANPAGES
MANPAGES_BUILD_DEPENDS= rst2man:textproc/py-docutils
MANPAGES_CONFIGURE_OFF= --disable-doc
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
do-install-MANPAGES-on:
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/simple.ne2 ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1562264080
SHA256 (Blub-netevent-0.2.1-79-g37c47a4_GH0.tar.gz) = 251c03781e289a940907990c1afb170cb8c80c1f36e7f8fc918662fa2fa25b18
SIZE (Blub-netevent-0.2.1-79-g37c47a4_GH0.tar.gz) = 38725

View File

@ -0,0 +1,11 @@
--- Makefile.orig 2018-12-07 15:42:58 UTC
+++ Makefile
@@ -8,7 +8,7 @@ MANDIR = $(DATAROOTDIR)/man
MAN1DIR = $(MANDIR)/man1
CPPFLAGS ?= -g
-CPPFLAGS += -Wall -Werror -Wno-unknown-pragmas
+CPPFLAGS += -Wall -Wno-unknown-pragmas
CXX ?= clang++
# Code should compile with c++11 as well, but c++14 may have stricter
# attributes on some methods.

View File

@ -0,0 +1,5 @@
Netevent is a tool which can be used to share linux event devices with other
machines (either via /dev/uinput or by implementing a client for the same
protocol with other means).
WWW: https://github.com/Blub/netevent

View File

@ -0,0 +1,3 @@
bin/netevent
%%MANPAGES%%man/man1/netevent.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.ne2