- Fix build on 5.x (fix compiling with gcc 3.x). This fixes pkg-plist on 5.x.

- Provide really working fix for odbc driver.
- Remove locks/%%HOSTNAME%% from pkg-plist -- it is cleaned up in
pkg-deinstall.
- Bump PORTREVISION.
This commit is contained in:
Max Khon 2004-07-11 11:20:40 +00:00
parent 53eb6314b5
commit 2f18811c6d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113390
18 changed files with 270 additions and 24 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= grass
PORTVERSION= 5.0.2
PORTREVISION= 2
PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= http://grass.itc.it/grass50/source/ \
@ -46,6 +46,7 @@ USE_PERL5= yes
USE_BISON= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 213
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-libs=${LOCALBASE}/lib \
--with-tcltk-includes="${LOCALBASE}/include/tcl8.3 \
@ -59,18 +60,13 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-lapack \
--with-nls \
--without-motif
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS}
HOSTNAME!= hostname
PLIST_SUB= HOSTNAME="${HOSTNAME}"
post-patch:
@${REINPLACE_CMD} -e 's,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},' \
-e 's,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},' ${WRKSRC}/configure.in
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502000
BROKEN= "Broken pkg-plist"
.endif
post-install:
-(cd ${PREFIX} && ${GREP} -v "@" ${PLIST} | \
${XARGS} ${STRIP_CMD} 2> /dev/null || ${TRUE})

View File

@ -1,5 +1,5 @@
--- configure.in.orig Sun Mar 16 07:25:19 2003
+++ configure.in Mon Mar 22 13:35:29 2004
--- configure.in.orig Sun Mar 16 18:25:19 2003
+++ configure.in Sun Jul 11 17:55:03 2004
@@ -295,7 +295,7 @@
AC_MSG_ERROR([*** You must supply a directory list to --with-libs.])
;;
@ -27,6 +27,17 @@
LOC_CHECK_LIBS(GLU,gluBeginCurve,GLU,$OPENGL_LIB_PATH,OPENGLULIB,$OPENGLLIB $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $MATHLIB,,,-lstdc++)
@@ -862,8 +862,8 @@
LOC_CHECK_USE(odbc,ODBC,USE_ODBC)
-ODBCINC=
-ODBCLIB=
+ODBCINC=%%PTHREAD_CFLAGS%%
+ODBCLIB=%%PTHREAD_LIBS%%
if test -n "$USE_ODBC"; then
@@ -1054,7 +1054,7 @@
LOC_CHECK_INC_PATH(freetype,FreeType,FTINC)

View File

@ -0,0 +1,11 @@
--- src/misc/m.kappa/cmd/prt_hdr.c.orig Sun Jul 11 17:16:19 2004
+++ src/misc/m.kappa/cmd/prt_hdr.c Sun Jul 11 17:16:32 2004
@@ -10,7 +10,7 @@
if ((fd = fopen(output, "w")) == NULL) {
fprintf (stderr,
"ERROR: can't open <%s> to write header information\n", output);
- exit();
+ exit(1);
}
fprintf (fd, "\n\t\t%s\n", title);

View File

@ -0,0 +1,11 @@
--- src/misc/m.kappa/cmd/readin_data.c.orig Sun Jul 11 17:29:10 2004
+++ src/misc/m.kappa/cmd/readin_data.c Sun Jul 11 17:29:20 2004
@@ -10,7 +10,7 @@
else
if ((fd = fopen (input, "r")) == NULL) {
fprintf (stderr, "ERROR: can't open <%s> to read in data\n", input);
- exit();
+ exit(1);
}
/* read in data from the input file or stdin */

View File

@ -0,0 +1,20 @@
--- src/raster/r.in.doq/cmd/get_newhead.c.orig Sun Jul 11 17:17:15 2004
+++ src/raster/r.in.doq/cmd/get_newhead.c Sun Jul 11 17:17:26 2004
@@ -44,7 +44,7 @@
/*** Check data ordering ******/
if (strstr(buf,"LEFT_RIGHT/TOP_BOTTOM") == NULL) {
fprintf(stderr,"Unable to handle this data ordering: %s\n",buf);
- exit();
+ exit(1);
}
}
else if (strstr(buf,"SAMPLES_AND_LINES") != NULL) {
@@ -63,7 +63,7 @@
/*********** Get # bands now handlws one ***************/
if (strstr(buf,"BLACK&WHITE") == NULL) {
fprintf(stderr,"There are multiple bands in this image.\n This routine presently handles only one\n");
- exit();
+ exit(1);
}
}
else if (strstr(buf,"HORIZONTAL_DATUM") != NULL) {

View File

@ -0,0 +1,11 @@
--- src/raster/wildfire/src/r.ros/spot_dist.c.orig Sun Jul 11 17:41:42 2004
+++ src/raster/wildfire/src/r.ros/spot_dist.c Sun Jul 11 17:42:04 2004
@@ -119,7 +119,7 @@
if (DATA(map_elev,row,col) > z) {
#ifdef DEBUG
-printf ("\nA return: m%d U=%d(m/h) h0=%d(m) e0(%d,%d)=%d z=%d(m) e(%d,%d)=%d
+printf ("\nA return: m%d U=%d(m/h) h0=%d(m) e0(%d,%d)=%d z=%d(m) e(%d,%d)=%d\
s=%d(m)", (int)fuel, (int)U, (int)h0, row0,col0,DATA(map_elev,row0,col0),
(int)z, row,col,DATA(map_elev,row,col), S);
#endif

View File

@ -0,0 +1,40 @@
--- src.garden/grass.postgresql/g.column.pg/main.c.orig Sun Jul 11 17:18:12 2004
+++ src.garden/grass.postgresql/g.column.pg/main.c Sun Jul 11 17:19:04 2004
@@ -80,24 +80,24 @@
/* Postgres 6.x style */
if (flag->answer) {
- sprintf(SQL, "SELECT a.attname as ColumnName, t.typname as Type,
- a.attlen as Length,
- a.atttypmod as \"Mod_Length\"
- FROM pg_class c, pg_attribute a, pg_type t
- WHERE c.relname = '%s'
- and a.attnum > 0
- and a.attrelid = c.oid
- and a.atttypid = t.oid
+ sprintf(SQL, "SELECT a.attname as ColumnName, t.typname as Type,\
+ a.attlen as Length,\
+ a.atttypmod as \"Mod_Length\"\
+ FROM pg_class c, pg_attribute a, pg_type t\
+ WHERE c.relname = '%s'\
+ and a.attnum > 0\
+ and a.attrelid = c.oid\
+ and a.atttypid = t.oid\
order by attnum", tbl->answer );
}
else {
/* no column descriptions */
- sprintf(SQL, "SELECT a.attname as ColumnName
- FROM pg_class c, pg_attribute a
- WHERE c.relname = '%s'
- and a.attnum > 0
- and a.attrelid = c.oid
+ sprintf(SQL, "SELECT a.attname as ColumnName\
+ FROM pg_class c, pg_attribute a\
+ WHERE c.relname = '%s'\
+ and a.attnum > 0\
+ and a.attrelid = c.oid\
order by attnum", tbl->answer );
}

View File

@ -0,0 +1,24 @@
--- src.garden/grass.postgresql/g.stats.pg/infxStats.c.orig Sun Jul 11 17:20:22 2004
+++ src.garden/grass.postgresql/g.stats.pg/infxStats.c Sun Jul 11 17:20:41 2004
@@ -37,7 +37,7 @@
}
if (freq ) {
- sprintf (SQL_stmt,"SELECT count(*) as count, %s from %s %s
+ sprintf (SQL_stmt,"SELECT count(*) as count, %s from %s %s\
group by %s order by count(*)"
,col,tab,wherecl,col); }
else
@@ -48,10 +48,10 @@
PQclear (res);
if ( can_avg_col ) {
- sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max, avg(%s) as Mean
+ sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max, avg(%s) as Mean\
FROM %s %s",col,col,col,tab,wherecl); }
else
- {sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max
+ {sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max\
FROM %s %s",col,col,tab,wherecl); }
}

View File

@ -4460,7 +4460,6 @@ grass5/txt/WEIGHT/syntax
@dirrm grass5/man/man1
@dirrm grass5/man/help
@dirrm grass5/man
@dirrm grass5/locks/%%HOSTNAME%%
@dirrm grass5/locks
@dirrm grass5/locale/ru/LC_MESSAGES
@dirrm grass5/locale/ru

View File

@ -7,7 +7,7 @@
PORTNAME= grass
PORTVERSION= 5.0.2
PORTREVISION= 2
PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= http://grass.itc.it/grass50/source/ \
@ -46,6 +46,7 @@ USE_PERL5= yes
USE_BISON= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 213
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-libs=${LOCALBASE}/lib \
--with-tcltk-includes="${LOCALBASE}/include/tcl8.3 \
@ -59,18 +60,13 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-lapack \
--with-nls \
--without-motif
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS}
HOSTNAME!= hostname
PLIST_SUB= HOSTNAME="${HOSTNAME}"
post-patch:
@${REINPLACE_CMD} -e 's,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},' \
-e 's,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},' ${WRKSRC}/configure.in
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502000
BROKEN= "Broken pkg-plist"
.endif
post-install:
-(cd ${PREFIX} && ${GREP} -v "@" ${PLIST} | \
${XARGS} ${STRIP_CMD} 2> /dev/null || ${TRUE})

View File

@ -1,5 +1,5 @@
--- configure.in.orig Sun Mar 16 07:25:19 2003
+++ configure.in Mon Mar 22 13:35:29 2004
--- configure.in.orig Sun Mar 16 18:25:19 2003
+++ configure.in Sun Jul 11 17:55:03 2004
@@ -295,7 +295,7 @@
AC_MSG_ERROR([*** You must supply a directory list to --with-libs.])
;;
@ -27,6 +27,17 @@
LOC_CHECK_LIBS(GLU,gluBeginCurve,GLU,$OPENGL_LIB_PATH,OPENGLULIB,$OPENGLLIB $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $MATHLIB,,,-lstdc++)
@@ -862,8 +862,8 @@
LOC_CHECK_USE(odbc,ODBC,USE_ODBC)
-ODBCINC=
-ODBCLIB=
+ODBCINC=%%PTHREAD_CFLAGS%%
+ODBCLIB=%%PTHREAD_LIBS%%
if test -n "$USE_ODBC"; then
@@ -1054,7 +1054,7 @@
LOC_CHECK_INC_PATH(freetype,FreeType,FTINC)

View File

@ -0,0 +1,11 @@
--- src/misc/m.kappa/cmd/prt_hdr.c.orig Sun Jul 11 17:16:19 2004
+++ src/misc/m.kappa/cmd/prt_hdr.c Sun Jul 11 17:16:32 2004
@@ -10,7 +10,7 @@
if ((fd = fopen(output, "w")) == NULL) {
fprintf (stderr,
"ERROR: can't open <%s> to write header information\n", output);
- exit();
+ exit(1);
}
fprintf (fd, "\n\t\t%s\n", title);

View File

@ -0,0 +1,11 @@
--- src/misc/m.kappa/cmd/readin_data.c.orig Sun Jul 11 17:29:10 2004
+++ src/misc/m.kappa/cmd/readin_data.c Sun Jul 11 17:29:20 2004
@@ -10,7 +10,7 @@
else
if ((fd = fopen (input, "r")) == NULL) {
fprintf (stderr, "ERROR: can't open <%s> to read in data\n", input);
- exit();
+ exit(1);
}
/* read in data from the input file or stdin */

View File

@ -0,0 +1,20 @@
--- src/raster/r.in.doq/cmd/get_newhead.c.orig Sun Jul 11 17:17:15 2004
+++ src/raster/r.in.doq/cmd/get_newhead.c Sun Jul 11 17:17:26 2004
@@ -44,7 +44,7 @@
/*** Check data ordering ******/
if (strstr(buf,"LEFT_RIGHT/TOP_BOTTOM") == NULL) {
fprintf(stderr,"Unable to handle this data ordering: %s\n",buf);
- exit();
+ exit(1);
}
}
else if (strstr(buf,"SAMPLES_AND_LINES") != NULL) {
@@ -63,7 +63,7 @@
/*********** Get # bands now handlws one ***************/
if (strstr(buf,"BLACK&WHITE") == NULL) {
fprintf(stderr,"There are multiple bands in this image.\n This routine presently handles only one\n");
- exit();
+ exit(1);
}
}
else if (strstr(buf,"HORIZONTAL_DATUM") != NULL) {

View File

@ -0,0 +1,11 @@
--- src/raster/wildfire/src/r.ros/spot_dist.c.orig Sun Jul 11 17:41:42 2004
+++ src/raster/wildfire/src/r.ros/spot_dist.c Sun Jul 11 17:42:04 2004
@@ -119,7 +119,7 @@
if (DATA(map_elev,row,col) > z) {
#ifdef DEBUG
-printf ("\nA return: m%d U=%d(m/h) h0=%d(m) e0(%d,%d)=%d z=%d(m) e(%d,%d)=%d
+printf ("\nA return: m%d U=%d(m/h) h0=%d(m) e0(%d,%d)=%d z=%d(m) e(%d,%d)=%d\
s=%d(m)", (int)fuel, (int)U, (int)h0, row0,col0,DATA(map_elev,row0,col0),
(int)z, row,col,DATA(map_elev,row,col), S);
#endif

View File

@ -0,0 +1,40 @@
--- src.garden/grass.postgresql/g.column.pg/main.c.orig Sun Jul 11 17:18:12 2004
+++ src.garden/grass.postgresql/g.column.pg/main.c Sun Jul 11 17:19:04 2004
@@ -80,24 +80,24 @@
/* Postgres 6.x style */
if (flag->answer) {
- sprintf(SQL, "SELECT a.attname as ColumnName, t.typname as Type,
- a.attlen as Length,
- a.atttypmod as \"Mod_Length\"
- FROM pg_class c, pg_attribute a, pg_type t
- WHERE c.relname = '%s'
- and a.attnum > 0
- and a.attrelid = c.oid
- and a.atttypid = t.oid
+ sprintf(SQL, "SELECT a.attname as ColumnName, t.typname as Type,\
+ a.attlen as Length,\
+ a.atttypmod as \"Mod_Length\"\
+ FROM pg_class c, pg_attribute a, pg_type t\
+ WHERE c.relname = '%s'\
+ and a.attnum > 0\
+ and a.attrelid = c.oid\
+ and a.atttypid = t.oid\
order by attnum", tbl->answer );
}
else {
/* no column descriptions */
- sprintf(SQL, "SELECT a.attname as ColumnName
- FROM pg_class c, pg_attribute a
- WHERE c.relname = '%s'
- and a.attnum > 0
- and a.attrelid = c.oid
+ sprintf(SQL, "SELECT a.attname as ColumnName\
+ FROM pg_class c, pg_attribute a\
+ WHERE c.relname = '%s'\
+ and a.attnum > 0\
+ and a.attrelid = c.oid\
order by attnum", tbl->answer );
}

View File

@ -0,0 +1,24 @@
--- src.garden/grass.postgresql/g.stats.pg/infxStats.c.orig Sun Jul 11 17:20:22 2004
+++ src.garden/grass.postgresql/g.stats.pg/infxStats.c Sun Jul 11 17:20:41 2004
@@ -37,7 +37,7 @@
}
if (freq ) {
- sprintf (SQL_stmt,"SELECT count(*) as count, %s from %s %s
+ sprintf (SQL_stmt,"SELECT count(*) as count, %s from %s %s\
group by %s order by count(*)"
,col,tab,wherecl,col); }
else
@@ -48,10 +48,10 @@
PQclear (res);
if ( can_avg_col ) {
- sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max, avg(%s) as Mean
+ sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max, avg(%s) as Mean\
FROM %s %s",col,col,col,tab,wherecl); }
else
- {sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max
+ {sprintf (SQL_stmt,"SELECT min(%s) as Min, max(%s) as Max\
FROM %s %s",col,col,tab,wherecl); }
}

View File

@ -4460,7 +4460,6 @@ grass5/txt/WEIGHT/syntax
@dirrm grass5/man/man1
@dirrm grass5/man/help
@dirrm grass5/man
@dirrm grass5/locks/%%HOSTNAME%%
@dirrm grass5/locks
@dirrm grass5/locale/ru/LC_MESSAGES
@dirrm grass5/locale/ru