- "R'n'D jue" is an alternative version of Rocks'n'Diamonds, developed in

cooperation with R&D author Holger Schemel.

  In contrast to the "rnd_jue -contribution package"
  (still available on Download page) it is a separate and independent program
  with the same source code as the original R'n'D but with a
  completely different appearance.

  This is based on the wide customizing features which have been developed
  recently while all the integrated games have been produced with the R'n'D
  Level Editor, which is actually a great "game creation tool" for
  non-programmers. So far "R'n'D jue" is also an example for what is possible
  with the old Rocks'n'Diamonds and should be an inspiration for potential
  level designers and game developers.

  Regarding the games and levels "R'n'D jue" is intended for players who have both
  an eye for an attractive design and a bent especially for "puzzle games".
  The user will also find "action" and many opportunities to test his
  manual-skill - nevertheless, the main feature of "R'n'D jue" is primarily
  to offer some (moderate) challenges for the brain.

  WWW: http://www.jb-line.de/rnd/rnd_start_e.html
  WWW: http://www.artsoft.org/rocksndiamonds/

Submitted by:	nemysis <nemysis@gmx.ch>
This commit is contained in:
Beech Rintoul 2013-03-22 22:31:57 +00:00
parent 16e2f012ba
commit 2ed2a30779
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=314971
7 changed files with 3612 additions and 0 deletions

View File

@ -797,6 +797,7 @@
SUBDIR += rfksay
SUBDIR += rftg
SUBDIR += ri-li
SUBDIR += rnd_jue
SUBDIR += robocode
SUBDIR += robotfindskitten
SUBDIR += rockdodger

104
games/rnd_jue/Makefile Normal file
View File

@ -0,0 +1,104 @@
# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= rnd_jue
PORTVERSION= 3.3.0.0
CATEGORIES= games
MASTER_SITES= http://www.jb-line.de/rnd/ \
http://www.artsoft.org/RELEASES/unix/rocksndiamonds/ \
SF/rocksndiamonds.mirror/:rocksndiamonds \
http://www.bd-fans.com/Files/RnD/Levels/:bd_fans_levels \
SF/nemysisfreebsdp/rocksndiamonds/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
rocksndiamonds-3.3.0.1.tar.gz:rocksndiamonds \
Walpurgis_Collection.zip:bd_fans_levels \
rnd_the_h_world.zip:bd_fans_levels \
${PORTNAME}_icons.tar.gz:icons
DIST_SUBDIR= rocksndiamonds
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
rocksndiamonds-3.3.0.1.tar.gz \
${PORTNAME}_icons.tar.gz
MAINTAINER= nemysis@gmx.ch
COMMENT= Colorful Boulderdash'n'Emerald Mine'n'Sokoban'n'Stuff jue
LICENSE= GPLv2
LIB_DEPENDS+= smpeg:${PORTSDIR}/multimedia/smpeg
EXTRACT_DEPENDS+=${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
USE_SDL= image mixer net sdl
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" MAKE="${GMAKE}" OPTIONS="${CFLAGS}" \
RO_GAME_DIR="${DATADIR}" \
X11_PATH="${LOCALBASE}"
ALL_TARGET= sdl
MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
DOC_FILES1= CREDITS ChangeLog
DOCSRCDIR2= ${WRKSRC}/docs/elements
DOCSDIR2= ${DOCSDIR}/docs/elements
DOC_FILES2= *.txt
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
DESKTOP_ENTRIES="R'n'D jue" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
.include <bsd.port.options.mk>
post-extract-script:
@(cd ${WRKDIR}/rocksndiamonds* && ${COPYTREE_SHARE} levels ${WRKSRC})
.for l in Walpurgis_Collection.zip rnd_the_h_world.zip
@${UNZIP_CMD} -qo -d ${WRKSRC}/levels ${_DISTDIR}/${l}
.endfor
@(cd ${WRKSRC}/levels/"Walpurgis Collection" && \
${RM} -fr "Walpurgis Gardens" "Walpurgis World")
@(cd ${WRKSRC}/levels/rnd_the_h_world && ${RM} -fr hwld_dceos)
@${RM} -f ${WRKDIR}/${PORTNAME}/Readme.txt
@${RM} -f ${WRKSRC}/levels/Readme.txt
post-patch:
@${REINPLACE_CMD} \
-e 's|sdl-config|$${SDL_CONFIG}|g' ${WRKSRC}/src/Makefile
@${REINPLACE_CMD} \
-e 's|machine/soundcard.h|sys/soundcard.h|' ${WRKSRC}/src/libgame/sound.c
@${REINPLACE_CMD} \
-e 's|machine/joystick.h|sys/joystick.h|' ${WRKSRC}/src/libgame/joystick.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.for dir in graphics levels music sounds
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DATADIR})
.endfor
post-install:
.for s in ${ICON_SIZES}
${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
@${MKDIR} ${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
.endif
@${ECHO} "@unexec ${RMDIR} \"${DATADIR}/levels\" 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO} "@unexec ${RMDIR} \"${DATADIR}\" 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
.include <bsd.port.mk>

10
games/rnd_jue/distinfo Normal file
View File

@ -0,0 +1,10 @@
SHA256 (rocksndiamonds/rnd_jue-3.3.0.0.tar.gz) = 9594656bab084fea2ecf104e48c4dea3ccd8153f86a6ddbab04cdd0d5f6899a6
SIZE (rocksndiamonds/rnd_jue-3.3.0.0.tar.gz) = 35414851
SHA256 (rocksndiamonds/rocksndiamonds-3.3.0.1.tar.gz) = 974897f14136ecec91c7bdded8d904d74f2064a6c8a6c6c83f2f7111108747d3
SIZE (rocksndiamonds/rocksndiamonds-3.3.0.1.tar.gz) = 2494558
SHA256 (rocksndiamonds/Walpurgis_Collection.zip) = bf7749b8d5f943ac747847d30596b0f97e04deb14bb9e4b2b8de723880771a91
SIZE (rocksndiamonds/Walpurgis_Collection.zip) = 1068254
SHA256 (rocksndiamonds/rnd_the_h_world.zip) = 97fcd192b500ce091c7aae1a02a56dc55789281d67adccde1f4986b9d0673709
SIZE (rocksndiamonds/rnd_the_h_world.zip) = 96712
SHA256 (rocksndiamonds/rnd_jue_icons.tar.gz) = 2f69b2c7ef1009356e190f623b646249175f6baf79b9e733b4fd2ac74618d803
SIZE (rocksndiamonds/rnd_jue_icons.tar.gz) = 23040

View File

@ -0,0 +1,18 @@
--- src/game_em/sound.c.orig 2007-04-25 23:37:09.000000000 +0200
+++ src/game_em/sound.c 2012-12-12 02:10:57.000000000 +0100
@@ -10,15 +10,8 @@
#if defined(PLATFORM_LINUX) || defined(PLATFORM_BSD)
-#ifdef PLATFORM_LINUX
#include <sys/ioctl.h>
#include <sys/soundcard.h>
-#endif
-
-#ifdef PLATFORM_BSD
-#include <ioctl.h>
-#include <soundcard.h>
-#endif
static char audioname[] = "/dev/audio";

View File

@ -0,0 +1,11 @@
===============================================================================
R'n'D jue has been installed.
R'n'D jue can use some Rocks'n'Diamonds levels.
You can install Port Rocks'n'Diamonds data 'games/rocksndiamonds-data'.
Rocks'n'Diamonds data can use Rocks'n'Diamonds and R'n'D jue.
===============================================================================

23
games/rnd_jue/pkg-descr Normal file
View File

@ -0,0 +1,23 @@
"R'n'D jue" is an alternative version of Rocks'n'Diamonds, developed in
cooperation with R&D author Holger Schemel.
In contrast to the "rnd_jue -contribution package"
(still available on Download page) it is a separate and independent program
with the same source code as the original R'n'D but with a
completely different appearance.
This is based on the wide customizing features which have been developed
recently while all the integrated games have been produced with the R'n'D
Level Editor, which is actually a great "game creation tool" for
non-programmers. So far "R'n'D jue" is also an example for what is possible
with the old Rocks'n'Diamonds and should be an inspiration for potential
level designers and game developers.
Regarding the games and levels "R'n'D jue" is intended for players who have both
an eye for an attractive design and a bent especially for "puzzle games".
The user will also find "action" and many opportunities to test his
manual-skill - nevertheless, the main feature of "R'n'D jue" is primarily
to offer some (moderate) challenges for the brain.
WWW: http://www.jb-line.de/rnd/rnd_start_e.html
WWW: http://www.artsoft.org/rocksndiamonds/

3445
games/rnd_jue/pkg-plist Normal file

File diff suppressed because it is too large Load Diff