multimedia/libbdplus: Makefile cleanup
- Update MASTER_SITES - use ports framework instead of trying to work around it - make portlint happy PR: 250986 Submitted by: daniel.engberg.lists@pyret.net
This commit is contained in:
parent
9d4f3646ae
commit
2ebea84c24
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559842
@ -2,24 +2,24 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libbdplus
|
||||
PORTVERSION= 0.1.2
|
||||
DISTVERSION= 0.1.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/${PORTNAME}/${PORTVERSION}/ \
|
||||
http://blu.opsec.eu/
|
||||
MASTER_SITES= https://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= BD+ System research implementation
|
||||
|
||||
LICENSE= LGPL21
|
||||
|
||||
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
|
||||
LIB_DEPENDS= libaacs.so:multimedia/libaacs \
|
||||
libgcrypt.so:security/libgcrypt \
|
||||
libgpg-error.so:security/libgpg-error
|
||||
|
||||
USES= autoreconf libtool pkgconfig tar:bzip2
|
||||
USE_LDCONFIG= yes
|
||||
USES= autoreconf tar:bzip2 pkgconfig libtool
|
||||
|
||||
CONFIGURE_ARGS= --without-libaacs
|
||||
|
||||
.include "${.CURDIR}/../libbluray/Makefile.include"
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-optimizations
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
13
multimedia/libbdplus/files/patch-configure.ac
Normal file
13
multimedia/libbdplus/files/patch-configure.ac
Normal file
@ -0,0 +1,13 @@
|
||||
--- configure.ac.orig 2020-11-09 02:33:57 UTC
|
||||
+++ configure.ac
|
||||
@@ -168,10 +168,6 @@ CC_CHECK_CFLAGS_APPEND([-Wall -Wdisabled-optimization
|
||||
[-Wredundant-decls -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef ]dnl
|
||||
[-Wmissing-prototypes -Wshadow])
|
||||
|
||||
-CC_CHECK_CFLAGS_APPEND([-Werror=implicit-function-declaration ]dnl
|
||||
- [-Werror-implicit-function-declaration],
|
||||
- [break;])
|
||||
-
|
||||
CC_CHECK_WERROR
|
||||
AS_IF([test "x$enable_werror" = "xyes"], [
|
||||
CFLAGS="${CFLAGS} $cc_cv_werror"
|
Loading…
Reference in New Issue
Block a user