- STAGE-clean
- Add LICENSE - Fix compiler warnings
This commit is contained in:
parent
e4fb23b723
commit
2eb9bbf5a5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=344213
@ -7,22 +7,23 @@ CATEGORIES= x11-wm
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= gahr@FreeBSD.org
|
||||
COMMENT= A lightweight pager for netwm compatible window managers
|
||||
COMMENT= Lightweight pager for netwm compatible window managers
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
|
||||
|
||||
USES= gmake
|
||||
USE_XORG= x11 xext
|
||||
USE_GMAKE= yes
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|g; \
|
||||
s|%%CXX%%|${CXX}|g; \
|
||||
s|sed|gsed|g' ${WRKSRC}/Makefile
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
20
x11-wm/obpager/files/patch-src_OBPager.cc
Normal file
20
x11-wm/obpager/files/patch-src_OBPager.cc
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/OBPager.cc.orig 2014-02-14 15:35:01.000000000 +0100
|
||||
+++ src/OBPager.cc 2014-02-14 15:39:12.000000000 +0100
|
||||
@@ -159,7 +159,7 @@
|
||||
* @param displayName is the name of the display to connect to
|
||||
*/
|
||||
|
||||
-void OBPager::connectToXServer(char *displayName)
|
||||
+void OBPager::connectToXServer(const char *displayName)
|
||||
{
|
||||
// Connect to the user-specified desktop or whatever is in $DISPLAY?
|
||||
|
||||
@@ -301,7 +301,7 @@
|
||||
int maxHeight = height;
|
||||
int minWidth = width;
|
||||
int minHeight = height;
|
||||
- char* appName = APPLET_NAME;
|
||||
+ char appName[] = APPLET_NAME;
|
||||
unsigned long borderColour = BlackPixel(mDisplay(), mScreenNum);
|
||||
unsigned long backgroundColour = BlackPixel(mDisplay(), mScreenNum);
|
||||
|
11
x11-wm/obpager/files/patch-src_OBPager.h
Normal file
11
x11-wm/obpager/files/patch-src_OBPager.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/OBPager.h.orig 2014-02-14 15:36:36.000000000 +0100
|
||||
+++ src/OBPager.h 2014-02-14 15:37:08.000000000 +0100
|
||||
@@ -63,7 +63,7 @@
|
||||
~OBPager();
|
||||
|
||||
/// Connect to a specified X server display, or the default display
|
||||
- void connectToXServer(char *displayName = NULL);
|
||||
+ void connectToXServer(const char *displayName = NULL);
|
||||
|
||||
/// Create and show the X window
|
||||
void createShowWindow();
|
Loading…
Reference in New Issue
Block a user