- Update to 0.70

PR:             110250
Submited by:    Alex Kozlov<spam@rm-rf.kiev.ua>
Approved by:    maintainer
This commit is contained in:
Martin Wilke 2007-03-13 13:18:09 +00:00
parent 4a86e56b5f
commit 2ea4d5836c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=187309
5 changed files with 39 additions and 5 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= dosbox
PORTVERSION= 0.65
PORTREVISION= 1
PORTVERSION= 0.70
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -17,6 +16,7 @@ COMMENT= An emulator of a PC with DOS
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= autoconf:259 aclocal:19
GNU_CONFIGURE= yes
USE_SDL= sdl net

View File

@ -1,3 +1,3 @@
MD5 (dosbox-0.65.tar.gz) = fef84c292c3aeae747368b9875c1575a
SHA256 (dosbox-0.65.tar.gz) = 23fd001e2006f66ffdfe63adb6478ba85027f65b5078d6c69ad59e7f678d761f
SIZE (dosbox-0.65.tar.gz) = 848989
MD5 (dosbox-0.70.tar.gz) = ea0a936e88eb294038e67eeb0d7129c4
SHA256 (dosbox-0.70.tar.gz) = 05fdfd561eee33de12d978795b7f12338327c6da1ce65971463b58f2e90b48e4
SIZE (dosbox-0.70.tar.gz) = 934649

View File

@ -0,0 +1,12 @@
--- configure.in.orig
+++ configure.in
@@ -335,6 +335,9 @@
AC_DEFINE(OS2, 1, [Compiling on OS/2 EMX])
AC_DEFINE(C_DIRECTSERIAL, 1, [ Define to 1 if you want serial passthrough support (Win32, Posix and OS/2).])
;;
+ *-*-freebsd*)
+ AC_DEFINE(FREEBSD, 1, [Compiling on FREEBSD])
+ AC_DEFINE(C_DIRECTSERIAL, 1, [ Define to 1 if you want serial passthrough support (Win32, Posix and OS/2).])
esac
dnl Some stuff for the icon.

View File

@ -0,0 +1,11 @@
--- src/hardware/serialport/misc_util.cpp.orig
+++ src/hardware/serialport/misc_util.cpp
@@ -6,7 +6,7 @@
// C++ SDLnet wrapper
// Socket inheritance
-#if defined LINUX || defined OS2
+#if defined LINUX || defined OS2 || defined FREEBSD
#define CAPWORD (NETWRAPPER_TCP|NETWRAPPER_TCP_NATIVESOCKET)
#ifdef OS2
typedef int socklen_t;

View File

@ -0,0 +1,11 @@
--- src/hardware/serialport/misc_util.h.orig
+++ src/hardware/serialport/misc_util.h
@@ -6,7 +6,7 @@
#include "SDL_net.h"
#include "support.h"
-#if defined LINUX || defined OS2
+#if defined LINUX || defined OS2 || defined FREEBSD
#define NATIVESOCKETS
#elif defined WIN32