Update libtorrent to 0.10.0.

Noticed by:	Charles Clark <cmc@stegosaur.us>
This commit is contained in:
Florent Thoumie 2006-07-12 19:09:46 +00:00
parent 25d57ca90d
commit 2e69128559
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=167601
7 changed files with 49 additions and 5 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= libtorrent-devel
PORTVERSION= 0.9.3
PORTVERSION= 0.10.0
PORTREVISION= 0
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
@ -20,4 +20,6 @@ DESCR= ${MASTERDIR}/pkg-descr
CONFLICTS= libtorrent-[0-9]*
EXTRA_PATCHES= ${.CURDIR}/files/devel-*
.include "${MASTERDIR}/Makefile"

View File

@ -1,3 +1,3 @@
MD5 (libtorrent-0.9.3.tar.gz) = 438192530048c5ba67bbc2f9852c695c
SHA256 (libtorrent-0.9.3.tar.gz) = 1bbc9c417c1595b4ddd06b40af0e15f2ac7e146e7e148ec47af28121a7a90799
SIZE (libtorrent-0.9.3.tar.gz) = 463674
MD5 (libtorrent-0.10.0.tar.gz) = 240e90818c4c9c34474b2e1873d09910
SHA256 (libtorrent-0.10.0.tar.gz) = 47645632fee222609c139bddf50872949bd3359214976a25a92bbc1d277c70de
SIZE (libtorrent-0.10.0.tar.gz) = 447795

View File

@ -0,0 +1,23 @@
--- ltmain.sh.orig Wed Jul 12 10:35:32 2006
+++ ltmain.sh Wed Jul 12 10:36:46 2006
@@ -2279,10 +2279,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$ECHO "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
@@ -2896,6 +2898,7 @@
;;
-avoid-version)
+ build_old_libs=no
avoid_version=yes
continue
;;

View File

@ -0,0 +1,11 @@
--- src/utils/sha1.h.orig Wed Jul 12 11:35:43 2006
+++ src/utils/sha1.h Wed Jul 12 11:36:04 2006
@@ -87,7 +87,7 @@
Sha1::final_c(char* buffer) {
unsigned int len;
- SHA1_End(&m_ctx, buffer, &len, 20);
+ SHA1_End(&m_ctx, (unsigned char*)buffer, &len, 20);
}
#elif defined USE_OPENSSL_SHA

View File

@ -1,4 +1,8 @@
include/torrent/bitfield.h
include/torrent/block.h
include/torrent/block_list.h
include/torrent/block_transfer.h
include/torrent/common.h
include/torrent/connection_manager.h
include/torrent/download.h
include/torrent/event.h
@ -16,10 +20,12 @@ include/torrent/poll_epoll.h
include/torrent/poll_kqueue.h
include/torrent/poll_select.h
include/torrent/rate.h
include/torrent/resume.h
include/torrent/torrent.h
include/torrent/tracker.h
include/torrent/tracker_list.h
include/torrent/transfer_list.h
lib/libtorrent.so
lib/libtorrent.so.7
lib/libtorrent.so.8
libdata/pkgconfig/libtorrent.pc
@dirrm include/torrent

View File

@ -25,6 +25,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
EXTRA_PATCHES?= ${.CURDIR}/files/stable-*
.include <bsd.port.pre.mk>
CONFIGURE_ARGS= --disable-debug --with-openssl=${OPENSSLBASE}