3.0.1 -> 3.1:
Defeat stupid proxies that don't recognise no-cache Update configure.in (again) Fix some typos and other cosmetic stuff Integrate all port patches back into the main source archive
This commit is contained in:
parent
2c70234e9e
commit
2e53a3e889
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31389
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= httptunnel
|
||||
PORTVERSION= 3.0.1
|
||||
PORTVERSION= 3.1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.Awfulhak.org/httptunnel/ \
|
||||
ftp://ftp.nocrew.org/pub/nocrew/unix/ \
|
||||
|
@ -1 +1 @@
|
||||
MD5 (httptunnel-3.0.1.tar.gz) = a761d59a2c93b0fe66e102067ac3e366
|
||||
MD5 (httptunnel-3.1.tar.gz) = 3fd732aece11a59fee3d74ecb77f8910
|
||||
|
@ -1,40 +0,0 @@
|
||||
--- common.c.orig Wed Dec 15 06:39:03 1999
|
||||
+++ common.c Wed Jul 19 10:09:32 2000
|
||||
@@ -115,7 +115,7 @@
|
||||
#endif
|
||||
|
||||
int
|
||||
-server_socket (int port, int backlog)
|
||||
+server_socket (struct in_addr addr, int port, int backlog)
|
||||
{
|
||||
struct sockaddr_in address;
|
||||
int i, s;
|
||||
@@ -131,9 +131,13 @@
|
||||
strerror (errno));
|
||||
}
|
||||
|
||||
+ memset(&address, '\0', sizeof address);
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
+ address.sin_len = sizeof address;
|
||||
+#endif
|
||||
address.sin_family = PF_INET;
|
||||
address.sin_port = htons ((short)port);
|
||||
- address.sin_addr.s_addr = INADDR_ANY;
|
||||
+ address.sin_addr = addr;
|
||||
|
||||
if (bind (s, (struct sockaddr *)&address, sizeof (address)) == -1)
|
||||
{
|
||||
@@ -153,8 +157,12 @@
|
||||
int
|
||||
set_address (struct sockaddr_in *address, const char *host, int port)
|
||||
{
|
||||
+ memset(address, '\0', sizeof *address);
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
+ address->sin_len = sizeof *address;
|
||||
+#endif
|
||||
address->sin_family = PF_INET;
|
||||
- address->sin_port = htons ((short)port);
|
||||
+ address->sin_port = htons ((u_short)port);
|
||||
address->sin_addr.s_addr = inet_addr (host);
|
||||
|
||||
if (address->sin_addr.s_addr == INADDR_NONE)
|
@ -1,11 +0,0 @@
|
||||
--- common.h.orig Thu Mar 16 00:41:09 2000
|
||||
+++ common.h Thu Mar 16 00:42:56 2000
|
||||
@@ -58,7 +58,7 @@
|
||||
static inline void log_annoying () {}
|
||||
#endif
|
||||
|
||||
-extern int server_socket (int port, int backlog);
|
||||
+extern int server_socket (struct in_addr addr, int port, int backlog);
|
||||
extern int set_address (struct sockaddr_in *address,
|
||||
const char *host, int port);
|
||||
extern int open_device (char *device);
|
@ -1,14 +0,0 @@
|
||||
--- htc.c.orig Thu Mar 16 00:27:51 2000
|
||||
+++ htc.c Thu Mar 16 00:43:21 2000
|
||||
@@ -408,7 +408,10 @@
|
||||
|
||||
if (arg.forward_port != -1)
|
||||
{
|
||||
- s = server_socket (arg.forward_port, 0);
|
||||
+ struct in_addr addr;
|
||||
+
|
||||
+ addr.s_addr = INADDR_ANY;
|
||||
+ s = server_socket (addr, arg.forward_port, 0);
|
||||
log_debug ("server_socket (%d) = %d", arg.forward_port, s);
|
||||
if (s == -1)
|
||||
{
|
Loading…
Reference in New Issue
Block a user