- Update to 3.3.5

This commit is contained in:
Dmitry Marakasov 2015-03-17 03:08:12 +00:00
parent 79f65c38ca
commit 2e4bd19ab0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381461
5 changed files with 5 additions and 24 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= osg
PORTVERSION= 3.3.3
PORTVERSION= 3.3.5
CATEGORIES= graphics
MASTER_SITES= http://trac.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
@ -29,7 +29,7 @@ USE_XORG= x11
USE_LDCONFIG= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
OSG_SHLIBVER=115 \
OSG_SHLIBVER=117 \
OPENTHREADS_VERSION=3.3.0 \
OPENTHREADS_SHLIBVER=20

View File

@ -1,2 +1,2 @@
SHA256 (OpenSceneGraph-3.3.3.zip) = b81cda123ffb3bd108e0fe4be4fff1351d6636e6fb0a1475b2c4fb9618d3ae2b
SIZE (OpenSceneGraph-3.3.3.zip) = 8227832
SHA256 (OpenSceneGraph-3.3.5.zip) = aa7c3e30149752202c3b6f771e4a5bed80465807d732953813512f3f64045564
SIZE (OpenSceneGraph-3.3.5.zip) = 8263725

View File

@ -1,14 +1,5 @@
--- CMakeLists.txt.orig 2014-12-18 20:47:08.000000000 +0300
+++ CMakeLists.txt 2015-01-24 21:51:57.000000000 +0300
@@ -629,7 +629,7 @@
FIND_PACKAGE(LibVNCServer)
FIND_PACKAGE(OurDCMTK)
FIND_PACKAGE(FFmpeg)
- FIND_PACKAGE(GStreamer COMPONENTS gstreamer-app gstreamer-pbutils)
+ FIND_PACKAGE(GStreamer COMPONENTS app pbutils)
FIND_PACKAGE(GLIB COMPONENTS gobject)
FIND_PACKAGE(DirectShow)
FIND_PACKAGE(SDL2)
@@ -805,7 +805,7 @@
IF(UNIX AND NOT WIN32 AND NOT APPLE)

View File

@ -1,11 +0,0 @@
--- CMakeModules/FindGStreamer.cmake.orig 2014-12-18 12:03:15.000000000 +0300
+++ CMakeModules/FindGStreamer.cmake 2015-01-24 21:36:08.000000000 +0300
@@ -104,7 +104,7 @@
# 1.1. Find headers and libraries
FIND_GSTREAMER_COMPONENT(GSTREAMER gstreamer-1.0 gst/gst.h gstreamer-1.0)
-#FIND_GSTREAMER_COMPONENT(GSTREAMER_BASE gstreamer-base-1.0 gst/gst.h gstbase-1.0)
+FIND_GSTREAMER_COMPONENT(GSTREAMER_BASE gstreamer-base-1.0 gst/gst.h gstbase-1.0)
# 1.2. Check GStreamer version

View File

@ -264,6 +264,7 @@ include/osgDB/Archive
include/osgDB/AuthenticationMap
include/osgDB/Callbacks
include/osgDB/ClassInterface
include/osgDB/ConvertBase64
include/osgDB/ConvertUTF
include/osgDB/DataTypes
include/osgDB/DatabasePager