New port: acidlaunch
Acidlaunch is a small, light-weight dockable app launcher with a simple XML-based configuration syntax. It's great as a small, simple app launcher, and it can optionally run in a withdrawn mode for embedding in the BlackBox slit. Submitted by: Alexey Dokuchaev
This commit is contained in:
parent
04794365f7
commit
2e38362afb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=78810
@ -6,6 +6,7 @@
|
||||
SUBDIR += LPRngTool
|
||||
SUBDIR += Tee
|
||||
SUBDIR += abck
|
||||
SUBDIR += acidlaunch
|
||||
SUBDIR += afio
|
||||
SUBDIR += ah-tty
|
||||
SUBDIR += and
|
||||
|
31
sysutils/acidlaunch/Makefile
Normal file
31
sysutils/acidlaunch/Makefile
Normal file
@ -0,0 +1,31 @@
|
||||
# New ports collection makefile for: acidlaunch
|
||||
# Date created: 11 Apr 2003
|
||||
# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= acidlaunch
|
||||
PORTVERSION= 0.5
|
||||
CATEGORIES= sysutils windowmaker
|
||||
MASTER_SITES= http://linuxgamers.net/download/
|
||||
|
||||
MAINTAINER= danfe@regency.nsu.ru
|
||||
COMMENT= An application launcher with simple XML-based configuration syntax
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GNOME= gtk12 gdkpixbuf libxml2
|
||||
USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
|
||||
MAN1= ${PORTNAME}.1
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
|
||||
@${MKDIR} ${PREFIX}/share/${PORTNAME}
|
||||
.for file in config.xml default.png
|
||||
${INSTALL_DATA} ${WRKSRC}/prefs/${file} ${PREFIX}/share/${PORTNAME}
|
||||
.endfor
|
||||
@${INSTALL_MAN} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
1
sysutils/acidlaunch/distinfo
Normal file
1
sysutils/acidlaunch/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (acidlaunch-0.5.tar.gz) = 7c90e429d5883b9f109a52e024597fab
|
20
sysutils/acidlaunch/files/patch-configure
Normal file
20
sysutils/acidlaunch/files/patch-configure
Normal file
@ -0,0 +1,20 @@
|
||||
--- configure.orig Fri Feb 22 04:45:04 2002
|
||||
+++ configure Fri Apr 11 20:25:11 2003
|
||||
@@ -1044,7 +1044,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
-#include <xmlversion.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
|
||||
int
|
||||
main()
|
||||
@@ -1155,7 +1155,7 @@
|
||||
#line 1156 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
-#include <xmlversion.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
#include <stdio.h>
|
||||
|
||||
int main() {
|
11
sysutils/acidlaunch/files/patch-src::Makefile.in
Normal file
11
sysutils/acidlaunch/files/patch-src::Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/Makefile.in.orig Fri Apr 11 20:41:42 2003
|
||||
+++ src/Makefile.in Fri Apr 11 20:42:11 2003
|
||||
@@ -72,7 +72,7 @@
|
||||
XML_CONFIG = @XML_CONFIG@
|
||||
XML_LIBS = @XML_LIBS@
|
||||
|
||||
-CPPFLAGS = -DPREFIX=\"@prefix@\"
|
||||
+CPPFLAGS = -DPREFIX=\"${X11BASE}\"
|
||||
|
||||
bin_PROGRAMS = acidlaunch
|
||||
|
7
sysutils/acidlaunch/pkg-descr
Normal file
7
sysutils/acidlaunch/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
Acidlaunch is a small, light-weight dockable app launcher with a simple
|
||||
XML-based configuration syntax. It's written in C++ using gtk,
|
||||
gdk-pixbuf and libxml2. It's great as a small, simple app launcher, and
|
||||
it can optionally run in a withdrawn mode for embedding in the BlackBox
|
||||
slit.
|
||||
|
||||
WWW: http://linuxgamers.net/infoPage.php?page=acidlaunch
|
4
sysutils/acidlaunch/pkg-plist
Normal file
4
sysutils/acidlaunch/pkg-plist
Normal file
@ -0,0 +1,4 @@
|
||||
bin/acidlaunch
|
||||
share/acidlaunch/config.xml
|
||||
share/acidlaunch/default.png
|
||||
@dirrm share/acidlaunch
|
Loading…
Reference in New Issue
Block a user