- Convert to USES=libtool and add INSTALL_TARGET=install-strip
- Add USE_AUTOTOOLS=libtoolize (and others) because ltmain.sh is a symlink
This commit is contained in:
parent
7483085a9a
commit
2e34e125f2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=367603
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= panda
|
||||
PORTVERSION= 0.5.4
|
||||
PORTREVISION= 7
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= SF \
|
||||
SAVANNAH \
|
||||
@ -19,27 +19,20 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
|
||||
libpng15.so:${PORTSDIR}/graphics/png \
|
||||
libtiff.so:${PORTSDIR}/graphics/tiff
|
||||
|
||||
USES= pathfix pkgconfig gmake tar:bzip2
|
||||
USE_BDB= yes
|
||||
USE_AUTOTOOLS= libtool
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-berkeley-db
|
||||
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
|
||||
LIBS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= gmake libtool pathfix pkgconfig tar:bzip2
|
||||
PATHFIX_MAKEFILEIN= Makefile.am
|
||||
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
|
||||
AUTOMAKE_ARGS= -a -c -f
|
||||
USE_BDB= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include -DHAVE_LIBPNG ${PTHREAD_CFLAGS}
|
||||
LIBS+= -lpng
|
||||
LDFLAGS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
|
||||
post-extract:
|
||||
.for file in config.sub config.guess
|
||||
@${RM} ${WRKSRC}/config/${file} && ${TOUCH} ${WRKSRC}/config/${file}
|
||||
.endfor
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's| -lpanda| $$(top_srcdir)/libpanda.la|g' \
|
||||
${WRKSRC}/examples/Makefile.in
|
||||
${REINPLACE_CMD} -e 's,-ldb,-l${BDB_LIB_NAME},' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/man/panda_*.3 ${STAGEDIR}${MANPREFIX}/man/man3
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
|
26
print/panda/files/patch-configure.in
Normal file
26
print/panda/files/patch-configure.in
Normal file
@ -0,0 +1,26 @@
|
||||
--- configure.in.orig 2004-04-13 00:46:24 UTC
|
||||
+++ configure.in
|
||||
@@ -28,7 +28,7 @@
|
||||
dnl AC_CHECK_LIB(dmalloc, malloc)
|
||||
|
||||
dnl -lpng::
|
||||
-AC_CHECK_LIB(png, png_libpng_ver, CFLAGS="$CFLAGS -DHAVE_LIBPNG" LDFLAGS="$LDFLAGS -lpng" )
|
||||
+AC_CHECK_LIB(png, png_get_libpng_ver, CFLAGS="$CFLAGS -DHAVE_LIBPNG" LDFLAGS="$LDFLAGS -lpng" )
|
||||
|
||||
dnl -ltiff:
|
||||
AC_CHECK_LIB(tiff, TIFFOpen, CFLAGS="$CFLAGS -DHAVE_LIBTIFF" LDFLAGS="$LDFLAGS -ltiff")
|
||||
@@ -52,12 +52,12 @@
|
||||
if test "z$DATABASE" = "zedb"; then
|
||||
AC_CHECK_LIB(edb, e_db_open,
|
||||
[LDFLAGS="$LDFLAGS -ledb" DATABASE="edb" AC_DEFINE([USE_EDB], [], [Use Edb])],
|
||||
- [AC_MSG_RESULT([not found]),
|
||||
+ [AC_MSG_RESULT([not found])
|
||||
AC_MSG_ERROR([please reinstall the Edb distribution])])
|
||||
elif test "z$DATABASE" = "zdb"; then
|
||||
AC_CHECK_LIB(db, db_create,
|
||||
[LDFLAGS="$LDFLAGS -ldb" DATABASE="db" AC_DEFINE([USE_DB], [], [Use Berkeley DB])],
|
||||
- [AC_MSG_RESULT([not found]),
|
||||
+ [AC_MSG_RESULT([not found])
|
||||
AC_MSG_ERROR([please reinstall the Berkeley DB distribution])])
|
||||
fi
|
||||
fi
|
@ -3,9 +3,9 @@ include/panda/functions.h
|
||||
include/panda/legacy.h
|
||||
include/panda/objects.h
|
||||
lib/libpanda.a
|
||||
lib/libpanda.la
|
||||
lib/libpanda.so
|
||||
lib/libpanda.so.0
|
||||
lib/libpanda.so.0.0.0
|
||||
libdata/pkgconfig/panda.pc
|
||||
man/man3/panda_addchild.3.gz
|
||||
man/man3/panda_addcubiccurvesegment.3.gz
|
||||
|
Loading…
Reference in New Issue
Block a user