Remove expired ports:

2018-09-25 math/mtl: fails to fetch: mastersite times out
2018-09-25 dns/dnscrypt-proxy: Deprecated by upstream, use dns/dnscrypt-proxy2 instead
This commit is contained in:
Rene Ladan 2018-09-27 09:00:13 +00:00
parent baca2b933f
commit 2dfde0455b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=480793
21 changed files with 2 additions and 558 deletions

2
MOVED
View File

@ -10529,3 +10529,5 @@ www/py-searx|www/searx|2018-09-16|Move to a proper directory: this is a server,
net/syndication|net/kf5-syndication|2018-09-17|Has become a proper KDE framework
x11-wm/swm||2018-09-21|Has expired: upstream no longer maintained, the screen turns black after starting swm
graphics/OpenEXR|graphics/openexr|2018-09-22|Renamed to match upstream distribution's lower-case name
math/mtl||2018-09-27|Has expired: fails to fetch: mastersite times out
dns/dnscrypt-proxy|dns/dnscrypt-proxy2|2018-09-27|Has expired: Deprecated by upstream, use dns/dnscrypt-proxy2 instead

View File

@ -37,7 +37,6 @@
SUBDIR += dnscap
SUBDIR += dnscheck
SUBDIR += dnscheckengine
SUBDIR += dnscrypt-proxy
SUBDIR += dnscrypt-proxy2
SUBDIR += dnscrypt-wrapper
SUBDIR += dnsdbck

View File

@ -1,68 +0,0 @@
# Created by: Leo Vandewoestijne <freebsd@dns.company>
# $FreeBSD$
PORTNAME= dnscrypt-proxy
PORTVERSION= 1.9.5
PORTREVISION= 3
CATEGORIES= dns
MASTER_SITES= LOCAL/dbaio/${PORTNAME}/
MAINTAINER= freebsd@dns.company
COMMENT= Boost privacy and security of DNS
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Deprecated by upstream, use dns/dnscrypt-proxy2 instead
EXPIRATION_DATE= 2018-09-25
BROKEN_powerpc64= fails to compile: fpst.c: error: redefinition of typedef 'FPST'
LIB_DEPENDS= libsodium.so:security/libsodium
USES= gmake
USERS= _dnscrypt-proxy
GROUPS= _dnscrypt-proxy
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README* THANKS
CONFLICTS_INSTALL= dnscrypt-proxy2
OPTIONS_DEFINE= DOCS PLUGINS PLUGINS_RELAXED PLUGINS_ROOT
OPTIONS_SINGLE= RCWHICH
OPTIONS_SINGLE_RCWHICH= RCSINGLE RCMULTI
OPTIONS_DEFAULT= PLUGINS RCSINGLE
OPTIONS_SUB= yes
PLUGINS_RELAXED_DESC= Allow loading plugins owned by other users
PLUGINS_ROOT_DESC= Only load plugins sitting in the default plugins directory
RCWHICH_DESC= Rc script to use:
RCSINGLE_DESC= Use default rc script for single daemon
RCMULTI_DESC= Use experimental rc script for multiple instances
PLUGINS_CONFIGURE_ENABLE= plugins
PLUGINS_LIB_DEPENDS= libltdl.so:devel/libltdl \
libldns.so:dns/ldns
PLUGINS_USE= LDCONFIG=${PREFIX}/lib/dnscrypt-proxy
PLUGINS_USES= libtool
PLUGINS_RELAXED_CONFIGURE_ENABLE= relaxed-plugins-permissions
PLUGINS_ROOT_CONFIGURE_ENABLE= plugins-root
RCSINGLE_VARS= USE_RC_SUBR=${PORTNAME}
RCSINGLE_SUB_FILES= pkg-message
RCMULTI_VARS= USE_RC_SUBR=${PORTNAME}_multi
RCMULTI_SUB_FILES= pkg-message_multi
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/man/dnscrypt-proxy.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/man/hostip.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
${MV} ${STAGEDIR}${PREFIX}/etc/dnscrypt-proxy.conf ${STAGEDIR}${PREFIX}/etc/dnscrypt-proxy.conf.sample
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1499458817
SHA256 (dnscrypt-proxy-1.9.5.tar.gz) = 64021fabb7d5bab0baf681796d90ecd2095fb81381e6fb317a532039025a9399
SIZE (dnscrypt-proxy-1.9.5.tar.gz) = 1663954

View File

@ -1,52 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: dnscrypt_proxy
# REQUIRE: SERVERS cleanvar ldconfig
# BEFORE: named local_unbound unbound
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable dnscrypt-proxy:
#
# dnscrypt_proxy_enable (bool): Set to NO by default.
# Set to YES to enable dnscrypt-proxy.
# dnscrypt_proxy_conf (str): Unset by default. Will override all other
# settings and only use the config file.
# dnscrypt_proxy_uid (str): Set to "_dnscrypt-proxy" by default.
# User to switch to after starting.
# dnscrypt_proxy_resolver (str):Set to "random" by default.
# Better to select one of your own choice.
# dnscrypt_proxy_pidfile (str): default: "/var/run/dnscrypt-proxy.pid"
# Location of pid file.
# dnscrypt_proxy_logfile (str): default: "/var/log/dnscrypt-proxy.log"
# Location of log file.
#
# To redirect a local resolver through dnscrypt-proxy, point it at 127.0.0.2
# and add the following to rc.conf:
# ifconfig_lo0_alias0="inet 127.0.0.2 netmask 0xffffffff"
# dnscrypt_proxy_flags='-a 127.0.0.2'
. /etc/rc.subr
name=dnscrypt_proxy
rcvar=dnscrypt_proxy_enable
load_rc_config ${name}
: ${dnscrypt_proxy_enable:=NO}
: ${dnscrypt_proxy_uid=_dnscrypt-proxy} # User to run daemon as
: ${dnscrypt_proxy_resolver=random} # resolver to use
: ${dnscrypt_proxy_pidfile=/var/run/dnscrypt-proxy.pid} # Path to pid file
: ${dnscrypt_proxy_logfile=/var/log/dnscrypt-proxy.log} # Path to log file
command=%%PREFIX%%/sbin/dnscrypt-proxy
if [ ${dnscrypt_proxy_conf} ]; then
command_args="${dnscrypt_proxy_conf}"
else
command_args="-d -p ${dnscrypt_proxy_pidfile} -l ${dnscrypt_proxy_logfile} -u ${dnscrypt_proxy_uid} -R ${dnscrypt_proxy_resolver}"
fi
procname=%%PREFIX%%/sbin/dnscrypt-proxy
pidfile=${dnscrypt_proxy_pidfile}
run_rc_command "$1"

View File

@ -1,71 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: dnscrypt_proxy
# REQUIRE: SERVERS cleanvar ldconfig
# BEFORE: named local_unbound unbound
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable dnscrypt-proxy:
#
# dnscrypt_proxy_instances (str): Set to "dnscrypt_proxy" by default.
# List of dnscrypt_proxy instance id's,
# e.g. "dnscrypt_proxy_1 dnscrypt_proxy_2", etc.
# {instance_id}_enable (bool): Set to NO by default.
# Set to YES to enable dnscrypt-proxy.
# {instance_id}_uid (str): Set to "_dnscrypt-proxy" by default.
# User to switch to after starting.
# {instance_id}_resolver (str): Set to "random" by default.
# Better to select one of your own choice.
# {instance_id}_pidfile (str): default: "/var/run/dnscrypt-proxy.pid"
# Location of pid file.
# {instance_id}_logfile (str): default: "/var/log/dnscrypt-proxy.log"
# Location of log file.
#
# To redirect a local resolver through dnscrypt-proxy, point it at 127.0.0.2
# and add the following to rc.conf:
# ifconfig_lo0_alias0="inet 127.0.0.2 netmask 0xffffffff"
# dnscrypt_proxy_flags='-a 127.0.0.2'
. /etc/rc.subr
name=dnscrypt_proxy
rcvar=dnscrypt_proxy_enable
load_rc_config ${name}
: ${dnscrypt_proxy_instances="${name}"}
: ${dnscrypt_proxy_enable:=NO}
dnscrypt_proxy_enable_tmp=${dnscrypt_proxy_enable}
command=%%PREFIX%%/sbin/dnscrypt-proxy
procname=%%PREFIX%%/sbin/dnscrypt-proxy
for i in $dnscrypt_proxy_instances; do
name=${i}
eval ${name}_enable=${dnscrypt_proxy_enable_tmp}
rcvar=${name}_enable
load_rc_config ${i}
eval dnscrypt_proxy_uid_tmp=\${${i}_uid}
eval dnscrypt_proxy_resolver_tmp=\${${i}_resolver}
eval dnscrypt_proxy_pidfile_tmp=\${${i}_pidfile}
eval dnscrypt_proxy_logfile_tmp=\${${i}_logfile}
: ${dnscrypt_proxy_uid_tmp:=_dnscrypt-proxy} # User to run daemon as
: ${dnscrypt_proxy_resolver_tmp:=random} # resolver to use
: ${dnscrypt_proxy_pidfile_tmp:=/var/run/${i}.pid} # Path to pid file
: ${dnscrypt_proxy_logfile_tmp:=/var/log/${i}.log} # Path to log file
command_args="-d -p ${dnscrypt_proxy_pidfile_tmp} -l ${dnscrypt_proxy_logfile_tmp} -u ${dnscrypt_proxy_uid_tmp} -R ${dnscrypt_proxy_resolver_tmp}"
pidfile=${dnscrypt_proxy_pidfile_tmp}
_rc_restart_done=false # workaround for: service dnscrypt-proxy restart
run_rc_command "$1"
done

View File

@ -1,27 +0,0 @@
This port/software comes all 'working out of the box'.
By default this port is using random resolvers.
Better to select one of your own choice.
To enable dnscrypt-proxy at boot:
sysrc dnscrypt_proxy_enable=YES
sysrc dnscrypt_proxy_flags="-a 127.0.0.2"
or:
sysrc dnscrypt_proxy_enable=YES
sysrc dnscrypt_proxy_conf="%%PREFIX%%/etc/dnscrypt-proxy.conf"
Be sure to setup above IP address/alias, so dnscrypt-proxy can bind correctly.
To view available options, run:
%%PREFIX%%/sbin/dnscrypt-proxy --help
or read the manual:
man dnscrypt-proxy
**************************************************
* *
* You can't mix the config file option with *
* other options or flags/settings in the rc.conf *
* *
**************************************************

View File

@ -1,29 +0,0 @@
This port/software comes all 'working out of the box'.
By default this port is using random resolvers.
Better to select one of your own choice.
To enable dnscrypt-proxy at boot:
sysrc dnscrypt_proxy_enable=YES
sysrc dnscrypt_proxy_instances="dnscrypt_proxy_1 dnscrypt_proxy_2" # etc.
sysrc dnscrypt_proxy_1_resolver=soltysiak
sysrc dnscrypt_proxy_1_flags="-a 127.0.0.2"
sysrc dnscrypt_proxy_2_resolver=okturtles
sysrc dnscrypt_proxy_2_flags="-a 127.0.0.3"
Be sure to setup above IP addresses/aliases, so dnscrypt-proxy can bind
correctly.
To view available options, run:
%%PREFIX%%/sbin/dnscrypt-proxy --help
or read the manual:
man dnscrypt-proxy
**************************************************
* *
* You can't mix the config file option with *
* other options or flags/settings in the rc.conf *
* *
**************************************************

View File

@ -1,17 +0,0 @@
The dnscrypt-proxy provides local service, which can be used directly as your
local resolver or as a DNS forwarder, encrypting and authenticating requests
using the DNSCrypt [1] protocol and passing them to an upstream server.
The DNSCrypt protocol uses high-speed high-security elliptic-curve cryptography
and is very similar to DNSCurve [2], but focuses on securing communications
between a client and its first-level resolver.
While not providing end-to-end security, it protects the local network, which
is often the weakest point of the chain, against man-in-the-middle attacks.
It also provides some confidentiality to DNS queries.
Reference links:
1. https://www.opendns.com/about/innovations/dnscrypt/
2. https://dnscurve.org/
WWW: https://github.com/jedisct1/dnscrypt-proxy

View File

@ -1,21 +0,0 @@
bin/hostip
@sample etc/dnscrypt-proxy.conf.sample
%%PLUGINS%%include/dnscrypt/plugin.h
%%PLUGINS%%include/dnscrypt/private.h
%%PLUGINS%%include/dnscrypt/version.h
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_cache.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_ldns_aaaa_blocking.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_ldns_blocking.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_ldns_forwarding.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_ldns_opendns_deviceid.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_ldns_opendns_set_client_ip.so
%%PLUGINS%%lib/dnscrypt-proxy/libdcplugin_example_logging.so
man/man8/dnscrypt-proxy.8.gz
man/man8/hostip.8.gz
sbin/dnscrypt-proxy
%%DATADIR%%/dnscrypt-resolvers.csv
%%DATADIR%%/minisign.pub
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/DNSCRYPT-V2-PROTOCOL.txt
%%PORTDOCS%%%%DOCSDIR%%/dnscrypt-proxy.conf

View File

@ -356,7 +356,6 @@
SUBDIR += mppp
SUBDIR += mprime
SUBDIR += msieve
SUBDIR += mtl
SUBDIR += mtrxmath
SUBDIR += multichoose
SUBDIR += mumps

View File

@ -1,61 +0,0 @@
# Created by: ijliao
# $FreeBSD$
PORTNAME= mtl
DISTVERSION= 2.1.2-23.tentative
PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= http://www.osl.iu.edu/download/research/mtl/
MAINTAINER= ports@FreeBSD.org
COMMENT= Matrix Template Library, Version 2
LICENSE= MTL
LICENSE_NAME= Matrix Template Library License
LICENSE_FILE= ${WRKSRC}/license.mtl.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN= fails to fetch: mastersite times out
DEPRECATED= fails to fetch: mastersite times out
EXPIRATION_DATE= 2018-09-25
CONFIGURE_ENV= CXXCPP="${CXXCPP}"
CXXCPP?= ${CXX} -E
GNU_CONFIGURE= yes
NO_BUILD= yes
USES= perl5
USE_PERL5= build
WRKSRC= ${WRKDIR}/${DISTNAME:R}
OPTIONS_DEFINE= EXAMPLES
post-patch:
@${REINPLACE_CMD} -e '/gnu\*)/,/;;/{/CXX=/d; /CXX_OPTIMIZE_FLAGS=/d; \
s/CXXFLAGS="/&$$ac_cv_env_CXXFLAGS_value /; }' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\./.*\.pl[[:blank:]]|${PERL} &|' \
${WRKSRC}/test/Makefile.in
@${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -m
check regression-test test: build
@cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
${MAKE_ARGS} QUICK=-qQ test summary
fulltest: build
@cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
${MAKE_ARGS} QUICK= test summary
.include <bsd.port.pre.mk>
.if defined(USE_GCC) || !empty(CXX:M*g++4*)
CXXFLAGS+= -fpermissive
.endif
PORTEXAMPLES= *
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/doubledouble
${INSTALL_DATA} ${WRKSRC}/contrib/examples/* ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/contrib/doubledouble/* ${STAGEDIR}${EXAMPLESDIR}/doubledouble
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (mtl-2.1.2-23.tentative.tar.gz) = 351bb9692639df74d8258bc973e98460203a7db1c9c49387558c51838b498193
SIZE (mtl-2.1.2-23.tentative.tar.gz) = 330538

View File

@ -1,17 +0,0 @@
--- mtl/Makefile.in.orig 2014-06-19 15:12:46.890432000 +0800
+++ mtl/Makefile.in 2014-06-19 15:13:23.850278020 +0800
@@ -454,11 +454,11 @@ uninstall-am: uninstall-info-am
make-install-dirs:
- -if test '!' -d $(includedir); then mkdir -p $(includedir); fi
+ -if test '!' -d $(DESTDIR)$(includedir); then mkdir -p $(DESTDIR)$(includedir); fi
install-data-hook: make-install-dirs
- -@ echo Installing $(includedir) ; \
- $(INSTALL_DATA) *.h $(includedir)
+ -@ echo Installing $(DESTDIR)$(includedir) ; \
+ $(INSTALL_DATA) *.h $(DESTDIR)$(includedir)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

View File

@ -1,10 +0,0 @@
--- mtl/external_vector.h.orig 2007-04-10 16:03:10.000000000 -0400
+++ mtl/external_vector.h 2012-01-01 03:59:14.000000000 -0500
@@ -3,6 +3,7 @@
#include "mtl/mtl_iterator.h"
#include "mtl/mtl_exception.h"
+#include <cstddef>
namespace mtl {

View File

@ -1,12 +0,0 @@
--- mtl/light1D.h.orig 2007-04-10 16:03:10.000000000 -0400
+++ mtl/light1D.h 2012-01-01 03:58:53.000000000 -0500
@@ -19,7 +19,8 @@
#include "mtl/reverse_iter.h"
#include "mtl/matrix_traits.h"
#include "mtl/scaled1D.h"
-#include <stdlib.h>
+#include <cstddef>
+#include <cstdlib>
namespace mtl {

View File

@ -1,10 +0,0 @@
--- mtl/linalg_vec.h.orig 2007-04-10 16:03:10.000000000 -0400
+++ mtl/linalg_vec.h 2012-01-01 06:06:12.000000000 -0500
@@ -116,6 +116,7 @@
typedef difference_type Vec_difference_type;
typedef iterator Vec_iterator;
typedef const_iterator Vec_const_iterator;
+ typedef value_type Vec_value_type;
class IndexArray {
public:

View File

@ -1,60 +0,0 @@
--- test/src/algo_test.h.orig 2007-04-10 16:03:10.000000000 -0400
+++ test/src/algo_test.h 2012-01-01 08:04:04.000000000 -0500
@@ -8,6 +8,28 @@
using mtl::dense1D;
template <class Matrix>
+void
+set_diagonal_test(std::string test_name, Matrix& A, bool& success)
+{
+ if (A.is_unit()) {
+ std::cout << test_name.c_str() << " skipping set_diagonal" << std::endl;
+ return;
+ }
+ typedef typename mtl::matrix_traits<Matrix>::value_type T;
+ typedef typename mtl::matrix_traits<Matrix>::size_type Int;
+ // set_diagnal
+ Int i;
+ mtl::set_diagonal(A, T(1));
+
+ for (i = 0; i < A.nrows() && i < A.ncols(); ++i)
+ if (A(i,i) != T(1)) {
+ std::cout << test_name.c_str() << " failed set_diagnal(A,a) *****" << std::endl;
+ success = false;
+ break;
+ }
+}
+
+template <class Matrix>
bool
mat_algo_test(Matrix& A, std::string test_name)
{
@@ -110,28 +132,6 @@
return success;
}
-template <class Matrix>
-void
-set_diagonal_test(std::string test_name, Matrix& A, bool& success)
-{
- if (A.is_unit()) {
- std::cout << test_name.c_str() << " skipping set_diagonal" << std::endl;
- return;
- }
- typedef typename mtl::matrix_traits<Matrix>::value_type T;
- typedef typename mtl::matrix_traits<Matrix>::size_type Int;
- // set_diagnal
- Int i;
- mtl::set_diagonal(A, T(1));
-
- for (i = 0; i < A.nrows() && i < A.ncols(); ++i)
- if (A(i,i) != T(1)) {
- std::cout << test_name.c_str() << " failed set_diagnal(A,a) *****" << std::endl;
- success = false;
- break;
- }
-}
-
template <class Mat>
inline void
fill_matrix(Mat& A, int /*sub*/, int /*super*/, mtl::rectangle_tag)

View File

@ -1,12 +0,0 @@
--- test/src/matrix_test.h.orig 2007-04-10 16:03:10.000000000 -0400
+++ test/src/matrix_test.h 2012-01-01 07:40:34.000000000 -0500
@@ -52,6 +52,9 @@
#include "fill_matrix.h"
+template <class Matrix>
+void
+do_test(Matrix& A, std::string test_name);
template <class Matrix>
void

View File

@ -1,13 +0,0 @@
The Matrix Template Library (MTL) is a high-performance generic component
library that provides comprehensive linear algebra functionality for a wide
variety of matrix formats.
As with the Standard Template Library (STL), MTL uses a five-fold approach,
consisting of generic functions, containers, iterators, adaptors, and function
objects, all developed specifically for high performance numerical linear
algebra. Within this framework, MTL provides generic algorithms corresponding
to the mathematical operations that define linear algebra. Similarly, the
containers, adaptors, and iterators are used to represent and to manipulate
concrete linear algebra objects such as matrices and vectors.
WWW: http://www.osl.iu.edu/research/mtl/

View File

@ -1,71 +0,0 @@
include/mtl/abs.h
include/mtl/array2D.h
include/mtl/banded_indexer.h
include/mtl/bare_bones_array.h
include/mtl/blais.h
include/mtl/blas_interface.h
include/mtl/block1D.h
include/mtl/block2D.h
include/mtl/compressed1D.h
include/mtl/compressed2D.h
include/mtl/compressed_iter.h
include/mtl/conj.h
include/mtl/cplx_dbldbl.h
include/mtl/dense1D.h
include/mtl/dense2D.h
include/mtl/dense_iterator.h
include/mtl/diagonal_indexer.h
include/mtl/dim_calc.h
include/mtl/dimension.h
include/mtl/dumptofile.h
include/mtl/elt.h
include/mtl/entry.h
include/mtl/envelope2D.h
include/mtl/external_vector.h
include/mtl/fast.h
include/mtl/harwell_boeing_stream.h
include/mtl/initialize.h
include/mtl/iohb.h
include/mtl/iterator_adaptor.h
include/mtl/lapack_interface.h
include/mtl/light1D.h
include/mtl/light_matrix.h
include/mtl/linalg_vec.h
include/mtl/lu.h
include/mtl/matlabio.h
include/mtl/matrix.h
include/mtl/matrix_implementation.h
include/mtl/matrix_market_stream.h
include/mtl/matrix_stream.h
include/mtl/matrix_traits.h
include/mtl/meta_equal.h
include/mtl/meta_if.h
include/mtl/mmio.h
include/mtl/mtl.h
include/mtl/mtl2lapack.h
include/mtl/mtl_algo.h
include/mtl/mtl_complex.h
include/mtl/mtl_config.h
include/mtl/mtl_decl.h
include/mtl/mtl_exception.h
include/mtl/mtl_iterator.h
include/mtl/mtl_limits.h
include/mtl/mtl_set.h
include/mtl/norm.h
include/mtl/not_at.h
include/mtl/oned_part.h
include/mtl/orien.h
include/mtl/partition.h
include/mtl/rect_indexer.h
include/mtl/refcnt_ptr.h
include/mtl/reverse_iter.h
include/mtl/scale_iterator.h
include/mtl/scaled1D.h
include/mtl/scaled2D.h
include/mtl/sparse1D.h
include/mtl/sparse_iterator.h
include/mtl/strided1D.h
include/mtl/strided_iterator.h
include/mtl/transform_iterator.h
include/mtl/uplo.h
include/mtl/utils.h