Update to 0.1.2

This commit is contained in:
Mario Sergio Fujikawa Ferreira 2005-01-08 17:45:41 +00:00
parent eb4a1d3895
commit 2dc8c5621f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=125848
8 changed files with 104 additions and 86 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= dctc
PORTVERSION= 0.0.6
PORTVERSION= 0.1.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dc-qt
@ -16,37 +16,66 @@ DISTNAME= dc-qt-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= A Qt GUI for the Direct Connect (TM) dctc text client
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
RUN_DEPENDS= dctc:${PORTSDIR}/net/dctc
USE_QT_VER= 3
USE_REINPLACE= yes
MAKE_ENV= QTDIR="${QTDIR}"
PLIST_FILES= bin/dc-qt
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_FILES= bin/dc_qt
QTDIR?= ${X11BASE}
QMAKE?= ${LOCALBASE}/bin/qmake
OPTIONS= XINE "Enable support for video preview using libxine" off
XINE_CONFIG?= ${X11BASE}/bin/xine-config
.ifndef(NOPORTDOCS)
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= \
about.html \
advanced.html \
basic.html \
config.html \
connect.html \
index.html \
logo.png \
mainwindow.png \
searchdl.html
.endif
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E -e 's|"hublist|"dc_hublist|' \
${WRKSRC}/dc_hub.cc
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
do-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
-spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ dc-qt.pro
# with xine preview support
.ifdef(WITH_XINE)
LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
CONFIGURE_ENV+= XINE_CONFIG=${XINE_CONFIG}
.else
CONFIGURE_ARGS+= --disable-preview
.endif
post-patch:
@${REINPLACE_CMD} -E \
-e 's|(HUBLIST[[:space:]]*=[[:space:]]*")hublist"|\1dc_hublist"|' \
${WRKSRC}/src/dc_hub.cc
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E \
-e 's|^(SUBDIRS).+$$|\1=|' \
${WRKSRC}/src/Makefile.in
.else
@${REINPLACE_CMD} -E \
-e 's|^(pkgdatadir).+$$|\1=${DOCSDIR}|' \
${WRKSRC}/src/doc/Makefile.in
.endif
post-configure:
# uphold CC/CXX/CFLAGS
# link against correct qt lib
@${REINPLACE_CMD} -E -e 's|^CC.+$$|CC=${CC}|; \
s|^CXX[[:space:]]*=.*$$|CXX=${CXX}|; \
s|^(CFLAGS.+)$$|\1 ${PTHREAD_CFLAGS}|; \
s|-lqt |-lqt-mt ${PTHREAD_LIBS:S/"//g} |' \
${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/dc-qt ${PREFIX}/bin
@${REINPLACE_CMD} -E \
-e 's|^(CXXFLAGS.+)$$|\1 ${CXXFLAGS}|' \
${WRKSRC}/Makefile \
${WRKSRC}/src/Makefile
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (dc-qt-0.0.6.tar.gz) = 71b76b159e48719e69c623bad89fbcba
SIZE (dc-qt-0.0.6.tar.gz) = 65907
MD5 (dc-qt-0.1.2.tar.gz) = 2653c020cd2cc3957d35f2c1e77b4d46
SIZE (dc-qt-0.1.2.tar.gz) = 349695

View File

@ -1,10 +0,0 @@
--- dctc_connection.h.orig Wed Aug 13 08:54:27 2003
+++ dctc_connection.h Wed Aug 13 08:54:44 2003
@@ -4,6 +4,7 @@
#include <qobject.h>
#include <qsocketdevice.h>
+#include <sys/types.h>
#include <sys/un.h>
class QSocketNotifier;

View File

@ -1,10 +0,0 @@
--- hubwdgt.cc.orig Wed Aug 13 08:57:51 2003
+++ hubwdgt.cc Wed Aug 13 08:59:05 2003
@@ -29,6 +29,7 @@
#include <qfile.h>
#include <qdir.h>
#include <zlib.h>
+#include <sys/time.h>
#include "hubwdgt.h"
#include "debugdlg.h"
#include "searchdlg.h"

View File

@ -6,7 +6,7 @@
#
PORTNAME= dctc
PORTVERSION= 0.0.6
PORTVERSION= 0.1.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dc-qt
@ -16,37 +16,66 @@ DISTNAME= dc-qt-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= A Qt GUI for the Direct Connect (TM) dctc text client
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
RUN_DEPENDS= dctc:${PORTSDIR}/net/dctc
USE_QT_VER= 3
USE_REINPLACE= yes
MAKE_ENV= QTDIR="${QTDIR}"
PLIST_FILES= bin/dc-qt
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_FILES= bin/dc_qt
QTDIR?= ${X11BASE}
QMAKE?= ${LOCALBASE}/bin/qmake
OPTIONS= XINE "Enable support for video preview using libxine" off
XINE_CONFIG?= ${X11BASE}/bin/xine-config
.ifndef(NOPORTDOCS)
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
PORTDOCS= \
about.html \
advanced.html \
basic.html \
config.html \
connect.html \
index.html \
logo.png \
mainwindow.png \
searchdl.html
.endif
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E -e 's|"hublist|"dc_hublist|' \
${WRKSRC}/dc_hub.cc
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
do-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
-spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ dc-qt.pro
# with xine preview support
.ifdef(WITH_XINE)
LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
CONFIGURE_ENV+= XINE_CONFIG=${XINE_CONFIG}
.else
CONFIGURE_ARGS+= --disable-preview
.endif
post-patch:
@${REINPLACE_CMD} -E \
-e 's|(HUBLIST[[:space:]]*=[[:space:]]*")hublist"|\1dc_hublist"|' \
${WRKSRC}/src/dc_hub.cc
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E \
-e 's|^(SUBDIRS).+$$|\1=|' \
${WRKSRC}/src/Makefile.in
.else
@${REINPLACE_CMD} -E \
-e 's|^(pkgdatadir).+$$|\1=${DOCSDIR}|' \
${WRKSRC}/src/doc/Makefile.in
.endif
post-configure:
# uphold CC/CXX/CFLAGS
# link against correct qt lib
@${REINPLACE_CMD} -E -e 's|^CC.+$$|CC=${CC}|; \
s|^CXX[[:space:]]*=.*$$|CXX=${CXX}|; \
s|^(CFLAGS.+)$$|\1 ${PTHREAD_CFLAGS}|; \
s|-lqt |-lqt-mt ${PTHREAD_LIBS:S/"//g} |' \
${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/dc-qt ${PREFIX}/bin
@${REINPLACE_CMD} -E \
-e 's|^(CXXFLAGS.+)$$|\1 ${CXXFLAGS}|' \
${WRKSRC}/Makefile \
${WRKSRC}/src/Makefile
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (dc-qt-0.0.6.tar.gz) = 71b76b159e48719e69c623bad89fbcba
SIZE (dc-qt-0.0.6.tar.gz) = 65907
MD5 (dc-qt-0.1.2.tar.gz) = 2653c020cd2cc3957d35f2c1e77b4d46
SIZE (dc-qt-0.1.2.tar.gz) = 349695

View File

@ -1,10 +0,0 @@
--- dctc_connection.h.orig Wed Aug 13 08:54:27 2003
+++ dctc_connection.h Wed Aug 13 08:54:44 2003
@@ -4,6 +4,7 @@
#include <qobject.h>
#include <qsocketdevice.h>
+#include <sys/types.h>
#include <sys/un.h>
class QSocketNotifier;

View File

@ -1,10 +0,0 @@
--- hubwdgt.cc.orig Wed Aug 13 08:57:51 2003
+++ hubwdgt.cc Wed Aug 13 08:59:05 2003
@@ -29,6 +29,7 @@
#include <qfile.h>
#include <qdir.h>
#include <zlib.h>
+#include <sys/time.h>
#include "hubwdgt.h"
#include "debugdlg.h"
#include "searchdlg.h"