Add flite 1.2, a small run-time speech synthesis engine.

This commit is contained in:
Maxim Sobolev 2004-12-18 18:43:12 +00:00
parent 809cc8d3b9
commit 2dbcfc55e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=124399
9 changed files with 166 additions and 0 deletions

View File

@ -109,6 +109,7 @@
SUBDIR += festvox-tll
SUBDIR += flac
SUBDIR += flac123
SUBDIR += flite
SUBDIR += fluidsynth
SUBDIR += fmio
SUBDIR += freebirth

23
audio/flite/Makefile Normal file
View File

@ -0,0 +1,23 @@
# New ports collection makefile for: flite
# Date created: 18 December 2004
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= flite
PORTVERSION= 1.2
CATEGORIES= audio
MASTER_SITES= http://ccache.samba.org/ftp/ccache/
DISTNAME= ${PKGNAME}-release
MAINTAINER= sobomax@FreeBSD.org
COMMENT= A small run-time speech synthesis engine
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared=yes
INSTALLS_SHLIB= yes
.include <bsd.port.mk>

2
audio/flite/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (flite-1.2-release.tar.bz2) = 24c1576f5b3eb23ecedf4bebde96710f
SIZE (flite-1.2-release.tar.bz2) = 7817919

View File

@ -0,0 +1,15 @@
$FreeBSD$
--- config/common_make_rules
+++ config/common_make_rules
@@ -88,8 +88,7 @@
@ rm -rf shared_os && mkdir shared_os
@ rm -f $@ $(LIBDIR)/$@.${PROJECT_VERSION} $(LIBDIR)/$@.${PROJECT_SHLIB_VERSION}
@ (cd shared_os && ar x ../$<)
- @ (cd shared_os && $(CC) -shared -Wl,-soname,$@.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os)
- @ ln -s $(LIBDIR)/$@.${PROJECT_VERSION} $(LIBDIR)/$@.${PROJECT_SHLIB_VERSION}
+ @ (cd shared_os && $(CC) -shared -Wl,-soname,$@.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_SHLIB_VERSION} *.os)
@ ln -s $(LIBDIR)/$@.${PROJECT_SHLIB_VERSION} $(LIBDIR)/$@
@ rm -rf shared_os

View File

@ -0,0 +1,24 @@
$FreeBSD$
--- configure.orig
+++ configure
@@ -1113,6 +1113,9 @@
OTHERLIBS=
if test "$shared" = true; then
case "$host_os" in
+ *bsd*)
+ SHFLAGS="-fPIC"
+ ;;
linux*)
SHFLAGS="-fPIC"
;;
@@ -1498,7 +1501,7 @@
AUDIODRIVER=oss
AUDIODEFS=-DCST_AUDIO_LINUX
;;
- *bsd)
+ *bsd*)
AUDIODRIVER=oss
AUDIODEFS=-DCST_AUDIO_FREEBSD
;;

View File

@ -0,0 +1,18 @@
$FreeBSD$
--- include/cst_sts.h
+++ include/cst_sts.h
@@ -47,9 +47,9 @@
/* else where, this information plus the indexes in the Unit relation */
/* allow reconstruction of the signal itself */
struct cst_sts_struct {
- const unsigned short *frame;
- const int size; /* in samples */
- const unsigned char *residual;
+ unsigned short *frame;
+ int size; /* in samples */
+ unsigned char *residual;
};
typedef struct cst_sts_struct cst_sts;

View File

@ -0,0 +1,15 @@
$FreeBSD$
--- lib/Makefile
+++ lib/Makefile
@@ -44,8 +44,7 @@
STATICLIBS= $(LIBNAMES:%=lib%.a)
SHAREDARLIBS= $(LIBNAMES:%=lib%.shared.a)
SHAREDLIBS = $(LIBNAMES:%=lib%.so)
-VERSIONSHAREDLIBS = $(SHAREDLIBS:%=%.${PROJECT_VERSION}) \
- $(SHAREDLIBS:%=%.${PROJECT_SHLIB_VERSION})
+VERSIONSHAREDLIBS = $(SHAREDLIBS:%=%.${PROJECT_SHLIB_VERSION})
ALL_LIBS = $(STATICLIBS) $(SHAREDLIBS) $(VERSIONSHAREDLIBS)
ALL = shared_libs

11
audio/flite/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
Flite is a small fast run-time speech synthesis engine. It is the
latest addition to the suite of free software synthesis tools
including University of Edinburgh's Festival Speech Synthesis System
and Carnegie Mellon University's FestVox project, tools, scripts and
documentation for building synthetic voices. However, flite itself
does not require either of these systems to compile and run.
Flite is the answer to the complaint that Festival is too big, too slow,
and not portable enough.
WWW: http://cmuflite.org

57
audio/flite/pkg-plist Normal file
View File

@ -0,0 +1,57 @@
bin/flite
bin/flite_time
include/flite/cst_alloc.h
include/flite/cst_args.h
include/flite/cst_audio.h
include/flite/cst_cart.h
include/flite/cst_clunits.h
include/flite/cst_diphone.h
include/flite/cst_endian.h
include/flite/cst_error.h
include/flite/cst_features.h
include/flite/cst_file.h
include/flite/cst_hrg.h
include/flite/cst_item.h
include/flite/cst_lexicon.h
include/flite/cst_lts.h
include/flite/cst_lts_rewrites.h
include/flite/cst_phoneset.h
include/flite/cst_regex.h
include/flite/cst_relation.h
include/flite/cst_sigpr.h
include/flite/cst_socket.h
include/flite/cst_ss.h
include/flite/cst_string.h
include/flite/cst_sts.h
include/flite/cst_synth.h
include/flite/cst_tokenstream.h
include/flite/cst_track.h
include/flite/cst_units.h
include/flite/cst_utt_utils.h
include/flite/cst_utterance.h
include/flite/cst_val.h
include/flite/cst_val_const.h
include/flite/cst_val_defs.h
include/flite/cst_viterbi.h
include/flite/cst_voice.h
include/flite/cst_wave.h
include/flite/flite.h
include/flite/flite_version.h
lib/libflite.a
lib/libflite.so
lib/libflite.so.1
lib/libflite_cmu_time_awb.a
lib/libflite_cmu_time_awb.so
lib/libflite_cmu_time_awb.so.1
lib/libflite_cmu_us_kal.a
lib/libflite_cmu_us_kal.so
lib/libflite_cmu_us_kal.so.1
lib/libflite_cmu_us_kal16.a
lib/libflite_cmu_us_kal16.so
lib/libflite_cmu_us_kal16.so.1
lib/libflite_cmulex.a
lib/libflite_cmulex.so
lib/libflite_cmulex.so.1
lib/libflite_usenglish.a
lib/libflite_usenglish.so
lib/libflite_usenglish.so.1