Resurrect `math/grpn' removed in r487992 because it used obsolete GTK+
stack. This version is a picked up fork on GitHub which now supports GTK+ 2.0 and include a number of bugfixes, so welcome back! Requested by: someone on #bsdports
This commit is contained in:
parent
2adf64a911
commit
2db5a597ef
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495782
@ -265,6 +265,7 @@
|
||||
SUBDIR += gretl
|
||||
SUBDIR += gri
|
||||
SUBDIR += gringo
|
||||
SUBDIR += grpn
|
||||
SUBDIR += gsl
|
||||
SUBDIR += hexcalc
|
||||
SUBDIR += hipmcl
|
||||
|
34
math/grpn/Makefile
Normal file
34
math/grpn/Makefile
Normal file
@ -0,0 +1,34 @@
|
||||
# Created by: Chris D. Faulhaber <jedgar@fxp.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= grpn
|
||||
PORTVERSION= 1.5.2
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= math
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GTK+-based reverse polish notation (RPN) calculator
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
USES= gnome pkgconfig
|
||||
USE_GNOME= gtk20
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= utopiabound
|
||||
|
||||
WRKSRC_SUBDIR= src
|
||||
|
||||
PLIST_FILES= bin/grpn man/man1/grpn.1.gz
|
||||
PORTDOCS= CHANGES
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,ulong,unsigned long,g' \
|
||||
${WRKSRC}/real.c
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
math/grpn/distinfo
Normal file
3
math/grpn/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1543025897
|
||||
SHA256 (utopiabound-grpn-v1.5.2_GH0.tar.gz) = 36a306ee7ac840c2f114877b07ee70688d53dd3111773938ae816c8b90d3e99d
|
||||
SIZE (utopiabound-grpn-v1.5.2_GH0.tar.gz) = 61799
|
38
math/grpn/files/patch-Makefile
Normal file
38
math/grpn/files/patch-Makefile
Normal file
@ -0,0 +1,38 @@
|
||||
--- Makefile.orig 2018-11-24 02:18:17 UTC
|
||||
+++ Makefile
|
||||
@@ -3,11 +3,11 @@
|
||||
# Please read the next few lines and enter the correct values.
|
||||
|
||||
# where to install GRPN
|
||||
-PREFIX = /usr/local
|
||||
-MANDIR = ${PREFIX}/man
|
||||
+PREFIX ?= /usr/local
|
||||
+MANDIR ?= ${MANPREFIX}/man
|
||||
|
||||
# What compiler should be used
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
|
||||
# NOTE:
|
||||
#
|
||||
@@ -16,10 +16,8 @@ CC = gcc
|
||||
# add -DUSE_GNOME if you want to make grpn GNOME compliant.
|
||||
|
||||
|
||||
-CFLAGS = -Wall -g -O2 -I/usr/X11/include -DUSE_PANGO `pkg-config --cflags gtk+-2.0` -DGTK_VER_1_1
|
||||
+CFLAGS += -Wall -DUSE_PANGO `pkg-config --cflags gtk+-2.0` -DGTK_VER_1_1
|
||||
|
||||
-DFLAGS = -L/usr/X11/lib
|
||||
-
|
||||
# end of user configurable section
|
||||
|
||||
|
||||
@@ -32,6 +30,8 @@ OBJS = test_gtk_ver.o real.o complex.o matrix.o number
|
||||
error.o help.o mode.o undo.o
|
||||
|
||||
LIBS = `pkg-config --libs gtk+-2.0` -lX11 -lm
|
||||
+
|
||||
+all: grpn
|
||||
|
||||
grpn: $(OBJS)
|
||||
$(CC) $(DFLAGS) -o $@ $(OBJS) $(LIBS)
|
9
math/grpn/pkg-descr
Normal file
9
math/grpn/pkg-descr
Normal file
@ -0,0 +1,9 @@
|
||||
GRPN is a RPN calculator for the X Window system built using
|
||||
the GIMP Toolkit (GTK).
|
||||
|
||||
GRPN works with real numbers, complex numbers, matrices, and
|
||||
complex matrices. Numbers can be displayed in 4 different
|
||||
radix modes, and complex numbers can be displayed in either
|
||||
Cartesian or polar form.
|
||||
|
||||
WWW: https://github.com/utopiabound/grpn
|
Loading…
Reference in New Issue
Block a user