editors/nvi-m17n: fix CJK display problem

PR:		220013
Submitted by:	Satoshi TOMIOKA <tomioka.satoshi.ml@gmail.com>
Reported by:	Yasuhito FUTATSUKI <freebsd-bug-report-yf@yf.bsdclub.org>
This commit is contained in:
Steve Wills 2018-06-16 22:47:21 +00:00
parent f999d34d71
commit 2daed13623
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472573
3 changed files with 10 additions and 15 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= nvi
PORTVERSION= 1.79.20040608
PORTREVISION= 4
PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES?= editors
MASTER_SITES= ftp://ftp.mk.bsdclub.org/pub/FreeBSD/distfiles/ \

View File

@ -1,8 +1,10 @@
--- ../common/multibyte.c.orig 2017-01-07 18:04:20.087312000 +0900
+++ ../common/multibyte.c 2017-01-07 18:05:53.585988000 +0900
@@ -1455,7 +1455,7 @@
--- ../common/multibyte.c.orig 2017-11-17 21:47:04.305764000 +0900
+++ ../common/multibyte.c 2017-11-17 21:58:19.218532000 +0900
@@ -1454,8 +1454,9 @@
if (maybe == 0)
return ename;
+ if ( (maxfunc!=1) && (try==maybe) ) continue ;
for (i = 0; i < maxfunc; i++) {
- if (maybe == (1 << i))
+ if (maybe & (1 << i))

View File

@ -1,6 +1,6 @@
--- configure.orig 2016-01-31 11:55:44 UTC
+++ configure
@@ -1805,10 +1805,8 @@ if test "$vi_cv_canna" = "yes"; then
+++ configure 2017-11-28 18:37:14.184568000 +0900
@@ -1805,10 +1805,8 @@
case "$host_os" in
bsdi2.1)
vi_cannapath="/usr/contrib/canna";;
@ -13,19 +13,12 @@
*)
vi_cannapath="/usr/local/canna";;
esac
@@ -2155,13 +2153,13 @@ fi
# [ --disable-curses DON'T use the nvi-provided curses routines.],
# [vi_cv_curses="other curses"], [vi_cv_curses="bundled curses"])
#AC_MSG_RESULT($vi_cv_curses)
-vi_cv_curses="bundled curses"
+vi_cv_curses="other curses"
case "$vi_cv_curses" in
"bundled curses")
@@ -2161,7 +2159,7 @@
CPPFLAGS="-I\$(srcdir)/curses $CPPFLAGS"
cobjs="\$(COBJS)";;
"other curses")
- LIBS="-lcurses $LIBS";;
+ LIBS="-lncurses $LIBS";;
+ LIBS="-lncursesw $LIBS";;
esac
echo $ac_n "checking for sys/mman.h""... $ac_c" 1>&6