Update to 0.33
PR: ports/41067 Submitted by: maintainer
This commit is contained in:
parent
6a3d1cc820
commit
2d15e8d2dd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63642
@ -6,25 +6,24 @@
|
||||
#
|
||||
|
||||
PORTNAME= antiword
|
||||
PORTVERSION= 0.32
|
||||
PORTVERSION= 0.33
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.winfield.demon.nl/linux/
|
||||
|
||||
MAINTAINER= leeym@leeym.com
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}
|
||||
USE_REINPLACE= yes
|
||||
INSTALL_TARGET= global_install
|
||||
|
||||
MAN1= antiword.1
|
||||
|
||||
post-patch:
|
||||
@${PERL5} -pi -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/antiword.h
|
||||
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' \
|
||||
-e 's,/usr/share,${PREFIX}/share,g' \
|
||||
${WRKSRC}/Makefile.* ${WRKSRC}/*.[ch]
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/antiword ${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/kantiword ${PREFIX}/bin
|
||||
post-install:
|
||||
@${INSTALL_MAN} ${WRKSRC}/Docs/antiword.1 ${MANPREFIX}/man/man1
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/Resources/* ${DATADIR}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/Docs/* ${DOCSDIR}
|
||||
|
@ -1 +1 @@
|
||||
MD5 (antiword-0.32.tar.gz) = bbbef871b7e7bea4df2102c8f634f81e
|
||||
MD5 (antiword-0.33.tar.gz) = e2178402066bbb1f5b3a49d47316a1fc
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- Makefile.Linux.orig Sat Jul 21 15:58:03 2001
|
||||
+++ Makefile.Linux Sat Nov 3 15:30:36 2001
|
||||
@@ -2,7 +2,7 @@
|
||||
# Makefile for antiword (Linux version)
|
||||
#
|
||||
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
LD = gcc
|
||||
|
||||
# must be equal to DEBUG or NDEBUG
|
||||
@@ -12,7 +12,7 @@
|
||||
|
||||
LDLIBS =
|
||||
|
||||
-CFLAGS = -Wall -pedantic $(OPT) -D$(DB)
|
||||
+CFLAGS += -Wall -pedantic -D$(DB)
|
||||
LDFLAGS =
|
||||
|
||||
OBJS =\
|
||||
@@ -27,7 +27,7 @@
|
||||
antiword\
|
||||
kantiword
|
||||
|
||||
-INSTALL_DIR = $(HOME)/bin
|
||||
+INSTALL_DIR = $(PREFIX)/bin
|
||||
|
||||
all: $(PROGS)
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- antiword.h.orig Sat Oct 27 08:35:52 2001
|
||||
+++ antiword.h Sat Oct 27 08:36:13 2001
|
||||
@@ -143,7 +143,7 @@
|
||||
#define ANTIWORD_DIR "antiword"
|
||||
#define FONTNAMES_FILE "fontname.txt"
|
||||
#else
|
||||
-#define GLOBAL_ANTIWORD_DIR "/opt/antiword/share"
|
||||
+#define GLOBAL_ANTIWORD_DIR "%%PREFIX%%/share/antiword"
|
||||
#define ANTIWORD_DIR ".antiword"
|
||||
#define FONTNAMES_FILE "fontnames"
|
||||
#endif /* __dos */
|
@ -5,6 +5,7 @@ share/antiword/8859-10.txt
|
||||
share/antiword/8859-13.txt
|
||||
share/antiword/8859-14.txt
|
||||
share/antiword/8859-15.txt
|
||||
share/antiword/8859-16.txt
|
||||
share/antiword/8859-2.txt
|
||||
share/antiword/8859-3.txt
|
||||
share/antiword/8859-4.txt
|
||||
@ -13,28 +14,29 @@ share/antiword/8859-6.txt
|
||||
share/antiword/8859-7.txt
|
||||
share/antiword/8859-8.txt
|
||||
share/antiword/8859-9.txt
|
||||
share/antiword/Default
|
||||
share/antiword/Example
|
||||
share/antiword/MacRoman.txt
|
||||
share/antiword/UTF-8.txt
|
||||
share/antiword/Unicode
|
||||
share/antiword/cp1250.txt
|
||||
share/antiword/cp1251.txt
|
||||
share/antiword/cp1252.txt
|
||||
share/antiword/cp437.txt
|
||||
share/antiword/cp850.txt
|
||||
share/antiword/cp852.txt
|
||||
share/antiword/fontnames
|
||||
share/antiword/fontnames.russian
|
||||
share/antiword/koi8-r.txt
|
||||
share/antiword/koi8-u.txt
|
||||
share/antiword/roman.txt
|
||||
%%PORTDOCS%%share/doc/antiword/COPYING
|
||||
%%PORTDOCS%%share/doc/antiword/ChangeLog
|
||||
%%PORTDOCS%%share/doc/antiword/Exmh
|
||||
%%PORTDOCS%%share/doc/antiword/FAQ
|
||||
%%PORTDOCS%%share/doc/antiword/History
|
||||
%%PORTDOCS%%share/doc/antiword/Netscape
|
||||
%%PORTDOCS%%share/doc/antiword/Mutt
|
||||
%%PORTDOCS%%share/doc/antiword/Netscape
|
||||
%%PORTDOCS%%share/doc/antiword/QandA
|
||||
%%PORTDOCS%%share/doc/antiword/ReadMe
|
||||
%%PORTDOCS%%share/doc/antiword/antiword.1
|
||||
%%PORTDOCS%%share/doc/antiword/antiword.man
|
||||
%%PORTDOCS%%share/doc/antiword/testdoc.doc
|
||||
%%PORTDOCS%%@dirrm share/doc/antiword
|
||||
@dirrm share/antiword
|
||||
|
Loading…
Reference in New Issue
Block a user