multimedia/freetuxtv: fix build

- Add p5-XML-Parser as BUILD_DEPENDS [1]
- Use pathfix [1]
- Add DOCS and NLS options [1]
- Fix build with clang, -Wno-return-type

PR:		ports/179950
Submitted by:	nemysis <nemysis@gmx.ch> [1] (maintainer)
This commit is contained in:
William Grzybowski 2013-06-25 13:51:12 +00:00
parent 1301b46ae7
commit 2d0bf489e2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=321744
3 changed files with 22 additions and 38 deletions

View File

@ -1,3 +1,4 @@
# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= freetuxtv
@ -11,6 +12,7 @@ COMMENT= WebTV player based on GTK2+ and LibVLC
LICENSE= GPLv3
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= vlc:${PORTSDIR}/multimedia/vlc \
dbus-glib:${PORTSDIR}/devel/dbus-glib \
sqlite3:${PORTSDIR}/databases/sqlite3 \
@ -24,27 +26,39 @@ LIB_DEPENDS= vlc:${PORTSDIR}/multimedia/vlc \
expat:${PORTSDIR}/textproc/expat2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USES= iconv pathfix pkgconfig
USE_GNOME= glib20 gtk20
USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext xfixes \
xi xinerama xrandr xrender
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-gtk=2.0
USE_GMAKE= yes
USES= pkgconfig iconv
CFLAGS= -Wno-return-type
INSTALLS_ICONS= yes
CONFIGURE_ARGS+=--with-gtk=2.0
PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_USES= gettext
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
post-patch:
@${REINPLACE_CMD} -e 's|$${pkgdatadir}/doc|$${PREFIX}/share/doc/${PORTNAME}|' \
-e 's|install-data-am: install-freetuxtvdocDATA|install-data-am: |' \
${WRKSRC}/Makefile.in
.if ! ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
post-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- po/Makefile.in.in.orig 2012-05-08 19:34:01.000000000 +0200
+++ po/Makefile.in.in 2012-09-22 10:34:08.000000000 +0200
@@ -34,7 +34,7 @@
datarootdir = @datarootdir@
libdir = @libdir@
DATADIRNAME = @DATADIRNAME@
-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+itlocaledir = $(datarootdir)/locale
subdir = po
install_sh = @install_sh@
# Automake >= 1.8 provides @mkdir_p@.

View File

@ -10,12 +10,6 @@ lib/libvlc-gtk.a
lib/libvlc-gtk.la
share/applications/freetuxtv.desktop
%%DATADIR%%/channels_groups.xml
%%DATADIR%%/doc/AUTHORS
%%DATADIR%%/doc/COPYING
%%DATADIR%%/doc/ChangeLog
%%DATADIR%%/doc/INSTALL
%%DATADIR%%/doc/NEWS
%%DATADIR%%/doc/README
%%DATADIR%%/images/channels/100pourcentradio.png
%%DATADIR%%/images/channels/1onairconnect.png
%%DATADIR%%/images/channels/2mmaroc.png
@ -440,22 +434,9 @@ share/icons/hicolor/scalable/apps/freetuxtv.svg
%%NLS%%share/locale/zh_CN/LC_MESSAGES/freetuxtv.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/freetuxtv.mo
share/pixmaps/freetuxtv.png
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/22x22/apps
@dirrmtry share/icons/hicolor/22x22
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%/images/channels
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrmtry include/libvlc-gtk