New port: net/fb303: Base Thrift service and a common set of functionality

This commit is contained in:
Yuri Victorovich 2020-09-15 22:12:40 +00:00
parent f2c87c052e
commit 2d09934671
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548751
7 changed files with 134 additions and 0 deletions

View File

@ -149,6 +149,7 @@
SUBDIR += exabgp4
SUBDIR += exaddos
SUBDIR += fb
SUBDIR += fb303
SUBDIR += fbzmq
SUBDIR += fiche
SUBDIR += file2pcap

35
net/fb303/Makefile Normal file
View File

@ -0,0 +1,35 @@
# $FreeBSD$
PORTNAME= fb303
DISTVERSION= g20200915
CATEGORIES= net
MAINTAINER= yuri@FreeBSD.org
COMMENT= Base Thrift service and a common set of functionality
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libfizz.so:security/fizz \
libfmt.so:devel/libfmt \
libfolly.so:devel/folly \
libgflags.so:devel/gflags \
libglog.so:devel/glog \
libthriftcpp2.so:devel/fbthrift \
libwangle.so:net/wangle
USES= cmake compiler:c++17-lang
USE_GITHUB= yes
GH_ACCOUNT= facebook
GH_TAGNAME= ec43a43
USE_LDCONFIG= yes
CXXFLAGS+= -fPIC
CMAKE_ON= BUILD_SHARED_LIBS
post-install:
@${RMDIR} ${STAGEDIR}${PREFIX}/include/fb303/test
.include <bsd.port.mk>

3
net/fb303/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1600206657
SHA256 (facebook-fb303-g20200915-ec43a43_GH0.tar.gz) = 956c7388d59a73c381627a8a67c57726994b28252b8246f224e94041cec0aaed
SIZE (facebook-fb303-g20200915-ec43a43_GH0.tar.gz) = 224086

View File

@ -0,0 +1,20 @@
--- build/fbcode_builder/CMake/FBThriftLibrary.cmake.orig 2020-09-15 21:55:13 UTC
+++ build/fbcode_builder/CMake/FBThriftLibrary.cmake
@@ -43,7 +43,7 @@ function(add_fbthrift_library LIB_NAME THRIFT_FILE)
set(PY_DEPENDS)
foreach(dep IN LISTS ARG_DEPENDS)
list(APPEND CPP_DEPENDS "${dep}_cpp")
- list(APPEND PY_DEPENDS "${dep}_py")
+ #list(APPEND PY_DEPENDS "${dep}_py")
endforeach()
foreach(lang IN LISTS ARG_LANGUAGES)
@@ -56,7 +56,7 @@ function(add_fbthrift_library LIB_NAME THRIFT_FILE)
INCLUDE_DIR "${ARG_INCLUDE_DIR}"
THRIFT_INCLUDE_DIR "${ARG_THRIFT_INCLUDE_DIR}"
)
- elseif ("${lang}" STREQUAL "py" OR "${lang}" STREQUAL "python")
+ elseif (FALSE AND "${lang}" STREQUAL "py" OR "${lang}" STREQUAL "python")
if (DEFINED ARG_PY_NAMESPACE)
set(namespace_args NAMESPACE "${ARG_PY_NAMESPACE}")
endif()

View File

@ -0,0 +1,22 @@
--- fb303/thrift/CMakeLists.txt.orig 2020-09-15 21:56:05 UTC
+++ fb303/thrift/CMakeLists.txt
@@ -15,7 +15,7 @@
add_fbthrift_library(
fb303_thrift
fb303_core.thrift
- LANGUAGES cpp py
+ LANGUAGES cpp
THRIFT_INCLUDE_DIR "${INCLUDE_INSTALL_DIR}/thrift-files"
SERVICES
BaseService
@@ -38,8 +38,10 @@ install(
DESTINATION "$<TARGET_PROPERTY:fb303_thrift_cpp,THRIFT_INSTALL_DIR>"
)
+if (FALSE)
install_fb_python_library(fb303_thrift_py EXPORT fb303-exports)
install(
TARGETS fb303_thrift_py.thrift_includes
EXPORT fb303-exports
)
+endif()

4
net/fb303/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
fb303 is a base Thrift service and a common set of functionality for querying
stats, options, and other information from a service.
WWW: https://github.com/facebook/fb303

49
net/fb303/pkg-plist Normal file
View File

@ -0,0 +1,49 @@
include/fb303/BaseService.h
include/fb303/CallbackValuesMap-inl.h
include/fb303/CallbackValuesMap.h
include/fb303/DynamicCounters.h
include/fb303/ExportType.h
include/fb303/ExportedHistogramMap.h
include/fb303/ExportedHistogramMapImpl.h
include/fb303/ExportedStatMap.h
include/fb303/ExportedStatMapImpl.h
include/fb303/FollyLoggingHandler.h
include/fb303/HistogramExporter.h
include/fb303/LegacyClock.h
include/fb303/MutexWrapper.h
include/fb303/QuantileStat-inl.h
include/fb303/QuantileStat.h
include/fb303/ServiceData.h
include/fb303/SimpleLRUMap.h
include/fb303/SynchMap-inl.h
include/fb303/SynchMap.h
include/fb303/TFunctionStatHandler.h
include/fb303/TLStatsAsyncAggregator.h
include/fb303/TLStatsLockTraits.h
include/fb303/ThreadCachedServiceData.h
include/fb303/ThreadLocalStats-inl.h
include/fb303/ThreadLocalStats.h
include/fb303/ThreadLocalStatsMap-inl.h
include/fb303/ThreadLocalStatsMap.h
include/fb303/Timeseries-inl.h
include/fb303/Timeseries.h
include/fb303/TimeseriesExporter.h
include/fb303/TimeseriesHistogram-inl.h
include/fb303/TimeseriesHistogram.h
include/fb303/detail/QuantileStatMap-inl.h
include/fb303/detail/QuantileStatMap.h
include/fb303/thrift/gen-cpp2/BaseService.h
include/fb303/thrift/gen-cpp2/BaseService.tcc
include/fb303/thrift/gen-cpp2/BaseServiceAsyncClient.h
include/fb303/thrift/gen-cpp2/BaseService_custom_protocol.h
include/fb303/thrift/gen-cpp2/fb303_core_constants.h
include/fb303/thrift/gen-cpp2/fb303_core_metadata.h
include/fb303/thrift/gen-cpp2/fb303_core_types.h
include/fb303/thrift/gen-cpp2/fb303_core_types.tcc
include/fb303/thrift/gen-cpp2/fb303_core_types_custom_protocol.h
include/thrift-files/fb303/thrift/fb303_core.thrift
lib/cmake/fb303/fb303-config.cmake
lib/cmake/fb303/fb303-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/fb303/fb303-targets.cmake
lib/libfb303.so
lib/libfb303_thrift_cpp.a