- Drop audio/libmusicbrainz support as it's deprecated and no longer
functional. It was only used for obtaining cdaudio metadata - Bump PORTREVISION PR: 168154 Submitted by: Jason E. Hale <bsdkaffee@gmail.com>
This commit is contained in:
parent
9aedb2419a
commit
2cfb986134
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298903
@ -5,7 +5,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bmp-scrobbler
|
||||
PORTREVISION= 9
|
||||
PORTREVISION= 10
|
||||
|
||||
MAINTAINER= novel@FreeBSD.org
|
||||
COMMENT= BMP plugin for Audioscrobbler.com
|
||||
|
@ -6,7 +6,7 @@
|
||||
|
||||
PORTNAME?= scrobbler
|
||||
PORTVERSION= 0.3.8.1
|
||||
PORTREVISION= 13
|
||||
PORTREVISION= 14
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://static.audioscrobbler.com/plugins/ \
|
||||
http://www.pipian.com/stuffforchat/
|
||||
@ -15,8 +15,7 @@ DISTNAME= xmms-scrobbler-${PORTVERSION}
|
||||
MAINTAINER?= novel@FreeBSD.org
|
||||
COMMENT?= XMMS/BMP plugin for Audioscrobbler.com
|
||||
|
||||
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
|
||||
curl.6:${PORTSDIR}/ftp/curl
|
||||
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
|
||||
|
||||
CONFLICTS= bmp-scrobbler-[0-9]* \
|
||||
xmms-scrobbler-[0-9]*
|
||||
|
129
audio/scrobbler/files/patch-Makefile.in
Normal file
129
audio/scrobbler/files/patch-Makefile.in
Normal file
@ -0,0 +1,129 @@
|
||||
--- ./Makefile.in.orig 2005-02-26 21:37:07.000000000 -0500
|
||||
+++ ./Makefile.in 2012-05-19 08:49:13.000000000 -0400
|
||||
@@ -78,7 +78,7 @@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
-LIBS = `curl-config --libs` -lmusicbrainz -lm -lstdc++
|
||||
+LIBS = `curl-config --libs` -lm -lstdc++
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LN_S = @LN_S@
|
||||
LTLIBOBJS = @LTLIBOBJS@
|
||||
@@ -173,9 +173,9 @@
|
||||
queue.c queue.h tags/tags.c tags/include/tags.h tags/unicode.c \
|
||||
tags/include/unicode.h fmt.c fmt.h gtkstuff.c gtkstuff.h md5.c md5.h \
|
||||
tags/include/endian.h tags/id3v1.c tags/id3v2.c tags/vorbis.c tags/ape.c \
|
||||
-tags/itunes.c tags/cdaudio.c tags/include/id3v1.h tags/include/id3v2.h \
|
||||
+tags/itunes.c tags/include/id3v1.h tags/include/id3v2.h \
|
||||
tags/include/ape.h tags/include/vorbis.h tags/include/itunes.h \
|
||||
-tags/include/cdaudio.h tags/id3genres.c tags/wma.c tags/include/wma.h
|
||||
+tags/id3genres.c tags/wma.c tags/include/wma.h
|
||||
|
||||
|
||||
libbmp_scrobbler_la_CFLAGS = $(AM_CFLAGS) @BMP_CFLAGS@ -DMAKE_BMP=1 \
|
||||
@@ -188,13 +188,13 @@
|
||||
queue.c queue.h tags/tags.c tags/include/tags.h tags/unicode.c \
|
||||
tags/include/unicode.h fmt.c fmt.h gtkstuff.c gtkstuff.h md5.c md5.h \
|
||||
tags/include/endian.h tags/id3v1.c tags/id3v2.c tags/vorbis.c tags/ape.c \
|
||||
-tags/itunes.c tags/cdaudio.c tags/include/id3v1.h tags/include/id3v2.h \
|
||||
+tags/itunes.c tags/include/id3v1.h tags/include/id3v2.h \
|
||||
tags/include/ape.h tags/include/vorbis.h tags/include/itunes.h \
|
||||
-tags/include/cdaudio.h tags/id3genres.c tags/wma.c tags/include/wma.h \
|
||||
+tags/id3genres.c tags/wma.c tags/include/wma.h \
|
||||
tags/include/bmp_vfs.h
|
||||
|
||||
|
||||
-EXTRA_DIST = README.tags KnownIssues
|
||||
+EXTRA_DIST = README.tags KnownIssues tags/cdaudio.c tags/include/cdaudio.h
|
||||
subdir = .
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
@@ -210,7 +210,7 @@
|
||||
libbmp_scrobbler_la-md5.lo libbmp_scrobbler_la-id3v1.lo \
|
||||
libbmp_scrobbler_la-id3v2.lo libbmp_scrobbler_la-vorbis.lo \
|
||||
libbmp_scrobbler_la-ape.lo libbmp_scrobbler_la-itunes.lo \
|
||||
- libbmp_scrobbler_la-cdaudio.lo libbmp_scrobbler_la-id3genres.lo \
|
||||
+ libbmp_scrobbler_la-id3genres.lo \
|
||||
libbmp_scrobbler_la-wma.lo
|
||||
libbmp_scrobbler_la_OBJECTS = $(am_libbmp_scrobbler_la_OBJECTS)
|
||||
libxmms_scrobbler_la_LIBADD =
|
||||
@@ -221,7 +221,6 @@
|
||||
libxmms_scrobbler_la-md5.lo libxmms_scrobbler_la-id3v1.lo \
|
||||
libxmms_scrobbler_la-id3v2.lo libxmms_scrobbler_la-vorbis.lo \
|
||||
libxmms_scrobbler_la-ape.lo libxmms_scrobbler_la-itunes.lo \
|
||||
- libxmms_scrobbler_la-cdaudio.lo \
|
||||
libxmms_scrobbler_la-id3genres.lo libxmms_scrobbler_la-wma.lo
|
||||
libxmms_scrobbler_la_OBJECTS = $(am_libxmms_scrobbler_la_OBJECTS)
|
||||
|
||||
@@ -229,7 +228,6 @@
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
am__depfiles_maybe = depfiles
|
||||
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/libbmp_scrobbler_la-ape.Plo \
|
||||
-@AMDEP_TRUE@ ./$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libbmp_scrobbler_la-fmt.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libbmp_scrobbler_la-gtkstuff.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libbmp_scrobbler_la-id3genres.Plo \
|
||||
@@ -245,7 +243,6 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libbmp_scrobbler_la-wma.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libbmp_scrobbler_la-xmms_scrobbler.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libxmms_scrobbler_la-ape.Plo \
|
||||
-@AMDEP_TRUE@ ./$(DEPDIR)/libxmms_scrobbler_la-cdaudio.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libxmms_scrobbler_la-fmt.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libxmms_scrobbler_la-gtkstuff.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/libxmms_scrobbler_la-id3genres.Plo \
|
||||
@@ -381,7 +378,6 @@
|
||||
-rm -f *.tab.c
|
||||
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-ape.Plo@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-fmt.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-gtkstuff.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-id3genres.Plo@am__quote@
|
||||
@@ -397,7 +393,6 @@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-wma.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libbmp_scrobbler_la-xmms_scrobbler.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libxmms_scrobbler_la-ape.Plo@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libxmms_scrobbler_la-cdaudio.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libxmms_scrobbler_la-fmt.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libxmms_scrobbler_la-gtkstuff.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libxmms_scrobbler_la-id3genres.Plo@am__quote@
|
||||
@@ -875,39 +870,6 @@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
@am__fastdepCC_FALSE@ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -c -o libbmp_scrobbler_la-itunes.lo `test -f 'tags/itunes.c' || echo '$(srcdir)/'`tags/itunes.c
|
||||
|
||||
-libbmp_scrobbler_la-cdaudio.o: tags/cdaudio.c
|
||||
-@am__fastdepCC_TRUE@ if $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -MT libbmp_scrobbler_la-cdaudio.o -MD -MP -MF "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo" \
|
||||
-@am__fastdepCC_TRUE@ -c -o libbmp_scrobbler_la-cdaudio.o `test -f 'tags/cdaudio.c' || echo '$(srcdir)/'`tags/cdaudio.c; \
|
||||
-@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo" "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Po"; \
|
||||
-@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo"; exit 1; \
|
||||
-@am__fastdepCC_TRUE@ fi
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='tags/cdaudio.c' object='libbmp_scrobbler_la-cdaudio.o' libtool=no @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Po' tmpdepfile='$(DEPDIR)/libbmp_scrobbler_la-cdaudio.TPo' @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -c -o libbmp_scrobbler_la-cdaudio.o `test -f 'tags/cdaudio.c' || echo '$(srcdir)/'`tags/cdaudio.c
|
||||
-
|
||||
-libbmp_scrobbler_la-cdaudio.obj: tags/cdaudio.c
|
||||
-@am__fastdepCC_TRUE@ if $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -MT libbmp_scrobbler_la-cdaudio.obj -MD -MP -MF "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo" \
|
||||
-@am__fastdepCC_TRUE@ -c -o libbmp_scrobbler_la-cdaudio.obj `if test -f 'tags/cdaudio.c'; then $(CYGPATH_W) 'tags/cdaudio.c'; else $(CYGPATH_W) '$(srcdir)/tags/cdaudio.c'; fi`; \
|
||||
-@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo" "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Po"; \
|
||||
-@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo"; exit 1; \
|
||||
-@am__fastdepCC_TRUE@ fi
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='tags/cdaudio.c' object='libbmp_scrobbler_la-cdaudio.obj' libtool=no @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Po' tmpdepfile='$(DEPDIR)/libbmp_scrobbler_la-cdaudio.TPo' @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -c -o libbmp_scrobbler_la-cdaudio.obj `if test -f 'tags/cdaudio.c'; then $(CYGPATH_W) 'tags/cdaudio.c'; else $(CYGPATH_W) '$(srcdir)/tags/cdaudio.c'; fi`
|
||||
-
|
||||
-libbmp_scrobbler_la-cdaudio.lo: tags/cdaudio.c
|
||||
-@am__fastdepCC_TRUE@ if $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -MT libbmp_scrobbler_la-cdaudio.lo -MD -MP -MF "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo" \
|
||||
-@am__fastdepCC_TRUE@ -c -o libbmp_scrobbler_la-cdaudio.lo `test -f 'tags/cdaudio.c' || echo '$(srcdir)/'`tags/cdaudio.c; \
|
||||
-@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo" "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Plo"; \
|
||||
-@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Tpo"; exit 1; \
|
||||
-@am__fastdepCC_TRUE@ fi
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='tags/cdaudio.c' object='libbmp_scrobbler_la-cdaudio.lo' libtool=yes @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/libbmp_scrobbler_la-cdaudio.Plo' tmpdepfile='$(DEPDIR)/libbmp_scrobbler_la-cdaudio.TPlo' @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -c -o libbmp_scrobbler_la-cdaudio.lo `test -f 'tags/cdaudio.c' || echo '$(srcdir)/'`tags/cdaudio.c
|
||||
-
|
||||
libbmp_scrobbler_la-id3genres.o: tags/id3genres.c
|
||||
@am__fastdepCC_TRUE@ if $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libbmp_scrobbler_la_CFLAGS) $(CFLAGS) -MT libbmp_scrobbler_la-id3genres.o -MD -MP -MF "$(DEPDIR)/libbmp_scrobbler_la-id3genres.Tpo" \
|
||||
@am__fastdepCC_TRUE@ -c -o libbmp_scrobbler_la-id3genres.o `test -f 'tags/id3genres.c' || echo '$(srcdir)/'`tags/id3genres.c; \
|
12
audio/scrobbler/files/patch-config.h.in
Normal file
12
audio/scrobbler/files/patch-config.h.in
Normal file
@ -0,0 +1,12 @@
|
||||
--- ./config.h.in.orig 2005-02-20 14:26:40.000000000 -0500
|
||||
+++ ./config.h.in 2012-05-19 08:49:13.000000000 -0400
|
||||
@@ -12,9 +12,6 @@
|
||||
/* Define to 1 if you have the <inttypes.h> header file. */
|
||||
#undef HAVE_INTTYPES_H
|
||||
|
||||
-/* Define to 1 if you have the `musicbrainz' library (-lmusicbrainz). */
|
||||
-#undef HAVE_LIBMUSICBRAINZ
|
||||
-
|
||||
/* Define to 1 if you have the <memory.h> header file. */
|
||||
#undef HAVE_MEMORY_H
|
||||
|
173
audio/scrobbler/files/patch-configure
Normal file
173
audio/scrobbler/files/patch-configure
Normal file
@ -0,0 +1,173 @@
|
||||
--- ./configure.orig 2005-02-26 21:37:06.000000000 -0500
|
||||
+++ ./configure 2012-05-19 08:49:13.000000000 -0400
|
||||
@@ -22548,145 +22548,6 @@
|
||||
|
||||
|
||||
|
||||
-
|
||||
-echo "$as_me:$LINENO: checking for mb_GetVersion in -lmusicbrainz" >&5
|
||||
-echo $ECHO_N "checking for mb_GetVersion in -lmusicbrainz... $ECHO_C" >&6
|
||||
-if test "${ac_cv_lib_musicbrainz_mb_GetVersion+set}" = set; then
|
||||
- echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
-else
|
||||
- ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lmusicbrainz -lstdc++ $LIBS"
|
||||
-cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-/* Override any gcc2 internal prototype to avoid an error. */
|
||||
-#ifdef __cplusplus
|
||||
-extern "C"
|
||||
-#endif
|
||||
-/* We use char because int might match the return type of a gcc2
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-char mb_GetVersion ();
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-mb_GetVersion ();
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>conftest.er1
|
||||
- ac_status=$?
|
||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
||||
- rm -f conftest.er1
|
||||
- cat conftest.err >&5
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } &&
|
||||
- { ac_try='test -z "$ac_c_werror_flag"
|
||||
- || test ! -s conftest.err'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; } &&
|
||||
- { ac_try='test -s conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- ac_cv_lib_musicbrainz_mb_GetVersion=yes
|
||||
-else
|
||||
- echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-ac_cv_lib_musicbrainz_mb_GetVersion=no
|
||||
-fi
|
||||
-rm -f conftest.err conftest.$ac_objext \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
-LIBS=$ac_check_lib_save_LIBS
|
||||
-fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_lib_musicbrainz_mb_GetVersion" >&5
|
||||
-echo "${ECHO_T}$ac_cv_lib_musicbrainz_mb_GetVersion" >&6
|
||||
-if test $ac_cv_lib_musicbrainz_mb_GetVersion = yes; then
|
||||
- cat >>confdefs.h <<_ACEOF
|
||||
-#define HAVE_LIBMUSICBRAINZ 1
|
||||
-_ACEOF
|
||||
-
|
||||
- LIBS="-lmusicbrainz $LIBS"
|
||||
-
|
||||
-else
|
||||
- echo "*"
|
||||
- echo "* The MusicBrainz client library needs to be installed "
|
||||
- echo "* to build this plugin. Please download the library from "
|
||||
- echo "* http://www.musicbrainz.org/download "
|
||||
- echo "*"
|
||||
- { { echo "$as_me:$LINENO: error: \"Cannot build. Stop.\"" >&5
|
||||
-echo "$as_me: error: \"Cannot build. Stop.\"" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-LIBS="-lmusicbrainz -lstdc++"
|
||||
-if test "$cross_compiling" = yes; then
|
||||
- have_mbver=false
|
||||
-else
|
||||
- cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-#include <musicbrainz/mb_c.h>
|
||||
-
|
||||
-int main ()
|
||||
-{
|
||||
- int major, minor, rev;
|
||||
- musicbrainz_t o;
|
||||
-
|
||||
- o = mb_New();
|
||||
- mb_GetVersion(o, &major, &minor, &rev);
|
||||
- mb_Delete(o);
|
||||
- if (major >= 2)
|
||||
- {
|
||||
- return 0;
|
||||
- }
|
||||
-
|
||||
- return -1;
|
||||
-}
|
||||
-
|
||||
-_ACEOF
|
||||
-rm -f conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- have_mbver=true
|
||||
-else
|
||||
- echo "$as_me: program exited with status $ac_status" >&5
|
||||
-echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-( exit $ac_status )
|
||||
-have_mbver=false
|
||||
-fi
|
||||
-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-
|
||||
if test "${my_cv_curl_vers+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
@@ -22727,24 +22588,6 @@
|
||||
|
||||
LIBS="$LIBS $GTKLIBS"
|
||||
|
||||
-echo "$as_me:$LINENO: checking for version >= 2.0.0 in -lmusicbrainz" >&5
|
||||
-echo $ECHO_N "checking for version >= 2.0.0 in -lmusicbrainz... $ECHO_C" >&6
|
||||
-if test "$have_mbver" = "false"; then
|
||||
- echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6
|
||||
- echo "*"
|
||||
- echo "* Version 2.0.0 or higher of the MusicBrainz "
|
||||
- echo "* client library needs to be installed to build this application. "
|
||||
- echo "* Please download the library from: "
|
||||
- echo "* http://musicbrainz.org/products/client/download.html "
|
||||
- echo "*"
|
||||
- { { echo "$as_me:$LINENO: error: Cannot build. Stop." >&5
|
||||
-echo "$as_me: error: Cannot build. Stop." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-else
|
||||
- echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6
|
||||
-fi
|
||||
|
||||
ac_config_files="$ac_config_files Makefile"
|
||||
cat >confcache <<\_ACEOF
|
26
audio/scrobbler/files/patch-tags__include__tags.h
Normal file
26
audio/scrobbler/files/patch-tags__include__tags.h
Normal file
@ -0,0 +1,26 @@
|
||||
--- ./tags/include/tags.h.orig 2012-05-19 17:35:23.000000000 -0400
|
||||
+++ ./tags/include/tags.h 2012-05-19 17:36:12.000000000 -0400
|
||||
@@ -31,7 +31,6 @@
|
||||
#include "vorbis.h"
|
||||
#include "itunes.h"
|
||||
#include "ape.h"
|
||||
-#include "cdaudio.h"
|
||||
|
||||
extern const char *genre_list[148];
|
||||
|
||||
@@ -59,7 +58,6 @@
|
||||
has_oggflac,
|
||||
has_speex,
|
||||
has_itunes,
|
||||
- has_cdaudio,
|
||||
prefer_ape;
|
||||
wma_t *wma;
|
||||
id3v1_t *id3v1;
|
||||
@@ -70,7 +68,6 @@
|
||||
*oggflac,
|
||||
*speex;
|
||||
itunes_t *itunes;
|
||||
- cdaudio_t *cdaudio;
|
||||
} metatag_t;
|
||||
|
||||
void get_tag_data(metatag_t *, char *, int);
|
58
audio/scrobbler/files/patch-tags__tags.c
Normal file
58
audio/scrobbler/files/patch-tags__tags.c
Normal file
@ -0,0 +1,58 @@
|
||||
--- ./tags/tags.c.orig 2005-02-20 13:08:42.000000000 -0500
|
||||
+++ ./tags/tags.c 2012-05-19 08:49:13.000000000 -0400
|
||||
@@ -141,37 +141,6 @@
|
||||
return;
|
||||
}
|
||||
|
||||
-void metaCD(metatag_t *meta, char *filename, int track)
|
||||
-{
|
||||
- int tmp;
|
||||
-
|
||||
- pdebug("Getting CD Audio metadata...", META_DEBUG);
|
||||
- meta->cdaudio = readCDAudio(filename, track);
|
||||
- if(meta->cdaudio == NULL)
|
||||
- {
|
||||
- pdebug("Error getting metadata", META_DEBUG);
|
||||
-
|
||||
- return;
|
||||
- }
|
||||
-
|
||||
- meta->has_cdaudio = 1;
|
||||
-
|
||||
- pdebug("Reading metadata into structs...", META_DEBUG);
|
||||
- meta->artist = meta->cdaudio->artist;
|
||||
- meta->title = meta->cdaudio->title;
|
||||
- meta->mb = realloc(meta->mb, strlen(meta->cdaudio->mbid) + 1);
|
||||
- strcpy(meta->mb, meta->cdaudio->mbid);
|
||||
- meta->album = meta->cdaudio->album;
|
||||
- meta->year = NULL;
|
||||
- meta->genre = NULL;
|
||||
- /* Special track handling... Yay! */
|
||||
- meta->track = realloc(meta->track, 4);
|
||||
- tmp = snprintf(meta->track, 3, "%d", track);
|
||||
- *(meta->track + tmp) = '\0';
|
||||
-
|
||||
- return;
|
||||
-} /* End CD Audio support */
|
||||
-
|
||||
static ape_t *fetchAPE(char *filename)
|
||||
{
|
||||
ape_t *ape;
|
||||
@@ -693,8 +662,6 @@
|
||||
{
|
||||
if(track > 0)
|
||||
{
|
||||
- metaCD(meta, filename, track);
|
||||
-
|
||||
return;
|
||||
}
|
||||
else
|
||||
@@ -801,8 +768,6 @@
|
||||
freeVorbis(meta->speex);
|
||||
if(meta->itunes != NULL)
|
||||
freeiTunes(meta->itunes);
|
||||
- if(meta->cdaudio != NULL)
|
||||
- freeCDAudio(meta->cdaudio);
|
||||
free(meta);
|
||||
}
|
||||
|
@ -5,7 +5,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xmms-scrobbler
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
|
||||
MAINTAINER= novel@FreeBSD.org
|
||||
COMMENT= XMMS plugin for Audioscrobbler.com
|
||||
|
Loading…
Reference in New Issue
Block a user