Fix build on powerpc and strip binaries.
PR: 222722 Submitted by: Mark Millard <markmi@dsl-only.net>
This commit is contained in:
parent
cdd7a975cd
commit
2cdc46338d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=451181
@ -28,10 +28,6 @@ PERL_USES= perl5
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
|
||||
CONFIGURE_ARGS+=--enable-64bit
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPERL}
|
||||
PLIST_SUB= PERL=""
|
||||
CONFIGURE_ARGS+=--with-perl=${PERL}
|
||||
@ -52,6 +48,8 @@ PLIST_SUB+= JAVA="@comment "
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pdfimage ${STAGEDIR}${PREFIX}/bin/text2pdf \
|
||||
${STAGEDIR}${PREFIX}/lib/libpdf.so.6.0.5
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}/fonts
|
||||
${INSTALL_DATA} ${WRKSRC}/fonts/* ${STAGEDIR}${DATADIR}/fonts
|
||||
.if ${PORT_OPTIONS:MJAVA}
|
||||
|
11
print/pdflib/files/patch-libs_pdcore_pc__config.h
Normal file
11
print/pdflib/files/patch-libs_pdcore_pc__config.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- libs/pdcore/pc_config.h.orig 2017-10-04 07:15:35 UTC
|
||||
+++ libs/pdcore/pc_config.h
|
||||
@@ -180,7 +180,7 @@
|
||||
/* try to identify Mac OS 9 compilers */
|
||||
|
||||
#if (defined macintosh || defined __POWERPC__ || defined __CFM68K__) && \
|
||||
- !defined MAC && !defined MACOSX && !defined __BEOS__
|
||||
+ !defined MAC && !defined MACOSX && !defined __BEOS__ && !defined __FreeBSD__
|
||||
#define MAC
|
||||
#endif
|
||||
|
Loading…
Reference in New Issue
Block a user