- Add upstream patch to address segfault issue with tcl-8.6

- Bump portrevision
This commit is contained in:
Beech Rintoul 2011-10-06 17:54:31 +00:00
parent 34eed15e2a
commit 2ca9248922
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=283059
2 changed files with 24 additions and 3 deletions

View File

@ -10,6 +10,7 @@
PORTNAME= eggdrop
PORTVERSION= 1.6.20
PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/ \
http://www.egghelp.org/files/patches/:ssl
@ -20,8 +21,9 @@ DISTFILES= ${PORTNAME}${PORTVERSION}.tar.bz2 \
MAINTAINER= beech@FreeBSD.org
COMMENT= The most popular open source Internet Relay Chat bot
USE_TCL= 85+
LICENSE= GPLv2
USE_TCL= 85+
GNU_CONFIGURE= yes
#CONFIGURE_ARGS= --with-tcllib=${LOCALBASE}/lib/libtcl${TCL_VER:S/.//}.so \
# --with-tclinc=${TCL_INCLUDEDIR}/tcl.h
@ -35,8 +37,6 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
LICENSE= GPLv2
.if defined(WITH_SSL)
. if ${ARCH} == "amd64"
BROKEN= ssl support is broken on amd64

View File

@ -0,0 +1,21 @@
--- src/tclhash.c.orig 2011-10-06 09:19:05.000000000 -0800
+++ src/tclhash.c 2011-10-06 09:25:14.000000000 -0800
@@ -1264,7 +1264,7 @@
for (i = 0; cc[i].name; i++) {
egg_snprintf(p, sizeof p, "*%s:%s", tl->name,
cc[i].funcname ? cc[i].funcname : cc[i].name);
- l = nmalloc(Tcl_ScanElement(p, &k));
+ l = nmalloc(Tcl_ScanElement(p, &k) + 1);
Tcl_ConvertElement(p, l, k | TCL_DONT_USE_BRACES);
table[0].cdata = (void *) cc[i].func;
add_cd_tcl_cmds(table);
@@ -1282,7 +1282,7 @@
for (i = 0; cc[i].name; i++) {
egg_snprintf(p, sizeof p, "*%s:%s", table->name,
cc[i].funcname ? cc[i].funcname : cc[i].name);
- l = nmalloc(Tcl_ScanElement(p, &k));
+ l = nmalloc(Tcl_ScanElement(p, &k) + 1);
Tcl_ConvertElement(p, l, k | TCL_DONT_USE_BRACES);
Tcl_DeleteCommand(interp, p);
unbind_bind_entry(table, cc[i].flags, cc[i].name, l);