Wv is converter from MS Word to several data format such HTML, PDF, PS
and so on. It's formely known as textproc/mswordview. textproc/mswordview will be disappeared. Submitted by: mzaki@e-mail.ne.jp Repo copied by: PW
This commit is contained in:
parent
45d903f0f2
commit
2c79e23fd3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34846
@ -103,6 +103,7 @@
|
||||
SUBDIR += wdiff
|
||||
SUBDIR += word2x
|
||||
SUBDIR += wordnet
|
||||
SUBDIR += wv
|
||||
SUBDIR += xerces
|
||||
SUBDIR += xhtml
|
||||
SUBDIR += xlhtml
|
||||
|
@ -1,25 +1,29 @@
|
||||
# New ports collection makefile for: mswordview
|
||||
# New ports collection makefile for: wv
|
||||
# Date created: Fri Nov 6 09:06:33 PST 1998
|
||||
# Whom: sumikawa@kame.net
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mswordview
|
||||
PORTVERSION= 0.5.14.6
|
||||
PORTNAME= wv
|
||||
PORTVERSION= 0.6.2
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.csn.ul.ie/~caolan/publink/mswordview/
|
||||
DISTNAME= ${PORTNAME}-0.5.14-bw6
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= wvware
|
||||
|
||||
MAINTAINER= sumikawa@kame.net
|
||||
MAINTAINER= mzaki@e-mail.ne.jp
|
||||
|
||||
LIB_DEPENDS= wmf.1:${PORTSDIR}/graphics/libwmf
|
||||
|
||||
WRKSRC= ${WRKDIR}/mswordview
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ttf=${LOCALBASE} --with-wmf=${LOCALBASE}
|
||||
CONFIGURE_ARGS= --with-ttf=${LOCALBASE} --with-wmf=${LOCALBASE} \
|
||||
--with-png=${LOCALBASE} --with-xpm=${X11BASE}
|
||||
USE_GMAKE= yes
|
||||
USE_XLIB= yes
|
||||
|
||||
MAN1= mswordview.1
|
||||
MAN1= wvAbw.1 wvCleanLatex.1 wvDVI.1 wvHtml.1 wvLatex.1 wvMime.1 \
|
||||
wvPDF.1 wvPS.1 wvSummary.1 wvText.1 wvVersion.1 wvWare.1 wvWml.1
|
||||
MLINKS= wvWare.1 wvConvert.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (mswordview-0.5.14-bw6.tar.gz) = e2f32426c4bf20f351fa64f148c84202
|
||||
MD5 (wv-0.6.2.tar.gz) = 5b4e3fbd9e285297c459df1d7a588d4e
|
||||
|
@ -1,79 +1,11 @@
|
||||
--- support.c Mon May 17 15:27:00 1999
|
||||
+++ support.c.new Sun Jul 2 22:24:08 2000
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "utf.h"
|
||||
#ifdef HAVE_WMF
|
||||
#include "gdwmfapi.h"
|
||||
+#include "xgdttf.h"
|
||||
--- configure.orig Sat Nov 4 22:02:07 2000
|
||||
+++ configure Sat Nov 4 22:02:46 2000
|
||||
@@ -3936,7 +3936,7 @@
|
||||
|
||||
#include <sys/mman.h>
|
||||
|
||||
@@ -1195,7 +1196,7 @@
|
||||
GDStruct gdstruct;
|
||||
static int text;
|
||||
|
||||
- error(erroroutput,"1 converting wmf to gif, via libwmf\n");
|
||||
+ error(erroroutput,"1 converting wmf to png, via libwmf\n");
|
||||
#ifdef HAVE_TTF
|
||||
if (text == 0)
|
||||
{
|
||||
@@ -1224,7 +1225,7 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
- error(erroroutput,"2 converting wmf to gif, via libwmf\n");
|
||||
+ error(erroroutput,"2 converting wmf to png, via libwmf\n");
|
||||
wmfinit(cstruct);
|
||||
|
||||
wmffunctions = &gd_wmffunctions;
|
||||
@@ -1252,7 +1253,7 @@
|
||||
return;
|
||||
}
|
||||
|
||||
- error(erroroutput,"3 converting wmf to gif, via libwmf\n");
|
||||
+ error(erroroutput,"3 converting wmf to png, via libwmf\n");
|
||||
|
||||
cstruct->preparse = 1;
|
||||
PlayMetaFile((void *)cstruct,file);
|
||||
@@ -1263,7 +1264,7 @@
|
||||
cstruct->preparse = 0;
|
||||
PlayMetaFile((void *)cstruct,file);
|
||||
|
||||
- strcat(filename,".gif");
|
||||
+ strcat(filename,".png");
|
||||
|
||||
out = fopen(filename, "wb");
|
||||
if (out == NULL)
|
||||
@@ -1276,15 +1277,15 @@
|
||||
return;
|
||||
}
|
||||
|
||||
- error(erroroutput,"4 converting wmf to gif, via libwmf\n");
|
||||
+ error(erroroutput,"4 converting wmf to png, via libwmf\n");
|
||||
|
||||
- /* write gif */
|
||||
- gdImageGif(gdstruct.im_out, out);
|
||||
+ /* write png */
|
||||
+ gdImagePng(gdstruct.im_out, out);
|
||||
fclose(out);
|
||||
|
||||
gdImageDestroy(gdstruct.im_out);
|
||||
|
||||
- error(erroroutput,"5 converting wmf to gif, via libwmf\n");
|
||||
+ error(erroroutput,"5 converting wmf to png, via libwmf\n");
|
||||
|
||||
free(file->pmh);
|
||||
free(file->wmfheader);
|
||||
@@ -1296,10 +1297,10 @@
|
||||
ourlist = NULL;
|
||||
}
|
||||
*/
|
||||
- error(erroroutput,"6 converting wmf to gif, via libwmf\n");
|
||||
+ error(erroroutput,"6 converting wmf to png, via libwmf\n");
|
||||
|
||||
#else
|
||||
- fprintf(erroroutput,"unable to convert wmf to gif as mswordview \
|
||||
+ fprintf(erroroutput,"unable to convert wmf to png as mswordview \
|
||||
was compiled without libwmf support\n\
|
||||
libwmf can be found at http://www.csn.ul.ie/~caolan/docs/libwmf.html\n");
|
||||
#endif
|
||||
HAVE_WMF=1
|
||||
WMF_CFLAGS="-I$WMF_DIR/include"
|
||||
- WMF_LIBS="-L$WMF_DIR/lib -lgdwmf"
|
||||
+ WMF_LIBS="-L$WMF_DIR/lib -lgdwmf -lxgd -lwmf"
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
||||
|
@ -1 +1 @@
|
||||
MS-WORD to HTML converter
|
||||
A library and executables which allow access to Microsoft Word files.
|
||||
|
@ -1,8 +1,10 @@
|
||||
MSWordView is a program that can understand the microsofts word 8
|
||||
binary file format (office97), it currently converts word into html,
|
||||
which can then be read with a browser.
|
||||
It is also capable of converting Japanese MS Word document
|
||||
wv is a library which allows access to Microsoft Word files.
|
||||
It can load and parse the Word 6-9 formats (Word 6, 95, 97, 2000).
|
||||
|
||||
WWW: http://www.csn.ul.ie/~caolan/docs/MSWordView.html
|
||||
And several converter executables called wvWare are also provided:
|
||||
wvHtml, wvLatex, wvCleanLatex, wvDVI, wvPS, wvPDF,
|
||||
wvText, wvAbw, wvWml, wvMime
|
||||
|
||||
port made by: sumikawa@kame.net
|
||||
note: wvHtml is previously known as MSWordView.
|
||||
|
||||
WWW: http://wvware.sourceforge.net/
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user