games/adonthell: Update to 0.3.7

- Remove gcc dependency
- For sanity remove Waste's Edge demo game to be readded as a separate port
- Take maintainership

Changes:	http://adonthell.nongnu.org/news/
This commit is contained in:
Tobias Kortkamp 2018-08-19 19:27:52 +00:00
parent 3763299290
commit 2c5be35550
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=477590
11 changed files with 21 additions and 219 deletions

View File

@ -3,64 +3,35 @@
# $MCom: ports/games/adonthell/Makefile,v 1.1 2006/10/04 20:13:33 ahze Exp $
PORTNAME= adonthell
PORTVERSION= 0.3.5
PORTREVISION= 18
PORTVERSION= 0.3.7
CATEGORIES= games
MASTER_SITES= SAVANNAH
DISTFILES= ${PORTNAME}-src-${PORTVERSION}${EXTRACT_SUFX} \
wastesedge-src-${WEDGE_VERSION}${EXTRACT_SUFX}
DISTFILES= ${PORTNAME}-src-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Free role playing game
MAINTAINER= tobik@FreeBSD.org
COMMENT= Role playing game engine
LICENSE= GPLv2
LICENSE_DISTFILES= ${DISTFILES}
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libfreetype.so:print/freetype2
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
USES= gettext gmake python:2.7
USE_SDL= mixer ttf sdl
USE_GCC= any
USES= gettext gmake localbase pkgconfig python:2.7
USE_SDL= mixer2 ttf2
GNU_CONFIGURE= yes
CONFIGURE_ENV= PYPACKAGE="${PYTHON_CMD}" ac_cv_path_P_SWIG=no
CONFIGURE_ARGS= --disable-py-debug
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-py-debug --disable-pyc \
--with-python=${PYTHON_CMD} \
--with-py-libs="-lpython${PYTHON_VER}"
PLIST_DIRS= ${DATADIR}/games
PLIST_FILES= bin/adonthell \
bin/adonthell-${PORTVERSION:R} \
bin/adonthell-wastesedge \
share/pixmaps/wastesedge_16x16.xpm \
share/pixmaps/wastesedge_32x32.xpm
PORTDATA= *
BROKEN_sparc64= Does not build on sparc64
DESKTOP_ENTRIES="Adonthell" "" "" "adonthell" "" ""
WEDGE_VERSION= 0.3.5
man/man6/adonthell.6.gz \
${DATADIR}/modules/adonthell.py \
${DATADIR}/modules/dialogue.py
post-patch:
@cd ${WRKSRC} && ${REINPLACE_CMD} -e \
's|-g -Wall|$$CFLAGS -Wall|g ; \
s|-lpthread|-pthread|g' configure
@cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${REINPLACE_CMD} -e \
's|@adonthell_binary@|${PREFIX}/bin/adonthell|' Makefile.in
@cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${REINPLACE_CMD} -e \
's|test $$adonthell_major_ver -eq 0 .*|true ;|' configure
@cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${REINPLACE_CMD} -e \
's|^[[:space:]]*_||' scripts/modules/player_text.py
post-install:
cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} \
&& ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS} \
--with-adonthell-binary=${STAGEDIR}${PREFIX}/bin/adonthell \
${CONFIGURE_TARGET}
cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${SETENV} HOME=${WRKDIR} \
${MAKE_CMD}
cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${SETENV} HOME=${WRKDIR} \
${MAKE_CMD} ${MAKE_ARGS} ${INSTALL_TARGET}
@${REINPLACE_CMD} 's,adonthell-0.3,adonthell,g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>

View File

@ -1,4 +1,3 @@
SHA256 (adonthell-src-0.3.5.tar.gz) = b1b24f26b9f32782793b222c687943442be83fc0d7f5dbb4928a61074be36dd7
SIZE (adonthell-src-0.3.5.tar.gz) = 877439
SHA256 (wastesedge-src-0.3.5.tar.gz) = f872a2dc89ca454523f5b55c7fc8b29986dae8bc72f52647a6e1dab3f2a30674
SIZE (wastesedge-src-0.3.5.tar.gz) = 10749912
TIMESTAMP = 1534706592
SHA256 (adonthell-src-0.3.7.tar.gz) = b94258666932bbae0e2fe0bcaf31c373a55a01c8977d24b9f45e1f11887ae8b5
SIZE (adonthell-src-0.3.7.tar.gz) = 889006

View File

@ -1,17 +0,0 @@
--- src/Makefile.in.orig 2008-05-29 19:00:50.000000000 +0000
+++ src/Makefile.in
@@ -769,13 +769,12 @@ uninstall-am: uninstall-binPROGRAMS
# Note: adonthell.py is also built by this target.
py_adonthell_wrap.cc : py_adonthell.i $(headers)
- @if test "${P_SWIG}"; then \
+ @if [ "${P_SWIG}" != "no" ]; then \
echo ${P_SWIG} -python -modern -shadow ${SDL_CFLAGS} -I$(srcdir) -I$(top_srcdir) -c++ -makedefault -o $(srcdir)/$*.cc $(srcdir)/py_adonthell.i; \
${P_SWIG} -python -modern -shadow ${SDL_CFLAGS} -I$(srcdir) -I$(top_srcdir) -c++ -makedefault -o $(srcdir)/$*.cc $(srcdir)/py_adonthell.i; \
mv $(srcdir)/adonthell.py modules/adonthell.py; \
else \
echo "You need swig >= ${SWIG_MINVER} in order to re-build this file."; \
- exit 1; \
fi;
lex.prefs.cc : prefs.l

View File

@ -1,41 +0,0 @@
--- src/dialog.cc.orig 2007-11-21 17:49:38.000000000 +0100
+++ src/dialog.cc 2007-11-21 17:52:11.000000000 +0100
@@ -90,7 +90,7 @@
{
s = PyList_GetItem (list, i);
if (s && PyString_Check (s)) strings[i] = PyString_AsString (s);
- else strings[i] = "*** Error";
+ else strings[i] = (char *)"*** Error";
}
Py_DECREF (list);
@@ -157,7 +157,7 @@
do
{
// Execute the next part of the dialogue
- arg = Py_BuildValue ("(i)", answer);
+ arg = Py_BuildValue ((char *)"(i)", answer);
// run next part of dialogue
dialogue.run (arg);
@@ -222,7 +222,7 @@
}
// check whether we shall continue or not
- arg = Py_BuildValue ("(i)", answer);
+ arg = Py_BuildValue ((char *)"(i)", answer);
result = dialogue.call_method_ret ("stop", arg);
stop = PyInt_AsLong (result);
Py_XDECREF (result);
@@ -298,9 +298,9 @@
strncpy (str, start+3, end);
if (the_player->storage::get_val ("gender") == FEMALE)
- mid = get_substr (str, "{", "/");
+ mid = get_substr (str, (char *)"{", (char *)"/");
else
- mid = get_substr (str, "/", "}");
+ mid = get_substr (str, (char *)"/", (char *)"}");
begin = newstr.length () - strlen(start);
tmp = new char[newstr.length () - end + strlen (mid)];

View File

@ -1,11 +0,0 @@
--- src/label.cc.orig 2008-05-29 18:42:50.000000000 +0000
+++ src/label.cc
@@ -645,7 +645,7 @@ void label::cursor_previous ()
}
-const string label::text_string () const
+const string & label::text_string () const
{
return my_text_;
}

View File

@ -1,11 +0,0 @@
--- src/label.h.orig 2005-04-16 17:56:32.000000000 +0000
+++ src/label.h
@@ -90,7 +90,7 @@ public :
/**
Get the text in string
*/
- const string text_string () const;
+ const string & text_string () const;
/**

View File

@ -1,13 +0,0 @@
--- src/map_event_handler.cc.orig Fri Apr 29 05:30:43 2005
+++ src/map_event_handler.cc Fri Apr 29 05:30:44 2005
@@ -19,9 +19,9 @@
* @brief Implements the map_event_handler class.
*/
-#include <algorithm>
#include "map_event.h"
#include "map_event_handler.h"
+#include <algorithm>
// See whether a matching event is registered and execute the

View File

@ -1,11 +0,0 @@
--- src/prefs.cc.orig 2007-11-21 17:58:31.000000000 +0100
+++ src/prefs.cc 2007-11-21 17:58:43.000000000 +0100
@@ -144,7 +144,7 @@
case 'c':
{
python::init ();
- python::exec_string ("import compileall; compileall.compile_dir (\".\", 0);");
+ python::exec_string ((char *)"import compileall; compileall.compile_dir (\".\", 0);");
python::cleanup ();
exit (0);
break;

View File

@ -1,40 +0,0 @@
--- src/py_callback.cc.orig 2007-11-21 17:53:00.000000000 +0100
+++ src/py_callback.cc 2007-11-21 17:54:03.000000000 +0100
@@ -55,7 +55,7 @@
// calls the python function without argument
void py_callback::callback_func0 ()
{
- PyObject *py_arg = arguments ? Py_BuildValue ("(O)",arguments) : NULL;
+ PyObject *py_arg = arguments ? Py_BuildValue ((char *)"(O)",arguments) : NULL;
PyObject* val = make_call (py_arg);
Py_XDECREF (val);
}
@@ -65,7 +65,7 @@
{
int retval = 1;
- PyObject *py_arg = arguments ? Py_BuildValue ("(O)",arguments) : NULL;
+ PyObject *py_arg = arguments ? Py_BuildValue ((char *)"(O)",arguments) : NULL;
PyObject* val = make_call (py_arg);
if (val) retval = PyInt_AsLong (val);
@@ -79,8 +79,8 @@
{
PyObject *py_arg;
- if (arguments) py_arg = Py_BuildValue ("(i,O)", arg, arguments);
- else py_arg = Py_BuildValue ("(i)", arg);
+ if (arguments) py_arg = Py_BuildValue ((char *)"(i,O)", arg, arguments);
+ else py_arg = Py_BuildValue ((char *)"(i)", arg);
PyObject * val = make_call (py_arg);
Py_XDECREF (val);
@@ -93,7 +93,7 @@
// get name of callback function
if (function) {
- PyObject *p_name = PyObject_GetAttrString (function, "__name__");
+ PyObject *p_name = PyObject_GetAttrString (function, (char *)"__name__");
if (PyString_Check (p_name)) name = PyString_AsString (p_name);
else fprintf (stderr, "*** error: py_callback::put_state: Failed to retrieve callback name!");

View File

@ -1,11 +0,0 @@
--- src/win_event.cc.orig 2002-12-16 19:09:54.000000000 +0000
+++ src/win_event.cc
@@ -35,7 +35,7 @@ void win_event::py_signal_connect (PyObj
case DESTROY:
{
set_callback_destroy (
- makeFunctor (&Functor0wRet<bool>(), *callback, &py_callback::callback_func0ret));
+ makeFunctor (new Functor0wRet<bool>(), *callback, &py_callback::callback_func0ret));
break;
}

View File

@ -1,13 +0,0 @@
--- src/win_select.cc.orig Fri Apr 29 05:39:00 2005
+++ src/win_select.cc Fri Apr 29 05:39:04 2005
@@ -12,9 +12,9 @@
See the COPYING file for more details
*/
+#include "audio.h"
#include "win_select.h"
-#include "audio.h"
win_select::win_select()
{