This is still badly broken, but this fixes the worst bugs (at least it

gets started, the lib part compiles now).  Chief problems were that
the configure script was looking for thot in an archive named Thot, and
the configure script requires all enables/disables, withs/withouts
to be explicitly laid out, else there's a ream of sed errors.
Oh, yeah, the WRKSRC had to be explitly created too.
This commit is contained in:
Chuck Robey 1999-09-22 04:36:58 +00:00
parent 2a84888391
commit 2c344b40d3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21876
4 changed files with 34 additions and 34 deletions

View File

@ -21,6 +21,7 @@ DISTFILES= ${THOT_SRC} ${EDITOR_SRC}
MAINTAINER= chuckr@FreeBSD.org
BROKEN= 'FUBARed'
WRKSRC= $(WRKDIR)/Thot/objects
THOT_SRC= thot-src-2.1e.tar.gz
EDITOR_SRC= thoteditor-src-2.1e.tar.gz
@ -28,12 +29,17 @@ EDITOR_SRC= thoteditor-src-2.1e.tar.gz
EXTRACT_ONLY= ${THOT_SRC}
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin
USE_GMAKE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
USE_GMAKE= yes
ALL_TARGET= all schemas
do-configure:
(cd $(WRKDIR)/Thot/objects;../configure $(CONFIGURE_ARGS))
post-extract:
(${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${EDITOR_SRC} ${EXTRACT_AFTER_ARGS} -C ${WRKSRC})
(${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${EDITOR_SRC} ${EXTRACT_AFTER_ARGS} -C ${WRKDIR}/Thot)
(cd $(WRKDIR)/Thot;$(MKDIR) objects)
post-install:
${MKDIR} ${PREFIX}/share/thot/doc

View File

@ -1,19 +1,24 @@
*** tools/javastub/javastub.c.orig Sun Aug 24 00:04:06 1997
--- tools/javastub/javastub.c Sun Aug 24 00:04:49 1997
***************
*** 11,17 ****
#include <stdio.h>
#include <stdlib.h>
! #include "config.h"
#include <ctype.h>
#include <string.h>
--- 11,17 ----
#include <stdio.h>
#include <stdlib.h>
! #include "../../config.h"
#include <ctype.h>
#include <string.h>
--- ../configure.orig Wed Sep 22 00:01:33 1999
+++ ../configure Wed Sep 22 00:04:04 1999
@@ -5261,7 +5261,7 @@
build_amaya="no"
fi
-if test ! -f $srcdir/thot/Makefile.in ; then
+if test ! -f $srcdir/Thot/Makefile.in ; then
echo "configure: warning: Thot editor sources not found" 1>&2
build_thot="no"
fi
@@ -5594,10 +5594,10 @@
if test "$build_thot" = "yes" ; then
- make_output="$make_output thot/Makefile \
+ make_output="$make_output Thot/Makefile \
drawlib/Makefile indexlib/Makefile"
EXTRA_MAKEFILE_IN="$EXTRA_MAKEFILE_IN \
-$srcdir/thot/Makefile.in \
+$srcdir/Thot/Makefile.in \
$srcdir/drawlib/Makefile.in \
$srcdir/indexlib/Makefile.in"

View File

@ -1,11 +0,0 @@
--- thot/Makefile.in.orig Fri May 16 07:00:19 1997
+++ thot/Makefile.in Fri Feb 12 15:11:54 1999
@@ -13,7 +13,7 @@
-I@top_srcdir@/drawlib -I@top_srcdir@/drawlib/f
LDFLAGS = @LDFLAGS@ -L../indexlib -L../drawlib -L../tablelib -L../thotlib -L..
LIBS = -lThotIndex -lThotDraw -lThotTable -lThotEditor @IMGLIBS@ \
- $(MOTIF_LIBRARIES) -lXm $(X_LIBS) -lXt -lXext $(X_PRE_LIBS) \
+ ${MOTIFLIB} $(X_LIBS) -lXp -lXt -lXext $(X_PRE_LIBS) \
-lX11 $(X_EXTRA_LIBS) @LIBS@ @EXTRA_LIBS@ -lm
prefix = @prefix@

View File

@ -1,5 +1,5 @@
--- makes/Makefile.template.orig Tue May 6 23:55:03 1997
+++ makes/Makefile.template Fri Feb 12 15:06:58 1999
--- ../makes/Makefile.template.orig Tue May 6 23:55:03 1997
+++ ../makes/Makefile.template Fri Feb 12 15:06:58 1999
@@ -56,7 +56,7 @@
# MOTIFLIBS : how to grab Motif at link time.
# X11R6 probably need -lSM -lICE