add retawq 0.0.5

An interactive, multi-threaded web browser for text terminals
This commit is contained in:
Ying-Chieh Liao 2001-12-30 18:52:17 +00:00
parent b892dcdb05
commit 2c0a6c05c4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=52418
7 changed files with 77 additions and 0 deletions

View File

@ -291,6 +291,7 @@
SUBDIR += quanta
SUBDIR += quixote
SUBDIR += reportmagic
SUBDIR += retawq
SUBDIR += roxen
SUBDIR += ruboard
SUBDIR += ruby-http-access

37
www/retawq/Makefile Normal file
View File

@ -0,0 +1,37 @@
# ex:ts=8
# Ports collection makefile for: retawq
# Date created: Dec 30, 2001
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= retawq
PORTVERSION= 0.0.5
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
USE_GMAKE= yes
MAKE_ENV= LDFLAGS="${LDFLAGS}"
ALL_TARGET= # empty
post-patch:
@${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g ; \
s,%%LOCALBASE%%,${LOCALBASE},g ; \
s,%%PREFIX%%,${PREFIX},g ; \
s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/retawq ${PREFIX}/bin
.for lang in de fr
${INSTALL_DATA} ${WRKSRC}/i18n/${lang}.mo ${PREFIX}/share/locale/${lang}/LC_MESSAGES/${PORTNAME}.mo
.endfor
.include <bsd.port.mk>

1
www/retawq/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (retawq-0.0.5.tar.gz) = 20fae30f25f1fce0dff40457c4004a81

View File

@ -0,0 +1,26 @@
--- Makefile.orig Wed Nov 28 23:24:02 2001
+++ Makefile Mon Dec 31 02:39:44 2001
@@ -16,11 +16,11 @@
CONFIG_CED = 1
# i18n (internationalization)
-CONFIG_I18N = 0
-CONFIG_I18N_PATH = \"/usr/share/locale\"
+CONFIG_I18N = 1
+CONFIG_I18N_PATH = \"%%LOCALBASE%%/share/locale\"
# path for "make install"; don't forget the trailing "/"!
-INSTALL_BINPREFIX = /usr/bin/
+INSTALL_BINPREFIX = %%PREFIX%%/bin/
# put your favourite C compiler here; mine is "gcc" ;-)
CC = gcc
@@ -128,7 +128,7 @@
@echo "#define CONFIG_DEBUG $(CONFIG_DEBUG)" >> .config
retawq: $(OBJS)
- $(CC) $(OBJS) $(LCLT) $(LCLC) -o retawq
+ $(CC) $(OBJS) $(LCLT) $(LCLC) -o retawq ${LDFLAGS}
stripsyms:
-strip --strip-unneeded retawq

1
www/retawq/pkg-comment Normal file
View File

@ -0,0 +1 @@
An interactive, multi-threaded web browser for text terminals

8
www/retawq/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
retawq is an interactive, multi-threaded network client ("web browser") for
text terminals on computers with Unix-like operating systems (Linux, BSD,
Solaris, ...). It is fast, small, nicely configurable, and comfortable;
e.g. the low-level communications are performed in a non-blocking way, and
you can keep open as many "virtual windows" as you want and work
simultaneously in two of them in a split-screen mode.
WWW: http://retawq.sourceforge.net/

3
www/retawq/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/retawq
share/locale/de/LC_MESSAGES/retawq.mo
share/locale/fr/LC_MESSAGES/retawq.mo