Cdecl composes compilable C declarations and typecasts from descriptive

English phrases, and can also explain a complicated typecast or declaration.
It handles ANSI C, C++, pre-ANSI C, and K&R C, and has TAB completion of
keywords and line editing and history (provided by the GNU readline library).
This commit is contained in:
David E. O'Brien 1999-09-05 05:07:08 +00:00
parent 2973fb8992
commit 2bc00d96c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21269
7 changed files with 72 additions and 0 deletions

30
devel/cdecl/Makefile Normal file
View File

@ -0,0 +1,30 @@
# ex:ts=8
# Ports collection makefile for: cdecl
# Version required: 2.5
# Date created: Sat Sep 04, 1999
# Whom: David O'Brien (obrien@NUXI.com)
#
# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
#
DISTNAME= cdecl-2.5
CATEGORIES= devel
MASTER_SITES= ftp://ftp.netsw.org/netsw/SoftEng/Lang/C/Tools/cdecl/ \
ftp://ftp.cc.gatech.edu/ac121/linux/devel/lang/c/ \
ftp://ftp.deva.net/pub/sources/programming/ \
ftp://ftp.bitcon.no//pub/linux/linuxberg/files/console/dev/ \
ftp://ftp.uakom.sk/pub/linux/devel/lang/c/
MAINTAINER= obrien@FreeBSD.org
ALL_TARGET=
MAN1= cdecl.1
MLINKS= cdecl.1 c++decl.1
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/cdecl
${INSTALL_DATA} ${WRKSRC}/testset* ${PREFIX}/share/doc/cdecl
.endif
.include <bsd.port.mk>

1
devel/cdecl/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (cdecl-2.5.tar.gz) = 29895dab52e85b2474a59449e07b7996

View File

@ -0,0 +1,20 @@
--- Makefile.orig Mon Jan 15 21:36:38 1996
+++ Makefile Sat Sep 4 22:02:21 1999
@@ -15,13 +15,13 @@
#
# add -DUSE_READLINE To compile in support for the GNU readline library.
-CFLAGS= -s -O2 -DUSE_READLINE
+CFLAGS+= -s -DUSE_READLINE
CC= gcc
LIBS= -lreadline -ltermcap
ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
-BINDIR= /usr/bin
-MANDIR= /usr/man/man1
-CATDIR= /usr/man/cat1
+BINDIR= $(PREFIX)/bin
+MANDIR= $(PREFIX)/man/man1
+CATDIR= $(PREFIX/usr/man/cat1
INSTALL= install -c
INSTALL_DATA= install -c -m 644

View File

@ -0,0 +1,12 @@
--- cdecl.c.orig Mon Jan 15 19:54:46 1996
+++ cdecl.c Sat Sep 4 20:02:59 1999
@@ -67,6 +67,9 @@
# include <stddef.h>
# include <string.h>
# include <stdarg.h>
+# ifndef DOS
+# include <errno.h> /* only M$-DOS environments have ``errno'' in stdlib.h */
+# endif /* ndef DOS */
#else
# ifndef NOVARARGS
# include <varargs.h>

1
devel/cdecl/pkg-comment Normal file
View File

@ -0,0 +1 @@
Explains complicated C/C++ declarations in plain English

4
devel/cdecl/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
Cdecl composes compilable C declarations and typecasts from descriptive
English phrases, and can also explain a complicated typecast or declaration.
It handles ANSI C, C++, pre-ANSI C, and K&R C, and has TAB completion of
keywords and line editing and history (provided by the GNU readline library).

4
devel/cdecl/pkg-plist Normal file
View File

@ -0,0 +1,4 @@
bin/cdecl
bin/c++decl
share/doc/cdecl/testset
share/doc/cdecl/testset++