Teach the original Makefile about NOPORTDOCS.

Reported by:	QAT
This commit is contained in:
Jimmy Olgeni 2010-09-30 20:05:20 +00:00
parent 81cd33b283
commit 2ae704fad3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=262207
2 changed files with 25 additions and 8 deletions

View File

@ -54,10 +54,11 @@ PLIST_SUB+= ODBC=""
PLIST_SUB+= ODBC="@comment "
.endif
post-patch:
.ifdef NOPORTDOCS
@${REINPLACE_CMD} -e '/DOCDIR)$$/s/^/#/g' ${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)
MAKE_ARGS+= NOPORTDOCS=${NOPORTDOCS}
.endif
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/configure
post-install:

View File

@ -1,6 +1,6 @@
--- Makefile.in.orig 2010-03-12 11:40:41.000000000 +0100
+++ Makefile.in 2010-04-08 17:23:18.000000000 +0200
@@ -82,7 +82,7 @@
--- Makefile.in.orig
+++ Makefile.in
@@ -89,7 +89,7 @@
SBINDIR = $(DESTDIR)@sbindir@
# /lib/ejabberd/
@ -9,7 +9,7 @@
# /share/doc/ejabberd
PACKAGE_TARNAME = @PACKAGE_TARNAME@
@@ -108,7 +108,7 @@
@@ -115,7 +115,7 @@
MSGSDIR = $(PRIVDIR)/msgs
# /var/lib/ejabberd/
@ -18,7 +18,7 @@
# /var/lock/ejabberdctl
CTLLOCKDIR = $(DESTDIR)@localstatedir@/lock/ejabberdctl
@@ -171,25 +171,22 @@
@@ -178,25 +178,22 @@
#
# Configuration files
install -d -m 750 $(G_USER) $(ETCDIR)
@ -51,3 +51,19 @@
#
# Init script
sed -e "s*@ctlscriptpath@*$(SBINDIR)*" \
@@ -253,6 +250,7 @@
chmod -R 750 $(LOGDIR)
#
# Documentation
+ifndef NOPORTDOCS
install -d $(DOCDIR)
install -m 644 ../doc/dev.html $(DOCDIR)
install -m 644 ../doc/guide.html $(DOCDIR)
@@ -262,6 +260,7 @@
&& install -m 644 ../doc/guide.pdf $(DOCDIR) \
|| echo "No ../doc/guide.pdf was built"
install -m 644 ../COPYING $(DOCDIR)
+endif
uninstall: uninstall-binary