SimGear is a toolkit for 3D games and simulations.
This commit is contained in:
parent
cb3bcee301
commit
2a83ced1b9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73752
@ -801,6 +801,7 @@
|
||||
SUBDIR += shtool
|
||||
SUBDIR += sigslot
|
||||
SUBDIR += silc-toolkit
|
||||
SUBDIR += simgear
|
||||
SUBDIR += simulavr
|
||||
SUBDIR += sip
|
||||
SUBDIR += soup
|
||||
|
29
devel/simgear/Makefile
Normal file
29
devel/simgear/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: SimGear
|
||||
# Date created: 2003-01-21
|
||||
# Whom: des
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= SimGear
|
||||
PORTVERSION= 0.3.1
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= ftp://ftp.simgear.org/pub/simgear/Source/ \
|
||||
ftp://ftp.de.flightgear.org/pub/simgear/
|
||||
|
||||
MAINTAINER= des@FreeBSD.org
|
||||
|
||||
# These should be LIB_DEPENDS, but it seems bsd.port.mk can't handle
|
||||
# versionless or static libraries.
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit \
|
||||
${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_MESA= yes
|
||||
GNU_CONFIGURE= yes
|
||||
# Force configure to look in /usr/local/{include,lib}
|
||||
CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/simgear/distinfo
Normal file
1
devel/simgear/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (SimGear-0.3.1.tar.gz) = 1711909a9175a193ae2c3c7093d2745c
|
11
devel/simgear/files/patch-aa
Normal file
11
devel/simgear/files/patch-aa
Normal file
@ -0,0 +1,11 @@
|
||||
--- simgear/xgl/xglUtils.c.orig Tue Jan 21 23:22:54 2003
|
||||
+++ simgear/xgl/xglUtils.c Tue Jan 21 23:24:28 2003
|
||||
@@ -4,7 +4,7 @@
|
||||
#include <string.h>
|
||||
|
||||
#if !defined( WIN32 )
|
||||
-# if !defined( HAVE_STL_SGI_PORT ) && !defined( __MWERKS__ ) && !defined( __APPLE__ )
|
||||
+# if !defined( HAVE_STL_SGI_PORT ) && !defined( __MWERKS__ ) && !defined( __APPLE__ ) && !defined( __FreeBSD__ )
|
||||
// Avoid malloc with STLport and MSL
|
||||
# include <malloc.h>
|
||||
# endif
|
1
devel/simgear/pkg-comment
Normal file
1
devel/simgear/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A toolkit for 3D games and simulations
|
12
devel/simgear/pkg-descr
Normal file
12
devel/simgear/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
SimGear is a set of open-source libraries designed to be used as
|
||||
building blocks for quickly assembling 3d simulations, games, and
|
||||
visualization applications.
|
||||
|
||||
SimGear is a relatively new project, and while quite a bit of code has
|
||||
been written in conjunction with the FlightGear project, the final
|
||||
interface and arrangements are still evolving.
|
||||
|
||||
The term "Simulation Kernel" is a bit presumptuous for us at this
|
||||
point, but this is the direction we are heading with SimGear.
|
||||
|
||||
WWW: http://www.simgear.org/
|
105
devel/simgear/pkg-plist
Normal file
105
devel/simgear/pkg-plist
Normal file
@ -0,0 +1,105 @@
|
||||
include/simgear/bucket/newbucket.hxx
|
||||
include/simgear/compiler.h
|
||||
include/simgear/constants.h
|
||||
include/simgear/debug/debug_types.h
|
||||
include/simgear/debug/logstream.hxx
|
||||
include/simgear/ephemeris/celestialBody.hxx
|
||||
include/simgear/ephemeris/ephemeris.hxx
|
||||
include/simgear/ephemeris/jupiter.hxx
|
||||
include/simgear/ephemeris/mars.hxx
|
||||
include/simgear/ephemeris/mercury.hxx
|
||||
include/simgear/ephemeris/moonpos.hxx
|
||||
include/simgear/ephemeris/neptune.hxx
|
||||
include/simgear/ephemeris/saturn.hxx
|
||||
include/simgear/ephemeris/star.hxx
|
||||
include/simgear/ephemeris/stardata.hxx
|
||||
include/simgear/ephemeris/uranus.hxx
|
||||
include/simgear/ephemeris/venus.hxx
|
||||
include/simgear/io/iochannel.hxx
|
||||
include/simgear/io/lowlevel.hxx
|
||||
include/simgear/io/sg_binobj.hxx
|
||||
include/simgear/io/sg_file.hxx
|
||||
include/simgear/io/sg_serial.hxx
|
||||
include/simgear/io/sg_socket.hxx
|
||||
include/simgear/io/sg_socket_udp.hxx
|
||||
include/simgear/magvar/magvar.hxx
|
||||
include/simgear/math/interpolater.hxx
|
||||
include/simgear/math/leastsqs.hxx
|
||||
include/simgear/math/localconsts.hxx
|
||||
include/simgear/math/point3d.hxx
|
||||
include/simgear/math/polar3d.hxx
|
||||
include/simgear/math/sg_geodesy.hxx
|
||||
include/simgear/math/sg_memory.h
|
||||
include/simgear/math/sg_random.h
|
||||
include/simgear/math/sg_types.hxx
|
||||
include/simgear/math/vector.hxx
|
||||
include/simgear/metar/MetarReport.h
|
||||
include/simgear/metar/MetarStation.h
|
||||
include/simgear/misc/commands.hxx
|
||||
include/simgear/misc/exception.hxx
|
||||
include/simgear/misc/props.hxx
|
||||
include/simgear/misc/props_io.hxx
|
||||
include/simgear/misc/sg_path.hxx
|
||||
include/simgear/misc/sgstream.hxx
|
||||
include/simgear/misc/stopwatch.hxx
|
||||
include/simgear/misc/strutils.hxx
|
||||
include/simgear/misc/texcoord.hxx
|
||||
include/simgear/misc/zfstream.hxx
|
||||
include/simgear/route/route.hxx
|
||||
include/simgear/route/waypoint.hxx
|
||||
include/simgear/screen/screen-dump.hxx
|
||||
include/simgear/screen/tr.h
|
||||
include/simgear/serial/serial.hxx
|
||||
include/simgear/sg_inlines.h
|
||||
include/simgear/sg_traits.hxx
|
||||
include/simgear/sg_zlib.h
|
||||
include/simgear/sky/cloud.hxx
|
||||
include/simgear/sky/clouds3d/SkySceneLoader.hpp
|
||||
include/simgear/sky/clouds3d/SkyUtil.hpp
|
||||
include/simgear/sky/dome.hxx
|
||||
include/simgear/sky/moon.hxx
|
||||
include/simgear/sky/oursun.hxx
|
||||
include/simgear/sky/sky.hxx
|
||||
include/simgear/sky/sphere.hxx
|
||||
include/simgear/sky/stars.hxx
|
||||
include/simgear/timing/geocoord.h
|
||||
include/simgear/timing/lowleveltime.h
|
||||
include/simgear/timing/sg_time.hxx
|
||||
include/simgear/timing/timestamp.hxx
|
||||
include/simgear/timing/timezone.h
|
||||
include/simgear/version.h
|
||||
include/simgear/xgl/xgl.h
|
||||
include/simgear/xml/easyxml.hxx
|
||||
lib/libsgbucket.a
|
||||
lib/libsgclouds3d.a
|
||||
lib/libsgdebug.a
|
||||
lib/libsgephem.a
|
||||
lib/libsgio.a
|
||||
lib/libsgmagvar.a
|
||||
lib/libsgmath.a
|
||||
lib/libsgmetar.a
|
||||
lib/libsgmisc.a
|
||||
lib/libsgroute.a
|
||||
lib/libsgscreen.a
|
||||
lib/libsgserial.a
|
||||
lib/libsgsky.a
|
||||
lib/libsgtiming.a
|
||||
lib/libsgxgl.a
|
||||
lib/libsgxml.a
|
||||
@dirrm include/simgear/xml
|
||||
@dirrm include/simgear/xgl
|
||||
@dirrm include/simgear/timing
|
||||
@dirrm include/simgear/sky/clouds3d
|
||||
@dirrm include/simgear/sky
|
||||
@dirrm include/simgear/serial
|
||||
@dirrm include/simgear/screen
|
||||
@dirrm include/simgear/route
|
||||
@dirrm include/simgear/misc
|
||||
@dirrm include/simgear/metar
|
||||
@dirrm include/simgear/math
|
||||
@dirrm include/simgear/magvar
|
||||
@dirrm include/simgear/io
|
||||
@dirrm include/simgear/ephemeris
|
||||
@dirrm include/simgear/debug
|
||||
@dirrm include/simgear/bucket
|
||||
@dirrm include/simgear
|
Loading…
Reference in New Issue
Block a user