Update to 1.0.6. Due to incompatibilities between our USE_LIBTOOL hack and
newest autocrap used to generate distribution I had to remove USE_LIBTOOL and use homemade patch to get rid of those .la files.
This commit is contained in:
parent
61951c68d7
commit
2a25c285e2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44711
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= bonobo
|
||||
PORTVERSION= 1.0.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.0.6
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= stable/sources/bonobo
|
||||
@ -20,9 +19,8 @@ USE_X_PREFIX= yes
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOMECTRL= yes
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFILES= configure libefs/configure
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
@ -33,9 +31,4 @@ pre-patch:
|
||||
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
|
||||
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
|
||||
|
||||
# XXX: hack - will be fixed in next release - say hi to
|
||||
# GNOME release engineering :)
|
||||
post-patch:
|
||||
@find ${WRKSRC} -name '*.idl' | xargs touch
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (bonobo-1.0.4.tar.gz) = 63375f80dc362e006f4c4f85017c1941
|
||||
MD5 (bonobo-1.0.6.tar.gz) = 336bc4a60f507138e57498e2ac63169e
|
||||
|
@ -1,20 +1,18 @@
|
||||
--- Makefile.in.orig Sat Aug 12 21:17:01 2000
|
||||
+++ Makefile.in Mon Aug 14 10:44:14 2000
|
||||
@@ -149,3 +149,3 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in.orig Tue Jul 3 15:35:08 2001
|
||||
+++ Makefile.in Tue Jul 3 15:37:04 2001
|
||||
@@ -157,10 +157,10 @@
|
||||
|
||||
NULL =
|
||||
|
||||
-SUBDIRS = macros intl idl libefs bonobo storage-modules monikers components samples gshell tests doc po
|
||||
+SUBDIRS = macros intl idl libefs bonobo storage-modules monikers components samples gshell doc po
|
||||
|
||||
|
||||
-confexecdir = $(libdir)
|
||||
+confexecdir = $(sysconfdir)
|
||||
confexec_DATA = bonoboConf.sh bonoboxConf.sh bonobox_printConf.sh
|
||||
--- po/Makefile.in.in.orig Mon Feb 21 23:37:16 2000
|
||||
+++ po/Makefile.in.in Tue Feb 22 11:18:13 2000
|
||||
@@ -18,8 +18,8 @@
|
||||
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
-datadir = $(prefix)/@DATADIRNAME@
|
||||
-localedir = $(datadir)/locale
|
||||
+datadir = $(prefix)/share/locale
|
||||
+localedir = $(prefix)/share/locale
|
||||
gnulocaledir = $(prefix)/share/locale
|
||||
gettextsrcdir = $(prefix)/share/gettext/po
|
||||
subdir = po
|
||||
include_HEADERS = bonobo.h
|
||||
|
18
devel/bonobo/files/patch-ltmain.sh
Normal file
18
devel/bonobo/files/patch-ltmain.sh
Normal file
@ -0,0 +1,18 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/07/03 12:57:52 1.1
|
||||
+++ ltmain.sh 2001/07/03 12:58:32
|
||||
@@ -4175,10 +4175,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -92,7 +92,9 @@ include/efs_error.h
|
||||
lib/bonobo/monikers/libmoniker_std.a
|
||||
lib/bonobo/monikers/libmoniker_std.so
|
||||
lib/bonobo/monikers/libmoniker_std.so.0
|
||||
lib/bonobo/plugin/libstorage_efs.a
|
||||
lib/bonobo/plugin/libstorage_efs.so
|
||||
lib/bonobo/plugin/libstorage_fs.a
|
||||
lib/bonobo/plugin/libstorage_fs.so
|
||||
lib/libbonobo-print.a
|
||||
lib/libbonobo-print.so
|
||||
|
Loading…
Reference in New Issue
Block a user