x11-wm/pekwm: Update to 0.2.0

PR:		259674
Reported by:	Natacha Porté (maintainer)
This commit is contained in:
Olivier Cochard 2021-11-08 16:21:46 +01:00
parent e886c38c6e
commit 2a0f516067
5 changed files with 44 additions and 83 deletions

View File

@ -2,31 +2,25 @@
PORTNAME= pekwm
DISTVERSIONPREFIX= release-
DISTVERSION= 0.1.17
PORTREVISION= 5
DISTVERSION= 0.2.0
PORTEPOCH= 1
CATEGORIES= x11-wm
MAINTAINER= natbsd@instinctive.eu
COMMENT= Light, unobtrusive, and configurable window manager
COMMENT= Light, Unobtrusive, and configurable windowmanager
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpng.so:graphics/png
LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2
RUN_DEPENDS= gsed:textproc/gsed \
xprop:x11/xprop
USES= autoreconf compiler gmake iconv:wchar_t jpeg \
USES= cmake compiler jpeg \
localbase pkgconfig tar:bzip2 xorg
USE_XORG= xft xpm x11 sm ice xext xinerama xrandr
USE_GITHUB= yes
GH_ACCOUNT= pekdon
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shape --enable-xinerama --enable-xrandr \
--enable-xft --enable-image-xpm --enable-image-jpeg \
--enable-image-png --disable-debug \
--disable-pedantic
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
LDFLAGS+= ${ICONV_LIB}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1585563189
SHA256 (pekdon-pekwm-release-0.1.17_GH0.tar.gz) = 7b5a07a377494588e95d68b87a3f4d823f813cb29053618bfad691a00cd8afb6
SIZE (pekdon-pekwm-release-0.1.17_GH0.tar.gz) = 429100
TIMESTAMP = 1636193572
SHA256 (pekdon-pekwm-release-0.2.0_GH0.tar.gz) = 143df0021665a7a1e06c22540f45ca3392235cb3dd2e0be70f9e00fd988fc9f9
SIZE (pekdon-pekwm-release-0.2.0_GH0.tar.gz) = 941616

View File

@ -1,66 +0,0 @@
--- data/scripts/pekwm_screenshot.sh.orig 2013-05-24 19:24:23 UTC
+++ data/scripts/pekwm_screenshot.sh
@@ -1,30 +1,30 @@
-#!/usr/bin/env bash
+#!/bin/sh
#
# Copyright © 2013 the pekwm development team
#
-function screenshot_scrot
+screenshot_scrot()
{
scrot -z "$1"
}
-function screenshot_xwd_netpbm
+screenshot_xwd_netpbm()
{
xwd -root | xwdtopnm 2>/dev/null | pnmtopng > "$1"
}
-function screenshot_imagemagick
+screenshot_imagemagick()
{
import -window root "$1"
}
-function is_in_path
+is_in_path()
{
which $1 >/dev/null 2>&1
return $?
}
-function detect_command
+detect_command()
{
is_in_path "scrot"
if test $? -eq 0; then
@@ -45,7 +45,7 @@ function detect_command
fi
}
-function usage
+usage()
{
echo "usage: pekwm_screenshot.sh [-c scrot|netpbm|magick] [-d delay] [-o output.png]"
echo ""
@@ -61,7 +61,7 @@ function usage
exit 0
}
-function usage_command
+usage_command()
{
echo "Unable to find any supported commands for taking screenshots"
echo ""
@@ -74,7 +74,7 @@ function usage_command
exit 1
}
-function main
+main()
{
# Initialize for strict mode
command=""

View File

@ -0,0 +1,8 @@
--- doc/CMakeLists.txt.orig 2021-11-06 11:24:56.636609000 +0100
+++ doc/CMakeLists.txt 2021-11-06 11:25:10.749968000 +0100
@@ -13,4 +13,4 @@
install(FILES
${manpages}
- DESTINATION share/man/man1)
+ DESTINATION man/man1)

View File

@ -1,15 +1,25 @@
%%DATADIR%%/scripts/pekwm_screenshot.sh
%%DATADIR%%/scripts/pekwm_themeset.sh
%%DATADIR%%/scripts/pekwm_ws_menu.sh
%%DATADIR%%/themes/default-plain/theme
%%DATADIR%%/themes/default/arrow.png
%%DATADIR%%/themes/default/arrow_focus.png
%%DATADIR%%/themes/default/backgrounds/pekwm_generated-1920x1080.png
%%DATADIR%%/themes/default/backgrounds/pekwm_generated-2560x1440.png
%%DATADIR%%/themes/default/bottom-border.png
%%DATADIR%%/themes/default/bottom-border_unfocus.png
%%DATADIR%%/themes/default/bottom-left.png
%%DATADIR%%/themes/default/bottom-left_unfocus.png
%%DATADIR%%/themes/default/bottom-right.png
%%DATADIR%%/themes/default/bottom-right_unfocus.png
%%DATADIR%%/themes/default/button-close.png
%%DATADIR%%/themes/default/button-close_hover.png
%%DATADIR%%/themes/default/button-close_press.png
%%DATADIR%%/themes/default/button-max.png
%%DATADIR%%/themes/default/button-max_hover.png
%%DATADIR%%/themes/default/button-max_press.png
%%DATADIR%%/themes/default/button-min.png
%%DATADIR%%/themes/default/button-min_hover.png
%%DATADIR%%/themes/default/button-min_press.png
%%DATADIR%%/themes/default/button.png
%%DATADIR%%/themes/default/button_hover.png
%%DATADIR%%/themes/default/button_press.png
@ -21,6 +31,7 @@
%%DATADIR%%/themes/default/menu-bottom.png
%%DATADIR%%/themes/default/menu-bottom_unfocus.png
%%DATADIR%%/themes/default/menuline.png
%%DATADIR%%/themes/default/panel.png
%%DATADIR%%/themes/default/right-border.png
%%DATADIR%%/themes/default/right-border_unfocus.png
%%DATADIR%%/themes/default/tab-separator.png
@ -32,9 +43,17 @@
%%DATADIR%%/themes/default/top-border_unfocus.png
%%DATADIR%%/themes/default/top-left.png
%%DATADIR%%/themes/default/top-left_unfocus.png
%%DATADIR%%/themes/default/top-right-no-buttons.png
%%DATADIR%%/themes/default/top-right.png
%%DATADIR%%/themes/default/top-right_unfocus.png
bin/pekwm
bin/pekwm_bg
bin/pekwm_ctrl
bin/pekwm_dialog
bin/pekwm_panel
bin/pekwm_screenshot
bin/pekwm_theme
bin/pekwm_wm
%%ETCDIR%%/autoproperties
%%ETCDIR%%/autoproperties_typerules
%%ETCDIR%%/config
@ -45,6 +64,12 @@ bin/pekwm
%%ETCDIR%%/mouse_click
%%ETCDIR%%/mouse_sloppy
%%ETCDIR%%/mouse_system
%%ETCDIR%%/panel
%%ETCDIR%%/start
%%ETCDIR%%/vars
man/man1/pekwm.1.gz
man/man1/pekwm_bg.1.gz
man/man1/pekwm_dialog.1.gz
man/man1/pekwm_panel.1.gz
man/man1/pekwm_screenshot.1.gz
man/man1/pekwm_theme.1.gz