x11/wayland-logout: update to 1.1

- Switch to more efficient code on FreeBSD 13.0

Changes:	https://github.com/soreau/wayland-logout/compare/v1.0...v1.1
Reported by:	portscout
This commit is contained in:
Jan Beich 2020-12-27 04:36:16 +00:00
parent e38dd037bc
commit 29d39e6fa2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559342
3 changed files with 17 additions and 32 deletions

View File

@ -2,22 +2,24 @@
PORTNAME= wayland-logout
DISTVERSIONPREFIX= v
DISTVERSION= 1.0
DISTVERSION= 1.1
CATEGORIES= x11
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= 6e0c13c8b198.patch:-p1 # https://github.com/soreau/wayland-logout/pull/6
PATCHFILES+= 64eb1c3c9a4d.patch:-p1 # https://github.com/soreau/wayland-logout/pull/6
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Simple logout on Wayland
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= meson
USE_GITHUB= yes
GH_ACCOUNT= soreau
NO_ARCH= yes
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
MESON_ARGS= ${${OPSYS} == FreeBSD && ${OSREL:R} >= 13:?-Dimplementation=c:}
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>

View File

@ -1,3 +1,7 @@
TIMESTAMP = 1599853712
SHA256 (soreau-wayland-logout-v1.0_GH0.tar.gz) = 445eb9a978481871dbc51ea0e9cde57ca9f778eda55ecd8a5aac205a71e7f0e6
SIZE (soreau-wayland-logout-v1.0_GH0.tar.gz) = 16663
TIMESTAMP = 1607050775
SHA256 (soreau-wayland-logout-v1.1_GH0.tar.gz) = 814765492340d52c3371f46a37f0ebae1225f2db686ff0eab57c9464b80d756f
SIZE (soreau-wayland-logout-v1.1_GH0.tar.gz) = 17731
SHA256 (6e0c13c8b198.patch) = e22a33f9b4b99e3450b7527fc6124c7ee1bca93f95ae89fbb56b6b4a404ed98d
SIZE (6e0c13c8b198.patch) = 1110
SHA256 (64eb1c3c9a4d.patch) = df379f6e150417facd1973bb2dbc435bb3212d8a2edc09277481cfc0a0f32d36
SIZE (64eb1c3c9a4d.patch) = 818

View File

@ -1,21 +0,0 @@
lsof is slow and not supported on DragonFly
--- wayland-logout.sh.orig 2020-09-11 19:48:32 UTC
+++ wayland-logout.sh
@@ -1,7 +1,5 @@
#!/bin/sh
-# REQUIREMENTS - lsof (not always present)
-
if [ -z "${WAYLAND_DISPLAY}" ]; then
printf '%s\n' 'Error: WAYLAND_DISPLAY not set'
exit 1
@@ -21,7 +19,7 @@ case "${WAYLAND_DISPLAY}" in
;;
esac
-WAYLAND_PIDS="$(lsof -t -f -- ${SOCKET_PATH})"
+WAYLAND_PIDS="$(sockstat -lu | awk "\$6 == \"${SOCKET_PATH}\" { print \$3 }" | uniq)"
set -- $WAYLAND_PIDS
if [ $# -gt 1 ]; then
printf '%s\n' 'Error: More than one process has been bound to the socket'