- Update to version 1.2.8

- Remove RELENG_4 BROKEN message
This commit is contained in:
Markus Brueffer 2007-02-07 19:11:03 +00:00
parent cfc928de0e
commit 2964049c0a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=184525
8 changed files with 8 additions and 106 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= tellico
PORTVERSION= 1.2.7
PORTVERSION= 1.2.8
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/tellico/download/
@ -30,10 +30,6 @@ OPTIONS= CDDB "CDDB support" on \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not compile on FreeBSD 4.x
.endif
.if defined(WITHOUT_CDDB)
CONFIGURE_ARGS+=--disable-libkcddb
.else

View File

@ -1,3 +1,3 @@
MD5 (tellico-1.2.7.tar.gz) = 51635d215ac43d8c90125cc24a28fe46
SHA256 (tellico-1.2.7.tar.gz) = bc5e8d1aa90d8b6d902d0c1e01814a77dac95188f911e3788c81da6cf4197916
SIZE (tellico-1.2.7.tar.gz) = 4684384
MD5 (tellico-1.2.8.tar.gz) = ac9be76e26edaf9f75cddb03ee4ed73b
SHA256 (tellico-1.2.8.tar.gz) = b6c111c713aa56844a4293a87a932888faec3cfd8c465d7fdab8686acd9f6806
SIZE (tellico-1.2.8.tar.gz) = 4689201

View File

@ -1,34 +0,0 @@
--- src/fetch/z3950connection.cpp.orig Thu Jan 11 18:50:07 2007
+++ src/fetch/z3950connection.cpp Fri Jan 12 11:13:31 2007
@@ -340,16 +340,16 @@
inline
QCString Z3950Connection::toCString(const QString& text_) {
- return iconv(text_.utf8(), QString::fromLatin1("utf-8"), m_sourceCharSet);
+ return iConv(text_.utf8(), QString::fromLatin1("utf-8"), m_sourceCharSet);
}
inline
QString Z3950Connection::toString(const QCString& text_) {
- return QString::fromUtf8(iconv(text_, m_sourceCharSet, QString::fromLatin1("utf-8")));
+ return QString::fromUtf8(iConv(text_, m_sourceCharSet, QString::fromLatin1("utf-8")));
}
// static
-QCString Z3950Connection::iconv(const QCString& text_, const QString& fromCharSet_, const QString& toCharSet_) {
+QCString Z3950Connection::iConv(const QCString& text_, const QString& fromCharSet_, const QString& toCharSet_) {
#if HAVE_YAZ
if(text_.isEmpty()) {
return text_;
@@ -365,9 +365,9 @@
QString charSetLower = fromCharSet_.lower();
charSetLower.remove('-').remove(' ');
if(charSetLower == Latin1Literal("iso5426")) {
- return iconv(Iso5426Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
+ return iConv(Iso5426Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
} else if(charSetLower == Latin1Literal("iso6937")) {
- return iconv(Iso6937Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
+ return iConv(Iso6937Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
}
kdWarning() << "Z3950Fetcher::iconv() - conversion from " << fromCharSet_
<< " to " << toCharSet_ << " is unsupported" << endl;

View File

@ -1,11 +0,0 @@
--- src/fetch/z3950connection.h.orig Fri Jan 12 11:14:04 2007
+++ src/fetch/z3950connection.h Fri Jan 12 11:14:17 2007
@@ -85,7 +85,7 @@
void abort() { m_aborted = true; }
private:
- static QCString iconv(const QCString& text, const QString& fromCharSet, const QString& toCharSet);
+ static QCString iConv(const QCString& text, const QString& fromCharSet, const QString& toCharSet);
static QString toXML(const QCString& marc, const QString& fromCharSet);
bool makeConnection();

View File

@ -6,7 +6,7 @@
#
PORTNAME= tellico
PORTVERSION= 1.2.7
PORTVERSION= 1.2.8
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/tellico/download/
@ -30,10 +30,6 @@ OPTIONS= CDDB "CDDB support" on \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not compile on FreeBSD 4.x
.endif
.if defined(WITHOUT_CDDB)
CONFIGURE_ARGS+=--disable-libkcddb
.else

View File

@ -1,3 +1,3 @@
MD5 (tellico-1.2.7.tar.gz) = 51635d215ac43d8c90125cc24a28fe46
SHA256 (tellico-1.2.7.tar.gz) = bc5e8d1aa90d8b6d902d0c1e01814a77dac95188f911e3788c81da6cf4197916
SIZE (tellico-1.2.7.tar.gz) = 4684384
MD5 (tellico-1.2.8.tar.gz) = ac9be76e26edaf9f75cddb03ee4ed73b
SHA256 (tellico-1.2.8.tar.gz) = b6c111c713aa56844a4293a87a932888faec3cfd8c465d7fdab8686acd9f6806
SIZE (tellico-1.2.8.tar.gz) = 4689201

View File

@ -1,34 +0,0 @@
--- src/fetch/z3950connection.cpp.orig Thu Jan 11 18:50:07 2007
+++ src/fetch/z3950connection.cpp Fri Jan 12 11:13:31 2007
@@ -340,16 +340,16 @@
inline
QCString Z3950Connection::toCString(const QString& text_) {
- return iconv(text_.utf8(), QString::fromLatin1("utf-8"), m_sourceCharSet);
+ return iConv(text_.utf8(), QString::fromLatin1("utf-8"), m_sourceCharSet);
}
inline
QString Z3950Connection::toString(const QCString& text_) {
- return QString::fromUtf8(iconv(text_, m_sourceCharSet, QString::fromLatin1("utf-8")));
+ return QString::fromUtf8(iConv(text_, m_sourceCharSet, QString::fromLatin1("utf-8")));
}
// static
-QCString Z3950Connection::iconv(const QCString& text_, const QString& fromCharSet_, const QString& toCharSet_) {
+QCString Z3950Connection::iConv(const QCString& text_, const QString& fromCharSet_, const QString& toCharSet_) {
#if HAVE_YAZ
if(text_.isEmpty()) {
return text_;
@@ -365,9 +365,9 @@
QString charSetLower = fromCharSet_.lower();
charSetLower.remove('-').remove(' ');
if(charSetLower == Latin1Literal("iso5426")) {
- return iconv(Iso5426Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
+ return iConv(Iso5426Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
} else if(charSetLower == Latin1Literal("iso6937")) {
- return iconv(Iso6937Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
+ return iConv(Iso6937Converter::toUtf8(text_).utf8(), QString::fromLatin1("utf-8"), toCharSet_);
}
kdWarning() << "Z3950Fetcher::iconv() - conversion from " << fromCharSet_
<< " to " << toCharSet_ << " is unsupported" << endl;

View File

@ -1,11 +0,0 @@
--- src/fetch/z3950connection.h.orig Fri Jan 12 11:14:04 2007
+++ src/fetch/z3950connection.h Fri Jan 12 11:14:17 2007
@@ -85,7 +85,7 @@
void abort() { m_aborted = true; }
private:
- static QCString iconv(const QCString& text, const QString& fromCharSet, const QString& toCharSet);
+ static QCString iConv(const QCString& text, const QString& fromCharSet, const QString& toCharSet);
static QString toXML(const QCString& marc, const QString& fromCharSet);
bool makeConnection();