security/ncrack: resurrect and update to version 0.7

The port has been recovered after deletion and upgraded to the latest
version available on Github.

The build has been tested with base and ports versions of openssl.
This commit is contained in:
Stefan Eßer 2021-05-03 20:22:01 +02:00
parent 2a92ce401f
commit 295be8e6e7
7 changed files with 87 additions and 0 deletions

View File

@ -365,6 +365,7 @@
SUBDIR += mussh
SUBDIR += n2n
SUBDIR += nacl
SUBDIR += ncrack
SUBDIR += ncrypt
SUBDIR += nettle
SUBDIR += nextcloud-end_to_end_encryption

22
security/ncrack/Makefile Normal file
View File

@ -0,0 +1,22 @@
# Created by: David E. Thiel <lx@FreeBSD.org>
PORTNAME= ncrack
DISTVERSION= 0.7
CATEGORIES= security
MAINTAINER= se@FreeBSD.org
COMMENT= High-speed network authentication cracking tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake ssl
USE_GITHUB= yes
GH_ACCOUNT= nmap
GNU_CONFIGURE= yes
CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
.include <bsd.port.mk>

3
security/ncrack/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1620063990
SHA256 (nmap-ncrack-0.7_GH0.tar.gz) = f3f971cd677c4a0c0668cb369002c581d305050b3b0411e18dd3cb9cc270d14a
SIZE (nmap-ncrack-0.7_GH0.tar.gz) = 8586213

View File

@ -0,0 +1,11 @@
--- opensshlib/umac.c.orig 2019-08-24 22:25:32 UTC
+++ opensshlib/umac.c
@@ -1177,7 +1177,7 @@ static int uhash(uhash_ctx_t ahc, u_char *msg, long le
* time. The all-at-once is more optimaized than the sequential version and
* should be preferred when the sequential interface is not required.
*/
-struct umac_ctx {
+extern struct umac_ctx {
uhash_ctx hash; /* Hash function for message compression */
pdf_ctx pdf; /* PDF for hashed output */
void *free_ptr; /* Address to free this struct via */

View File

@ -0,0 +1,32 @@
--- portable_endian.h.orig 2019-08-24 22:25:32 UTC
+++ portable_endian.h
@@ -18,6 +18,7 @@
# include <endian.h>
# include <features.h>
/* See http://linux.die.net/man/3/endian */
+# if !defined(__FreeBSD__)
# if !defined(__GLIBC__) || !defined(__GLIBC_MINOR__) || ((__GLIBC__ < 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ < 9)))
# include <arpa/inet.h>
# if defined(__BYTE_ORDER) && (__BYTE_ORDER == __LITTLE_ENDIAN)
@@ -54,6 +55,7 @@
# error Byte Order not supported or not defined.
# endif
# endif
+# endif
@@ -81,11 +83,11 @@
# define __LITTLE_ENDIAN LITTLE_ENDIAN
# define __PDP_ENDIAN PDP_ENDIAN
-#elif defined(__OpenBSD__)
+#elif defined(__OpenBSD__) || defined (__FreeBSD__)
# include <sys/endian.h>
-#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
+#elif defined(__NetBSD__) || defined(__DragonFly__)
# include <sys/endian.h>

View File

@ -0,0 +1,7 @@
Ncrack is a high-speed network authentication cracking tool. Ncrack was
designed using a modular approach, a command-line syntax similar to
Nmap and a dynamic engine that can adapt its behaviour based on network
feedback. It allows for rapid, yet reliable large-scale auditing of
multiple hosts.
WWW: https://nmap.org/ncrack/

11
security/ncrack/pkg-plist Normal file
View File

@ -0,0 +1,11 @@
bin/ncrack
share/ncrack/ncrack-services
share/ncrack/common.usr
share/ncrack/default.pwd
share/ncrack/default.usr
share/ncrack/jtr.pwd
share/ncrack/minimal.usr
share/ncrack/myspace.pwd
share/ncrack/phpbb.pwd
share/ncrack/top50000.pwd
man/man1/ncrack.1.gz