An open source application, server and network management platform based on the

Zope application server.

WWW: http://zenoss.com/

PR:		ports/156655
Submitted by:	Phil Phillips <phil@experts-exchange.com>
Approved by:	rene (mentor)
This commit is contained in:
Chris Rees 2011-07-21 16:55:07 +00:00
parent 6d0579e876
commit 295be1c105
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278129
19 changed files with 18794 additions and 0 deletions

View File

@ -299,5 +299,6 @@
SUBDIR += zabbix-frontend
SUBDIR += zabbix-proxy
SUBDIR += zabbix-server
SUBDIR += zenoss
.include <bsd.port.subdir.mk>

107
net-mgmt/zenoss/Makefile Normal file
View File

@ -0,0 +1,107 @@
# New ports collection makefile for: zenoss
# Date created: 19 April 2011
# Whom: Phil Phillips
#
# $FreeBSD$
#
PORTNAME= zenoss
PORTVERSION= 3.1.0
CATEGORIES= net-mgmt java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-3.1/${PORTNAME}-${PORTVERSION}:source1 \
http://dev.sencha.com/deploy/:source2
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:source1 \
JSBuilder2.zip:source2
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= pphillips@experts-exchange.com
COMMENT= Application, server, and network management platform
BUILD_DEPENDS+= swig>=1.3:${PORTSDIR}/devel/swig13 \
${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS+= bash>=4.1:${PORTSDIR}/shells/bash \
net-snmp>=5.5:${PORTSDIR}/net-mgmt/net-snmp \
liberation-fonts-ttf>=1.05:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
LICENSE= GPLv2
USE_RC_SUBR= zenoss
USE_MYSQL= client
USE_GMAKE= yes
USE_OPENSSL= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_BUILD= yes
USE_AUTOTOOLS= autoconf:env
USERS= zenoss
GROUPS= zenoss
SUB_FILES= pkg-install profile local.conf
SUB_LIST= ZENHOME=${ZENHOME}
PLIST_SUB= ZENHOME=${ZENHOME:S,${PREFIX}/,,} \
OSVERSION_MAJOR=${INDEXFILE:S/INDEX-//}
ZENHOME= ${PREFIX}/${PORTNAME}
MANPREFIX?= ${ZENHOME}/share
.include "${.CURDIR}/Makefile.man"
BUILD_ENV= PYTHONDONTWRITEBYTECODE=yes
.include <bsd.port.pre.mk>
.if (${ARCH} == amd64)
PLIST_SUB+= 32BIT_ONLY="@comment "
.else
PLIST_SUB+= 32BIT_ONLY=""
.endif
.if (${OSVERSION} >= 900000)
PLIST_SUB+= OSSAUDIODEV="@comment "
.else
PLIST_SUB+= OSSAUDIODEV=""
.endif
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= depends on Java
post-patch:
@${MKDIR} ${WRKSRC}/jsbuildertmp && ${CP} ${DISTDIR}/JSBuilder2.zip ${WRKSRC}/jsbuildertmp
@${REINPLACE_CMD} -e 's/ZENHOME[^.]*\.conf$$/&.example/' \
-e 's,lib/pkgconfig,libdata/pkgconfig,' \
${WRKSRC}/GNUmakefile \
${WRKSRC}/rrddeps.sh
@${CP} ${FILESDIR}/libsmi-0.4.8.all.patch01 ${WRKSRC}/externallibs
@${REINPLACE_CMD} -e '1s,#!/bin/bash,#!/usr/bin/env bash,' \
${WRKSRC}/genpatchdeps.sh
@${ECHO} ${ZENHOME} > ${WRKSRC}/zenhome
do-build:
@${DO_NADA}
do-install:
# Integrated dependencies insist on using lib/pkgconfig -- instead of huge
# patches, we'll symlink it temporarily
@${MKDIR} ${ZENHOME}/lib \
&& ${LN} -sF ${ZENHOME}/libdata/pkgconfig \
${ZENHOME}/lib/pkgconfig
@cd ${WRKSRC} && ${ENV} ${BUILD_ENV} bash ./build.sh 2>/dev/null
@${RM} ${ZENHOME}/lib/pkgconfig
@${MKDIR} ${ZENHOME}/fonts
${INSTALL_DATA} ${WRKDIR}/local.conf ${ZENHOME}/etc/fonts
@${MKDIR} ${ZENHOME}/init
${INSTALL_DATA} ${WRKSRC}/zenhome ${ZENHOME}/init
${INSTALL_DATA} ${WRKSRC}/build-functions.sh ${ZENHOME}/init
${INSTALL_DATA} ${WRKSRC}/install-functions.sh ${ZENHOME}/init
${INSTALL_DATA} ${WRKSRC}/shared-functions.sh ${ZENHOME}/init
${INSTALL_SCRIPT} ${WRKSRC}/init.sh ${ZENHOME}/init
${INSTALL_DATA} ${WRKDIR}/profile ${ZENHOME}/.profile
${INSTALL_DATA} ${WRKSRC}/libzenoss/Products/ZenModel/ZenossInfo.py ${ZENHOME}/Products/ZenModel
@${FIND} ${ZENHOME} -type f -exec ${CHOWN} ${USERS}:${GROUPS} \{\} \;
@${LN} -fs ${PREFIX}/lib/X11/fonts/Liberation ${ZENHOME}/fonts
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,282 @@
# This file lists the man pages to avoid overcrowding the Makefile
#
# $FreeBSD$
#
MAN1= autopoint.1 \
bin_dec_hex.1 \
cdeftutorial.1 \
envsubst.1 \
fc-cache.1 \
fc-cat.1 \
fc-list.1 \
fc-match.1 \
gettext.1 \
gettextize.1 \
glib-genmarshal.1 \
glib-gettextize.1 \
glib-mkenums.1 \
gobject-query.1 \
gtester-report.1 \
gtester.1 \
iconv.1 \
msgattrib.1 \
msgcat.1 \
msgcmp.1 \
msgcomm.1 \
msgconv.1 \
msgen.1 \
msgexec.1 \
msgfilter.1 \
msgfmt.1 \
msggrep.1 \
msginit.1 \
msgmerge.1 \
msgunfmt.1 \
msguniq.1 \
ngettext.1 \
pango-querymodules.1 \
pkg-config.1 \
recode-sr-latin.1 \
rpntutorial.1 \
rrd-beginners.1 \
rrdbuild.1 \
rrdcgi.1 \
rrdcreate.1 \
rrddump.1 \
rrdfetch.1 \
rrdfirst.1 \
rrdgraph.1 \
rrdgraph_data.1 \
rrdgraph_examples.1 \
rrdgraph_graph.1 \
rrdgraph_rpn.1 \
rrdinfo.1 \
rrdlast.1 \
rrdlastupdate.1 \
rrdresize.1 \
rrdrestore.1 \
rrdthreads.1 \
rrdtool.1 \
rrdtune.1 \
rrdtutorial.1 \
rrdupdate.1 \
rrdxport.1 \
smicache.1 \
smidiff.1 \
smidump.1 \
smilint.1 \
smiquery.1 \
smistrip.1 \
smixlate.1 \
xgettext.1 \
xml2-config.1 \
xmlcatalog.1 \
xmllint.1
MAN3= FcAtomicCreate.3 \
FcAtomicDeleteNew.3 \
FcAtomicDestroy.3 \
FcAtomicLock.3 \
FcAtomicNewFile.3 \
FcAtomicOrigFile.3 \
FcAtomicReplaceOrig.3 \
FcAtomicUnlock.3 \
FcBlanksAdd.3 \
FcBlanksCreate.3 \
FcBlanksDestroy.3 \
FcBlanksIsMember.3 \
FcCacheCopySet.3 \
FcCacheDir.3 \
FcCacheNumFont.3 \
FcCacheNumSubdir.3 \
FcCacheSubdir.3 \
FcCharSetAddChar.3 \
FcCharSetCopy.3 \
FcCharSetCount.3 \
FcCharSetCoverage.3 \
FcCharSetCreate.3 \
FcCharSetDestroy.3 \
FcCharSetEqual.3 \
FcCharSetFirstPage.3 \
FcCharSetHasChar.3 \
FcCharSetIntersect.3 \
FcCharSetIntersectCount.3 \
FcCharSetIsSubset.3 \
FcCharSetNew.3 \
FcCharSetNextPage.3 \
FcCharSetSubtract.3 \
FcCharSetSubtractCount.3 \
FcCharSetUnion.3 \
FcConfigAppFontAddDir.3 \
FcConfigAppFontAddFile.3 \
FcConfigAppFontClear.3 \
FcConfigBuildFonts.3 \
FcConfigCreate.3 \
FcConfigDestroy.3 \
FcConfigEnableHome.3 \
FcConfigFilename.3 \
FcConfigGetBlanks.3 \
FcConfigGetCache.3 \
FcConfigGetCacheDirs.3 \
FcConfigGetConfigDirs.3 \
FcConfigGetConfigFiles.3 \
FcConfigGetCurrent.3 \
FcConfigGetFontDirs.3 \
FcConfigGetFonts.3 \
FcConfigGetRescanInterval.3 \
FcConfigHome.3 \
FcConfigParseAndLoad.3 \
FcConfigSetCurrent.3 \
FcConfigSetRescanInterval.3 \
FcConfigSubstitute.3 \
FcConfigSubstituteWithPat.3 \
FcConfigUptoDate.3 \
FcDefaultSubstitute.3 \
FcDirCacheLoad.3 \
FcDirCacheLoadFile.3 \
FcDirCacheRead.3 \
FcDirCacheUnlink.3 \
FcDirCacheUnload.3 \
FcDirCacheValid.3 \
FcDirSave.3 \
FcDirScan.3 \
FcFileIsDir.3 \
FcFileScan.3 \
FcFini.3 \
FcFontList.3 \
FcFontMatch.3 \
FcFontRenderPrepare.3 \
FcFontSetAdd.3 \
FcFontSetCreate.3 \
FcFontSetDestroy.3 \
FcFontSetList.3 \
FcFontSetMatch.3 \
FcFontSetPrint.3 \
FcFontSetSort.3 \
FcFontSetSortDestroy.3 \
FcFontSort.3 \
FcFreeTypeCharIndex.3 \
FcFreeTypeCharSet.3 \
FcFreeTypeCharSetAndSpacing.3 \
FcFreeTypeQuery.3 \
FcFreeTypeQueryFace.3 \
FcGetLangs.3 \
FcGetVersion.3 \
FcInit.3 \
FcInitBringUptoDate.3 \
FcInitLoadConfig.3 \
FcInitLoadConfigAndFonts.3 \
FcInitReinitialize.3 \
FcIsLower.3 \
FcIsUpper.3 \
FcLangGetCharSet.3 \
FcLangSetAdd.3 \
FcLangSetCompare.3 \
FcLangSetContains.3 \
FcLangSetCopy.3 \
FcLangSetCreate.3 \
FcLangSetDestroy.3 \
FcLangSetEqual.3 \
FcLangSetHasLang.3 \
FcLangSetHash.3 \
FcMatrixCopy.3 \
FcMatrixEqual.3 \
FcMatrixInit.3 \
FcMatrixMultiply.3 \
FcMatrixRotate.3 \
FcMatrixScale.3 \
FcMatrixShear.3 \
FcNameConstant.3 \
FcNameGetConstant.3 \
FcNameGetObjectType.3 \
FcNameParse.3 \
FcNameRegisterConstants.3 \
FcNameRegisterObjectTypes.3 \
FcNameUnparse.3 \
FcNameUnregisterConstants.3 \
FcNameUnregisterObjectTypes.3 \
FcObjectSetAdd.3 \
FcObjectSetBuild.3 \
FcObjectSetCreate.3 \
FcObjectSetDestroy.3 \
FcPatternAdd-Type.3 \
FcPatternAdd.3 \
FcPatternAddWeak.3 \
FcPatternBuild.3 \
FcPatternCreate.3 \
FcPatternDel.3 \
FcPatternDestroy.3 \
FcPatternDuplicate.3 \
FcPatternEqual.3 \
FcPatternEqualSubset.3 \
FcPatternGet-Type.3 \
FcPatternGet.3 \
FcPatternHash.3 \
FcPatternPrint.3 \
FcPatternReference.3 \
FcPatternRemove.3 \
FcStrBasename.3 \
FcStrCmp.3 \
FcStrCmpIgnoreCase.3 \
FcStrCopy.3 \
FcStrCopyFilename.3 \
FcStrDirname.3 \
FcStrDowncase.3 \
FcStrFree.3 \
FcStrListCreate.3 \
FcStrListDone.3 \
FcStrListNext.3 \
FcStrPlus.3 \
FcStrSetAdd.3 \
FcStrSetAddFilename.3 \
FcStrSetCreate.3 \
FcStrSetDel.3 \
FcStrSetDestroy.3 \
FcStrSetEqual.3 \
FcStrSetMember.3 \
FcStrStr.3 \
FcStrStrIgnoreCase.3 \
FcToLower.3 \
FcUcs4ToUtf8.3 \
FcUtf16Len.3 \
FcUtf16ToUcs4.3 \
FcUtf8Len.3 \
FcUtf8ToUcs4.3 \
FcValueDestroy.3 \
FcValueEqual.3 \
FcValuePrint.3 \
FcValueSave.3 \
bind_textdomain_codeset.3 \
bindtextdomain.3 \
dcgettext.3 \
dcngettext.3 \
dgettext.3 \
dngettext.3 \
gettext.3 \
iconv.3 \
iconv_close.3 \
iconv_open.3 \
iconv_open_into.3 \
iconvctl.3 \
libpng.3 \
libpngpf.3 \
libsmi.3 \
libxml.3 \
ngettext.3 \
smi_attribute.3 \
smi_class.3 \
smi_config.3 \
smi_event.3 \
smi_identity.3 \
smi_macro.3 \
smi_module.3 \
smi_node.3 \
smi_render.3 \
smi_type.3 \
smi_util.3 \
textdomain.3 \
zlib.3
MAN5= fonts-conf.5 \
png.5

4
net-mgmt/zenoss/distinfo Normal file
View File

@ -0,0 +1,4 @@
SHA256 (zenoss-3.1.0.tar.gz) = a37b6b3acb820e420e863657cd14eca87ef3f23a10ee9b51e2563537aadd4662
SIZE (zenoss-3.1.0.tar.gz) = 105896128
SHA256 (JSBuilder2.zip) = 71948305d1d89a7952fdd43a5f59bdc99c2acca785b5636f4eae6d76e8dcd07a
SIZE (JSBuilder2.zip) = 870364

View File

@ -0,0 +1,18 @@
$FreeBSD$
Yet another lib/pkgconfig patch.
This is detected and applied by the build scripts when copied into
WRKSRC/externallibs
--- Makefile.in.orig 2011-06-26 16:03:36.209389341 +0100
+++ Makefile.in 2011-06-26 16:04:33.626118820 +0100
@@ -233,7 +233,7 @@
SUBDIRS = lib tools mibs pibs test doc
m4datadir = $(datadir)/aclocal
m4data_DATA = libsmi.m4
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = ${prefix}/libdata/pkgconfig
pkgconfig_DATA = libsmi.pc
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View File

@ -0,0 +1 @@
<dir>%%ZENHOME%%/fonts</dir>

View File

@ -0,0 +1,95 @@
$FreeBSD$
--- GNUmakefile.orig 2011-02-08 08:07:00.000000000 -0800
+++ GNUmakefile 2011-04-25 13:47:03.000000000 -0700
@@ -11,10 +11,10 @@
#
###########################################################################
-SHELL=/bin/bash
+SHELL=/usr/local/bin/bash
ifeq ($(ZENHOME),)
-ZENHOME=/usr/local/zenoss
+ZENHOME=`cat zenhome`
endif
PATCHCMD=$(firstword \
$(wildcard /usr/local/bin/gpatch) \
@@ -63,19 +63,10 @@
MINIFIED_ZENOSS_UI_JS = $(INSTALL_DIR)/Products/ZenUI3/browser/resources/js/deploy/zenoss-compiled.js
-ifeq ($(PLATFORM), "SunOS")
- NAGIOSLIBS=-ldl -lm
- NAGIOSCONF=--with-openssl=/usr/sfw
- RRD_LDFLAGS:="-R$(INSTALL_DIR)/lib"
-else
- NAGIOSLIBS=-ldl
- NAGIOSCONF=
- ifeq ("$(PLATFORM)", "Darwin")
- RRD_LDFLAGS:="-L$(INSTALL_DIR)/lib"
- else
- RRD_LDFLAGS:="-Wl,--rpath -Wl,$(INSTALL_DIR)/lib"
- endif
-endif
+NAGIOSLIBS=-lc
+NAGIOSCONF=
+RRD_LDFLAGS:="-Wl,--rpath -Wl,$(INSTALL_DIR)/lib"
+PYRRD_LDFLAGS:="-I../../src -L../../src/.libs -Wl,--rpath -Wl,$(INSTALL_DIR)/lib"
ifeq ("$(PLATFORM)", "Darwin")
BUILDOPTS= CC=gcc-4.0 CXX=g++-4.0
@@ -103,7 +94,7 @@
$(ZENPYTHON) setup.py build_scripts --executable=$(ZENHOME)/bin/python $(LOG)
PYBUILDEXTCMD=$(BUILDOPTS) PYTHONPATH=$(PYTHONPATH) \
- CPPFLAGS=$(RRD_LDFLAGS) \
+ CPPFLAGS=$(PYRRD_LDFLAGS) \
$(ZENPYTHON) setup.py build_ext $(LOG)
PYINSTALLCMD=$(BUILDOPTS) PYTHONPATH=$(PYTHONPATH) \
@@ -149,7 +140,7 @@
MYSQLPYTHON= $(call ROOT, MySQL-python)
PYOPENSSL= $(call ROOT, pyOpenSSL)
EPYDOC= $(call ROOT, epydoc)
-ZOPE= $(call ROOT, Zope2)
+ZOPE= $(call ROOT, Zope2-)
ZOPEDEPS= $(call ROOT, Zope2deps)
PYCRYPTO= $(call ROOT, pycrypto)
COVERAGE= $(call ROOT, coverage)
@@ -455,7 +446,7 @@
if tar -zxf $$bn;then \
cd $$dir ;\
if [ -f "../$${dir}.patch" ];then \
- if $(PATCHCMD) --dry-run -p0 < ../$${dir}.patch ;then \
+ if $(PATCHCMD) --check -p0 < ../$${dir}.patch ;then \
$(PATCHCMD) -p0 < ../$${dir}.patch 2>/dev/null 1>&2 ; \
else \
echo "Warning: Unable to patch $$bn" ;\
@@ -472,7 +463,7 @@
if tar -zxf $$bn;then \
cd $$dir ;\
if [ -f "../$${dir}.patch" ];then \
- if $(PATCHCMD) --dry-run -p0 < ../$${dir}.patch ;then \
+ if $(PATCHCMD) --check -p0 < ../$${dir}.patch ;then \
$(PATCHCMD) -p0 < ../$${dir}.patch 2>/dev/null 1>&2 ; \
else \
echo "Warning: Unable to patch $$bn" ;\
@@ -489,7 +480,7 @@
if unzip -q $$bn;then \
cd $$dir ;\
if [ -f "../$${dir}.patch" ];then \
- if $(PATCHCMD) --dry-run -p0 < ../$${dir}.patch ;then \
+ if $(PATCHCMD) --check -p0 < ../$${dir}.patch ;then \
$(PATCHCMD) -p0 < ../$${dir}.patch 2>/dev/null 1>&2 ; \
else \
echo "Warning: Unable to patch $$bn" ;\
@@ -611,7 +602,7 @@
$(MAKE) install PYTHON=$(ZENPYTHON) DESTDIR=$(DESTDIR) $(LOG)
$(BUILD)/$(NAGIOS)/Makefile: $(BUILD)/$(NAGIOS)/.unpacked
- @cd $(<D) ; LIBS="$(NAGIOSLIBS)" ; export LIBS ; $(CONFIGURE) $(NAGIOSCONF) $(LOG)
+ @cd $(<D) ; LIBS="$(NAGIOSLIBS)" ; export LIBS ; $(CONFIGURE) --disable-nls $(NAGIOSCONF) $(LOG)
@touch $@
NORMAL_MAKE=$(BUILD_MSG) ; cd $(<D) ; $(MAKE) $(LOG)

View File

@ -0,0 +1,19 @@
$FreeBSD$
--- libzenoss/Products/ZenModel/ZenossInfo.py.orig 2011-02-08 08:07:45.000000000 -0800
+++ libzenoss/Products/ZenModel/ZenossInfo.py 2011-04-21 09:50:39.000000000 -0700
@@ -255,13 +255,7 @@
@return: version number or ''
@rtype: string
"""
- try:
- products = zenPath("Products")
- cmd = "svn info '%s' 2>/dev/null | awk '/Revision/ {print $2}'" % products
- fd = os.popen(cmd)
- return fd.readlines()[0].strip()
- except:
- return ''
+ return ''
def getNetSnmpVersion(self):

View File

@ -0,0 +1,48 @@
$FreeBSD$
--- build-functions.sh.orig 2011-02-08 08:06:51.000000000 -0800
+++ build-functions.sh 2011-04-19 21:07:40.000000000 -0700
@@ -62,7 +62,7 @@
export DESTDIR=/
if [ -z "$ZENHOME" ] ; then
- export ZENHOME=/usr/local/zenoss
+ export ZENHOME=`cat zenhome`
fi
if [ -z "$ZOPEHOME" ] ; then
@@ -417,8 +417,16 @@
set_vars
set_make
- # verify all the input and environment
- run_checks
+ # build the external libs and download zenoss
+ compile
+}
+
+# sets up variables and configure
+init()
+{
+ # initialize environment variables
+ set_vars
+ set_make
# configure environment variables
set_mysql
@@ -426,15 +434,6 @@
# check mysql login
check_mysql_login
- # purge the last backup
- purge_backup
-
- # kill off any running zenoss processes
- kill_running
-
- # build the external libs and download zenoss
- compile
-
# perform post-installation configuration
configure
}

View File

@ -0,0 +1,22 @@
$FreeBSD$
--- build.sh.orig 2011-02-08 08:07:00.000000000 -0800
+++ build.sh 2011-04-19 20:21:37.000000000 -0700
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
###############################################################################
#
@@ -16,11 +16,5 @@
. shared-functions.sh
. build-functions.sh
-# gracefully handle Ctrl-C or other interrupts
-trap cleanup EXIT
-
# build and install the software
build
-
-# inform the user we're finished with the install
-get_happy

View File

@ -0,0 +1,30 @@
$FreeBSD$
--- buildjs.sh.orig 2011-02-08 08:07:00.000000000 -0800
+++ buildjs.sh 2011-03-03 15:58:08.000000000 -0800
@@ -14,7 +14,7 @@
exit $2
}
-JAVA_CHECK=`java -version 2>&1 | grep "java version \"1.[6-9]"`
+JAVA_CHECK=`java -version 2>&1 | grep "version \"1.[6-9]"`
if [ -z "$JAVA_CHECK" ]; then
which java
do_exit "This script requires the Sun JDK 1.6 or greater." $MISSING_JDK_1_6
@@ -30,16 +30,6 @@
if [ ! -d ./jsbuildertmp ]; then
mkdir jsbuildertmp || do_exit 'Unable to make temp directory. No permission?' $CANNOT_MAKE_TEMP_DIR
fi
- WGET_COMMAND=`which wget`
- if [ -z "$WGET_COMMAND" ]; then
- CURL_COMMAND=`which curl`
- if [ -z "$CURL_COMMAND" ]; then
- do_exit 'wget or curl required for buildjs.sh' $MISSING_WGET_AND_CURL
- fi
- curl -L http://www.extjs.com/deploy/JSBuilder2.zip -o ./jsbuildertmp/JSBuilder2.zip
- else
- wget -O ./jsbuildertmp/JSBuilder2.zip http://www.extjs.com/deploy/JSBuilder2.zip
- fi
UNZIP=`which unzip`
if [ -z "$UNZIP" ]; then
do_exit "Unzip not available to unzip JSBuilder2.zip" $MISSING_UNZIP

View File

@ -0,0 +1,20 @@
$FreeBSD$
--- /dev/null 2011-04-19 17:01:32.000000000 -0700
+++ init.sh 2011-04-19 17:02:19.000000000 -0700
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+# load up the functions we'll use to build and install
+. shared-functions.sh
+. build-functions.sh
+
+# gracefully handle Ctrl-C or other interrupts
+trap cleanup EXIT
+
+if [ "`whoami`" != "zenoss" ]; then
+ echo "You must run this script as the zenoss user"
+ exit 1
+fi
+
+init
+get_happy

View File

@ -0,0 +1,82 @@
$FreeBSD$
--- rrddeps.sh.orig 2011-02-08 16:07:00.000000000 +0000
+++ rrddeps.sh 2011-06-25 12:42:21.985461786 +0100
@@ -44,6 +44,13 @@
export CFLAGS="-O3 -fPIC -I${INSTALL_DIR}/include"
+USE_GETTEXT=yes
+CPPFLAGS+=" -I${INSTALL_DIR}/include"
+LDFLAGS+=" -L${INSTALL_DIR}/lib"
+
+GNU_CONFIGURE=yes
+CONFIGURE_ENV="CPPFLAGS= -I${INSTALL_DIR}/include LDFLAGS=-L${INSTALL_DIR}/lib"
+
build_dep () {
if [ -e $BUILD_DIR/$dep-* ]
then
@@ -56,15 +63,29 @@
patch -p0 <$RRDDEPS_DIR/$patch >>$BUILDLOG 2>&1 || exit $?
fi
cd $dep-* || exit $?
- echo "configuring: $dep"
- ./configure --prefix=$ZENHOME $confopts >>$BUILDLOG 2>&1 || exit $?
- echo "building: $dep"
- make >>$BUILDLOG 2>&1 || exit $?
- echo "installing: $dep"
- make install DESTDIR="" >>$BUILDLOG 2>&1 || exit $?
- if [ -n "$DESTDIR" ] && [ "$DESTDIR" != "/" ]
+
+ sed -i.bak -e "s#^\(pkgconfigdir\).*#\1 = ${PKG_CONFIG_PATH}#" Makefile.in
+
+ if [ "$dep" = "freetype" ]
then
- make install DESTDIR="$DESTDIR" >>$BUILDLOG 2>&1 || exit $?
+ GNUMAKE=gmake ./configure --prefix=$ZENHOME $confopts || exit $?
+ gmake || exit $?
+ gmake install DESTDIR="" || exit $?
+ if [ -n "$DESTDIR" ] && [ "$DESTDIR" != "/" ]
+ then
+ gmake install DESTDIR="$DESTDIR" || exit $?
+ fi
+ else
+ echo "configuring: $dep"
+ ./configure --prefix=$ZENHOME $confopts >>$BUILDLOG 2>&1 || exit $?
+ echo "building: $dep"
+ make >>$BUILDLOG 2>&1 || exit $?
+ echo "installing: $dep"
+ make install DESTDIR="" >>$BUILDLOG 2>&1 || exit $?
+ if [ -n "$DESTDIR" ] && [ "$DESTDIR" != "/" ]
+ then
+ make install DESTDIR="$DESTDIR" >>$BUILDLOG 2>&1 || exit $?
+ fi
fi
cd ..
fi
@@ -75,6 +96,11 @@
patch=""
build_dep
+dep=libiconv
+confopts=''
+patch=""
+build_dep
+
dep=gettext
confopts=''
patch="gettext-0.17.all.patch01"
@@ -115,13 +141,6 @@
patch=""
build_dep
-if [ "$os_name" == "Darwin" ]; then
- dep=libiconv
- confopts=''
- patch=""
- build_dep
-fi
-
dep=cairo
confopts='--enable-xlib=no --enable-xlib-render=no --enable-win32=no'
patch="cairo-1.8.4.Darwin.patch01"

View File

@ -0,0 +1,43 @@
#!/bin/sh
#
# $FreeBSD$
#
# pkg-install.in for zenoss
CP="/bin/cp -p"
CHOWN="/usr/sbin/chown"
ECHO="/bin/echo"
MKDIR="/bin/mkdir -p"
SED="/usr/bin/sed"
FIND="/usr/bin/find"
DIRECTORIES="export
Products/ZenModel/ZenPackTemplate/CONTENT/skins
Products/ZenModel/ZenPackTemplate/CONTENT/daemons
Products/ZenModel/ZenPackTemplate/CONTENT/reports
Products/ZenModel/ZenPackTemplate/CONTENT/objects
lib/python2.6/lib-old
lib/gio/modules
share/mibs/site
share/pibs/ietf
share/pibs/tubs
share/pibs/site
share/rrdtool
var/cache/fontconfig"
if [ "$2" = "POST-INSTALL" ]; then
# Make sure empty directories are created
cd %%ZENHOME%%
for i in $DIRECTORIES; do
${MKDIR} -m 0755 $i
${CHOWN} zenoss:zenoss $i
done
# If config file doesn't exist, then copy it from example
cd %%ZENHOME%%/etc
for i in *.example; do
[ -e $conf ] || ${CP} $i ${i%.example}
done
${FIND} %%ZENHOME%% -type d -exec ${CHOWN} zenoss:zenoss \{\} \;
fi

View File

@ -0,0 +1,8 @@
#
# $FreeBSD$
#
export ZENHOME=%%ZENHOME%%
export PYTHONPATH=$ZENHOME/lib/python
export PATH=$ZENHOME/bin:$PATH
export INSTANCE_HOME=$ZENHOME

View File

@ -0,0 +1,42 @@
#!/bin/sh
# $FreeBSD$
#
# PROVIDE: zenoss
# REQUIRE: login
#
# Add the following line to /etc/rc.conf to enable zenoss:
#
# zenoss_enable="YES"
command="%%ZENHOME%%/bin/zenoss"
. /etc/rc.subr
load_rc_config zenoss
#set defaults
zenoss_enable=${zenoss_enable:-"NO"}
name=zenoss
rcvar=`set_rcvar`
extra_commands="init"
start_cmd="zenoss_command start"
stop_cmd="zenoss_command stop"
restart_cmd="zenoss_command restart"
status_cmd="zenoss_command status"
init_cmd="zenoss_init"
zenoss_command()
{
su -l zenoss -c "exec ${command} ${rc_arg}"
}
zenoss_init()
{
su -l zenoss -c "cd %%ZENHOME%%/init && ./init.sh"
}
run_rc_command "$1"

View File

@ -0,0 +1,4 @@
An open source application, server and network management platform based on the
Zope application server.
WWW: http://zenoss.com/

View File

@ -0,0 +1,9 @@
================================================================================
Add the following line to /etc/rc.conf to enable zenoss:
zenoss_enable="YES"
To initialize zenoss, you can run the following (as root):
service zenoss init
================================================================================

17959
net-mgmt/zenoss/pkg-plist Normal file

File diff suppressed because it is too large Load Diff