multimedia/olive: Update g20190414 -> 0.1.1

PR:		240131
Reported by:	upstream
This commit is contained in:
Yuri Victorovich 2019-08-28 05:06:04 +00:00
parent 2bd5f9f2de
commit 2957615947
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=510040
4 changed files with 124 additions and 79 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= olive
PORTVERSION= g20190414
PORTREVISION= 2
DISTVERSION= 0.1.1
CATEGORIES= multimedia
PKGNAMESUFFIX= -video-editor
@ -12,13 +11,18 @@ COMMENT= NLE (nonlinear) video editor
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libOpenColorIO.so:graphics/opencolorio
USES= cmake compiler:c++11-lang desktop-file-utils gl qt:5 shared-mime-info
USES= qmake compiler:c++11-lang desktop-file-utils gl pkgconfig qt:5 shared-mime-info
USE_GITHUB= yes
GH_ACCOUNT= olive-editor
GH_TAGNAME= continuous
USE_QT= core gui multimedia network opengl svg widgets qmake_build buildtools_build linguisttools_build
USE_QT= core gui multimedia network opengl svg widgets buildtools_build linguisttools_build
USE_GL= gl
CMAKE_ARGS= -DGIT_HASH:STRING=NoGitHashVersion${DISTVERSION}
DATADIR= ${PREFIX}/share/olive-editor
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1555295763
SHA256 (olive-editor-olive-g20190414-continuous_GH0.tar.gz) = e336b105f1f3deca591078f2b891b0e6c10a506940b6c92975c31da7e91842a2
SIZE (olive-editor-olive-g20190414-continuous_GH0.tar.gz) = 1931825
TIMESTAMP = 1566872364
SHA256 (olive-editor-olive-0.1.1-continuous_GH0.tar.gz) = e7581a88682cf5b0e142a49992e8e347406e0201b06c165091dbb6c8edebc8ba
SIZE (olive-editor-olive-0.1.1-continuous_GH0.tar.gz) = 2141695

View File

@ -0,0 +1,43 @@
--- olive.pro.orig 2019-08-28 03:49:22 UTC
+++ olive.pro
@@ -28,23 +28,23 @@ DEFINES += QT_DEPRECATED_WARNINGS
#DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000 # disables all the APIs deprecated before Qt 6.0.0
# Tries to get the current Git short hash
-system("which git") {
- GITPATH = $$PWD
-
- win32 {
- GITPATH = $$system(cygpath $$PWD)
- }
-
- GITHASHVAR = $$system(git --git-dir=\"$$GITPATH/.git\" --work-tree=\"$$GITPATH\" log -1 --format=%h)
-
- # Fallback for Ubuntu/Launchpad (extracts Git hash from debian/changelog rather than Git repo)
- # (see https://answers.launchpad.net/launchpad/+question/678556)
- isEmpty(GITHASHVAR) {
- GITHASHVAR = $$system(sh $$PWD/debian/gitfromlog.sh $$PWD/debian/changelog)
- }
-
- DEFINES += GITHASH=\\"\"$$GITHASHVAR\\"\"
-}
+#system("which git") {
+# GITPATH = $$PWD
+#
+# win32 {
+# GITPATH = $$system(cygpath $$PWD)
+# }
+#
+# GITHASHVAR = $$system(git --git-dir=\"$$GITPATH/.git\" --work-tree=\"$$GITPATH\" log -1 --format=%h)
+#
+# # Fallback for Ubuntu/Launchpad (extracts Git hash from debian/changelog rather than Git repo)
+# # (see https://answers.launchpad.net/launchpad/+question/678556)
+# isEmpty(GITHASHVAR) {
+# GITHASHVAR = $$system(sh $$PWD/debian/gitfromlog.sh $$PWD/debian/changelog)
+# }
+#
+ DEFINES += GITHASH=\\"\"undefined\\"\"
+#}
CONFIG += c++11

View File

@ -1,82 +1,80 @@
bin/olive-editor
share/applications/org.olivevideoeditor.Olive.desktop
share/icons/hicolor/128x128/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/128x128/mimetypes/application-vnd.olive-project.png
share/icons/hicolor/16x16/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/16x16/mimetypes/application-vnd.olive-project.png
share/icons/hicolor/256x256/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/256x256/mimetypes/application-vnd.olive-project.png
share/icons/hicolor/32x32/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/32x32/mimetypes/application-vnd.olive-project.png
share/icons/hicolor/48x48/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/48x48/mimetypes/application-vnd.olive-project.png
share/icons/hicolor/512x512/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/512x512/mimetypes/application-vnd.olive-project.png
share/icons/hicolor/64x64/apps/org.olivevideoeditor.Olive.png
share/icons/hicolor/64x64/mimetypes/application-vnd.olive-project.png
share/metainfo/org.olivevideoeditor.Olive.appdata.xml
share/mime/packages/org.olivevideoeditor.Olive.xml
%%DATADIR%%-editor/effects/boxblur.frag
%%DATADIR%%-editor/effects/boxblur.xml
%%DATADIR%%-editor/effects/bulge.frag
%%DATADIR%%-editor/effects/bulge.xml
%%DATADIR%%-editor/effects/chromakey.frag
%%DATADIR%%-editor/effects/chromakey.xml
%%DATADIR%%-editor/effects/chromaticaberration.frag
%%DATADIR%%-editor/effects/chromaticaberration.xml
%%DATADIR%%-editor/effects/colorcorrection.frag
%%DATADIR%%-editor/effects/colorcorrection.xml
%%DATADIR%%-editor/effects/colorsel.frag
%%DATADIR%%-editor/effects/colorsel.xml
%%DATADIR%%-editor/effects/common.frag
%%DATADIR%%-editor/effects/common.vert
%%DATADIR%%-editor/effects/crop.frag
%%DATADIR%%-editor/effects/crop.xml
%%DATADIR%%-editor/effects/crossstitch.frag
%%DATADIR%%-editor/effects/crossstitch.xml
%%DATADIR%%-editor/effects/directionalblur.frag
%%DATADIR%%-editor/effects/directionalblur.xml
%%DATADIR%%-editor/effects/dropshadow.xml.disabled
%%DATADIR%%-editor/effects/emboss.frag
%%DATADIR%%-editor/effects/emboss.xml
%%DATADIR%%-editor/effects/findedges.frag
%%DATADIR%%-editor/effects/findedges.xml.disabled
%%DATADIR%%-editor/effects/fisheye.frag
%%DATADIR%%-editor/effects/fisheye.xml
%%DATADIR%%-editor/effects/flip.frag
%%DATADIR%%-editor/effects/flip.xml
%%DATADIR%%-editor/effects/gaussianblur.frag
%%DATADIR%%-editor/effects/gaussianblur.xml
%%DATADIR%%-editor/effects/huesatbri.frag
%%DATADIR%%-editor/effects/huesatbri.xml
%%DATADIR%%-editor/effects/invert.frag
%%DATADIR%%-editor/effects/invert.xml
%%DATADIR%%-editor/effects/lumakey.frag
%%DATADIR%%-editor/effects/lumakey.xml
%%DATADIR%%-editor/effects/noise.frag
%%DATADIR%%-editor/effects/noise.xml
%%DATADIR%%-editor/effects/pixelate.frag
%%DATADIR%%-editor/effects/pixelate.xml
%%DATADIR%%-editor/effects/posterize.frag
%%DATADIR%%-editor/effects/posterize.xml
%%DATADIR%%-editor/effects/radialblur.frag
%%DATADIR%%-editor/effects/radialblur.xml
%%DATADIR%%-editor/effects/ripple.frag
%%DATADIR%%-editor/effects/ripple.xml
%%DATADIR%%-editor/effects/sphere.frag
%%DATADIR%%-editor/effects/sphere.xml
%%DATADIR%%-editor/effects/swirl.frag
%%DATADIR%%-editor/effects/swirl.xml
%%DATADIR%%-editor/effects/tile.frag
%%DATADIR%%-editor/effects/tile.xml
%%DATADIR%%-editor/effects/toonify.frag
%%DATADIR%%-editor/effects/toonify.xml
%%DATADIR%%-editor/effects/vignette.frag
%%DATADIR%%-editor/effects/vignette.xml
%%DATADIR%%-editor/effects/volumetriclight.frag
%%DATADIR%%-editor/effects/volumetriclight.xml
%%DATADIR%%-editor/effects/wave.frag
%%DATADIR%%-editor/effects/wave.xml
%%DATADIR%%-editor/ts/olive_ar.qm
%%DATADIR%%-editor/ts/olive_bs.qm
%%DATADIR%%-editor/ts/olive_cs.qm
%%DATADIR%%-editor/ts/olive_de.qm
%%DATADIR%%-editor/ts/olive_es.qm
%%DATADIR%%-editor/ts/olive_fr.qm
%%DATADIR%%-editor/ts/olive_id.qm
%%DATADIR%%-editor/ts/olive_it.qm
%%DATADIR%%-editor/ts/olive_ru.qm
%%DATADIR%%-editor/ts/olive_sr.qm
%%DATADIR%%/effects/boxblur.frag
%%DATADIR%%/effects/boxblur.xml
%%DATADIR%%/effects/bulge.frag
%%DATADIR%%/effects/bulge.xml
%%DATADIR%%/effects/chromaticaberration.frag
%%DATADIR%%/effects/chromaticaberration.xml
%%DATADIR%%/effects/crop.frag
%%DATADIR%%/effects/crop.xml
%%DATADIR%%/effects/despill.frag
%%DATADIR%%/effects/despill.xml
%%DATADIR%%/effects/directionalblur.frag
%%DATADIR%%/effects/directionalblur.xml
%%DATADIR%%/effects/flip.frag
%%DATADIR%%/effects/flip.xml
%%DATADIR%%/effects/gaussianblur.frag
%%DATADIR%%/effects/gaussianblur.xml
%%DATADIR%%/effects/need checking/chromakey.frag
%%DATADIR%%/effects/need checking/chromakey.xml
%%DATADIR%%/effects/need checking/colorcorrection.frag
%%DATADIR%%/effects/need checking/colorcorrection.xml
%%DATADIR%%/effects/need checking/colorsel.frag
%%DATADIR%%/effects/need checking/colorsel.xml
%%DATADIR%%/effects/need checking/common.frag
%%DATADIR%%/effects/need checking/common.vert
%%DATADIR%%/effects/need checking/crossstitch.frag
%%DATADIR%%/effects/need checking/crossstitch.xml
%%DATADIR%%/effects/need checking/emboss.frag
%%DATADIR%%/effects/need checking/emboss.xml
%%DATADIR%%/effects/need checking/findedges.frag
%%DATADIR%%/effects/need checking/findedges.xml.disabled
%%DATADIR%%/effects/need checking/fisheye.frag
%%DATADIR%%/effects/need checking/fisheye.xml
%%DATADIR%%/effects/need checking/huesatbri.frag
%%DATADIR%%/effects/need checking/huesatbri.xml
%%DATADIR%%/effects/need checking/invert.frag
%%DATADIR%%/effects/need checking/invert.xml
%%DATADIR%%/effects/need checking/lumakey.frag
%%DATADIR%%/effects/need checking/lumakey.xml
%%DATADIR%%/effects/need checking/posterize.frag
%%DATADIR%%/effects/need checking/posterize.xml
%%DATADIR%%/effects/need checking/toonify.frag
%%DATADIR%%/effects/need checking/toonify.xml
%%DATADIR%%/effects/need checking/volumetriclight.frag
%%DATADIR%%/effects/need checking/volumetriclight.xml
%%DATADIR%%/effects/noise.frag
%%DATADIR%%/effects/noise.xml
%%DATADIR%%/effects/pixelate.frag
%%DATADIR%%/effects/pixelate.xml
%%DATADIR%%/effects/radialblur.frag
%%DATADIR%%/effects/radialblur.xml
%%DATADIR%%/effects/ripple.frag
%%DATADIR%%/effects/ripple.xml
%%DATADIR%%/effects/sphere.frag
%%DATADIR%%/effects/sphere.xml
%%DATADIR%%/effects/swirl.frag
%%DATADIR%%/effects/swirl.xml
%%DATADIR%%/effects/tile.frag
%%DATADIR%%/effects/tile.xml
%%DATADIR%%/effects/vignette.frag
%%DATADIR%%/effects/vignette.xml
%%DATADIR%%/effects/wave.frag
%%DATADIR%%/effects/wave.xml