Unbreak the build by replacing recently removed `get-wings-flags ...'

program invocations with corresponding `pkg-config WINGs ...' ones.

As we now non-trivially patch the configure script, merge the changes
made with sed(1) into the patch file.
This commit is contained in:
Alexey Dokuchaev 2020-09-01 06:58:02 +00:00
parent 5be195b7d0
commit 2941c4637d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=547240
2 changed files with 51 additions and 2 deletions

View File

@ -61,8 +61,6 @@ post-patch:
's|/usr/X11R6|${PREFIX}|g' ${WRKSRC}/configs/Xsession.in
@${REINPLACE_CMD} -e \
's|$$(DESTDIR)$$(PAMDIR)/wdm||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-ldl||g ; \
s|/authdir||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|@FAILSAFE@|@FAILSAFE_PATH@|g' ${WRKSRC}/configs/Xsession.in
@${REINPLACE_CMD} -e \

View File

@ -0,0 +1,51 @@
--- configure.orig 2005-03-26 13:57:04 UTC
+++ configure
@@ -4004,7 +4004,7 @@ if test "${ac_cv_lib_pam_main+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpam -ldl $LIBS"
+LIBS="-lpam $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -4059,7 +4059,7 @@ echo "${ECHO_T}$ac_cv_lib_pam_main" >&6
if test $ac_cv_lib_pam_main = yes; then
USE_PAM=yes
- PASSWDLIB="-lpam -ldl"
+ PASSWDLIB="-lpam"
cat >>confdefs.h <<_ACEOF
#define HAVE_PAM_LIB 1
@@ -6313,7 +6313,7 @@ fi
fi
# Extract the first word of "get-wings-flags", so it can be a program name with args.
-set dummy get-wings-flags; ac_word=$2
+set dummy pkg-config; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
if test "${ac_cv_prog_GETWINGSFLAGS+set}" = set; then
@@ -6353,9 +6353,9 @@ echo "$as_me: error: 'get-wings-flags' command was not
{ (exit 1); exit 1; }; }
fi
-WCFLAGS=`get-wings-flags --cflags`
-WLDFLAGS=`get-wings-flags --ldflags`
-WLIBS=`get-wings-flags --libs`
+WCFLAGS=`pkg-config WINGs --cflags`
+WLDFLAGS=
+WLIBS=`pkg-config WINGs --libs`
@@ -6506,7 +6506,7 @@ _ACEOF
cat >>confdefs.h <<_ACEOF
-#define DEF_AUTH_DIR "$DMDIR/authdir"
+#define DEF_AUTH_DIR "$DMDIR"
_ACEOF