mpeg-2 encoder/decoder.

Submitted by:	"Philippe Charnier" <charnier@lirmm.fr>
This commit is contained in:
Satoshi Asami 1996-07-10 05:32:54 +00:00
parent 722118d97f
commit 292e34c318
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3338
14 changed files with 182 additions and 0 deletions

View File

@ -0,0 +1,25 @@
# New ports collection makefile for: mpeg2codec
# Version required: 1.1a
# Date created: June 21, 1996
# Whom: "Philippe Charnier" <charnier@lirmm.fr>
#
# $Id$
#
DISTNAME= mpeg2codec-1.1a
CATEGORIES+= graphics
MASTER_SITES= ftp://ftp.netcom.com/pub/cf/cfogg/mpeg2/
DISTFILES= mpeg2codec_v1.1a.tar.gz
MAINTAINER= charnier@lirmm.fr
USE_X11= yes
WRKSRC= ${WRKDIR}/mpeg2
do-install:
.for i in dec enc
${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
${WRKSRC}/src/mpeg2${i}/mpeg2${i}ode ${PREFIX}/bin
.endfor
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (mpeg2codec_v1.1a.tar.gz) = 83eda281bac437f52e38977d4df065b6

View File

@ -0,0 +1,41 @@
--- Makefile 1996/06/18 18:44:04 1.1
+++ Makefile 1996/06/18 19:46:05
@@ -30,23 +30,23 @@
# uncomment the following two lines if you want to include X11 support
# (mpeg2decode)
-#USE_DISP = -DDISPLAY
-#LIBS = -lX11
+USE_DISP = -DDISPLAY
+LIBS = -lX11
# uncomment the following two lines if you want to use shared memory
# (faster display if server and client run on the same machine)
# (mpeg2decode)
-#USE_SHMEM = -DSH_MEM
-#LIBS = -lXext -lX11
+USE_SHMEM = -DSH_MEM
+LIBS = -lXext -lX11
# if your X11 include files / libraries are in a non standard location:
# set INCLUDEDIR to -I followed by the appropriate include file path and
# set LIBRARYDIR to -L followed by the appropriate library path
# (mpeg2decode)
-#INCLUDEDIR = -I/usr/openwin/include
-#LIBRARYDIR = -L/usr/openwin/lib
+INCLUDEDIR = -I${X11BASE}/include
+LIBRARYDIR = -L${X11BASE}/lib
# select one of the following CC CFLAGS settings
@@ -54,7 +54,7 @@
# GNU gcc
#
CC = gcc
-CFLAGS = -O2
+CFLAGS = -O2 -m486
#
# SPARCworks acc

View File

@ -0,0 +1,19 @@
--- src/mpeg2enc/mpeg2enc.c 1996/06/20 19:58:58 1.1
+++ src/mpeg2enc/mpeg2enc.c 1996/06/20 19:36:25
@@ -29,6 +29,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <floatingpoint.h>
#define GLOBAL /* used by global.h */
#include "config.h"
@@ -50,6 +51,8 @@
printf("Usage: mpeg2encode in.par out.m2v\n");
exit(0);
}
+
+ fpsetmask(0);
/* read parameter file */
readparmfile(argv[1]);

View File

@ -0,0 +1 @@
An MPEG-2 Encoder and Decoder.

View File

@ -0,0 +1,2 @@
It converts uncompressed video frames into MPEG-1 and MPEG-2 video
coded bitstream sequences, and vice versa.

View File

@ -0,0 +1,2 @@
bin/mpeg2encode
bin/mpeg2decode

View File

@ -0,0 +1,25 @@
# New ports collection makefile for: mpeg2codec
# Version required: 1.1a
# Date created: June 21, 1996
# Whom: "Philippe Charnier" <charnier@lirmm.fr>
#
# $Id$
#
DISTNAME= mpeg2codec-1.1a
CATEGORIES+= graphics
MASTER_SITES= ftp://ftp.netcom.com/pub/cf/cfogg/mpeg2/
DISTFILES= mpeg2codec_v1.1a.tar.gz
MAINTAINER= charnier@lirmm.fr
USE_X11= yes
WRKSRC= ${WRKDIR}/mpeg2
do-install:
.for i in dec enc
${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
${WRKSRC}/src/mpeg2${i}/mpeg2${i}ode ${PREFIX}/bin
.endfor
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (mpeg2codec_v1.1a.tar.gz) = 83eda281bac437f52e38977d4df065b6

View File

@ -0,0 +1,41 @@
--- Makefile 1996/06/18 18:44:04 1.1
+++ Makefile 1996/06/18 19:46:05
@@ -30,23 +30,23 @@
# uncomment the following two lines if you want to include X11 support
# (mpeg2decode)
-#USE_DISP = -DDISPLAY
-#LIBS = -lX11
+USE_DISP = -DDISPLAY
+LIBS = -lX11
# uncomment the following two lines if you want to use shared memory
# (faster display if server and client run on the same machine)
# (mpeg2decode)
-#USE_SHMEM = -DSH_MEM
-#LIBS = -lXext -lX11
+USE_SHMEM = -DSH_MEM
+LIBS = -lXext -lX11
# if your X11 include files / libraries are in a non standard location:
# set INCLUDEDIR to -I followed by the appropriate include file path and
# set LIBRARYDIR to -L followed by the appropriate library path
# (mpeg2decode)
-#INCLUDEDIR = -I/usr/openwin/include
-#LIBRARYDIR = -L/usr/openwin/lib
+INCLUDEDIR = -I${X11BASE}/include
+LIBRARYDIR = -L${X11BASE}/lib
# select one of the following CC CFLAGS settings
@@ -54,7 +54,7 @@
# GNU gcc
#
CC = gcc
-CFLAGS = -O2
+CFLAGS = -O2 -m486
#
# SPARCworks acc

View File

@ -0,0 +1,19 @@
--- src/mpeg2enc/mpeg2enc.c 1996/06/20 19:58:58 1.1
+++ src/mpeg2enc/mpeg2enc.c 1996/06/20 19:36:25
@@ -29,6 +29,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <floatingpoint.h>
#define GLOBAL /* used by global.h */
#include "config.h"
@@ -50,6 +51,8 @@
printf("Usage: mpeg2encode in.par out.m2v\n");
exit(0);
}
+
+ fpsetmask(0);
/* read parameter file */
readparmfile(argv[1]);

View File

@ -0,0 +1 @@
An MPEG-2 Encoder and Decoder.

View File

@ -0,0 +1,2 @@
It converts uncompressed video frames into MPEG-1 and MPEG-2 video
coded bitstream sequences, and vice versa.

View File

@ -0,0 +1,2 @@
bin/mpeg2encode
bin/mpeg2decode