- Add NO_ARCH
- Switch to options helpers - Regenerate patches with `make makepatch` - Simplify DOCS installation
This commit is contained in:
parent
dc41702666
commit
28c4e22d99
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416349
@ -16,9 +16,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
RUN_DEPENDS= rrdtool>=0:databases/rrdtool \
|
||||
p5-File-Tail>=0:devel/p5-File-Tail
|
||||
|
||||
NO_BUILD= yes
|
||||
USES= perl5 shebangfix tar:tgz
|
||||
SHEBANG_FILES= bindgraph.pl bindgraph.cgi
|
||||
NO_BUILD= yes
|
||||
NO_ARCH= yes
|
||||
|
||||
CGIDIR?= ${PREFIX}/www/cgi-bin
|
||||
DATADIR?= /var/db/bindgraph
|
||||
@ -31,8 +32,7 @@ PLIST_SUB= CGIDIR=${CGIDIR:S,${PREFIX}/,,} \
|
||||
BINDGRAPH_USER="${BINDGRAPH_USER}" \
|
||||
BINDGRAPH_GROUP="${BINDGRAPH_GROUP}"
|
||||
|
||||
DOCS= README ChangeLog
|
||||
PORTDOCS= ${DOCS}
|
||||
PORTDOCS= README ChangeLog
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
@ -49,13 +49,15 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR}," ${WRKSRC}/bindgraph.cgi
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}${CGIDIR}
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
@${MKDIR} ${STAGEDIR}${CGIDIR}
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bindgraph.pl ${STAGEDIR}${PREFIX}/sbin/
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bindgraph.cgi ${STAGEDIR}${CGIDIR}/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
for f in ${DOCS}; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$f ${STAGEDIR}${DOCSDIR}/; \
|
||||
done
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- bindgraph.cgi.orig 2003-05-05 06:26:18.000000000 +0800
|
||||
+++ bindgraph.cgi 2008-03-30 18:04:38.000000000 +0800
|
||||
--- bindgraph.cgi.orig 2016-05-23 13:30:02 UTC
|
||||
+++ bindgraph.cgi
|
||||
@@ -8,13 +8,14 @@
|
||||
|
||||
use RRDs;
|
||||
@ -17,7 +17,7 @@
|
||||
# temporary directory where the images will be saved
|
||||
my $tmp_dir = '/tmp/bindgraph';
|
||||
|
||||
@@ -89,6 +90,10 @@
|
||||
@@ -89,6 +90,10 @@ sub graph($$$;$) {
|
||||
}
|
||||
}
|
||||
|
||||
@ -28,7 +28,7 @@
|
||||
my ($text, $xs, $ys) = RRDs::graph(
|
||||
$file,
|
||||
'--imgformat', 'PNG',
|
||||
@@ -102,8 +107,7 @@
|
||||
@@ -102,8 +107,7 @@ sub graph($$$;$) {
|
||||
@rrdef,
|
||||
@rrprint,
|
||||
'COMMENT:\s',
|
||||
@ -38,7 +38,7 @@
|
||||
);
|
||||
my $err = RRDs::error;
|
||||
die_fatal("RRDs::graph($file, ...): $err") if $err;
|
||||
@@ -209,6 +213,7 @@
|
||||
@@ -209,6 +213,7 @@ sub main {
|
||||
$uri =~ s#/#,#g;
|
||||
$uri =~ s#~#tilde,#g;
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user