Update to 2.0.47.
This commit is contained in:
parent
e67fb70990
commit
28bb814f74
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=494589
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1549533147
|
||||
SHA256 (munin-2.0.45.tar.gz) = 3461dfe6eb597b6a330409aa41289e354378204496576564a627d3923873e54f
|
||||
SIZE (munin-2.0.45.tar.gz) = 2258820
|
||||
TIMESTAMP = 1551698437
|
||||
SHA256 (munin-2.0.47.tar.gz) = 3a1c66a605ebc348fea977c5b54fcb892d6b76ab2591b48880c6eb70dbf00407
|
||||
SIZE (munin-2.0.47.tar.gz) = 2249015
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig 2018-12-19 20:56:49 UTC
|
||||
--- Makefile.orig 2019-02-28 14:43:36 UTC
|
||||
+++ Makefile
|
||||
@@ -96,60 +96,47 @@ install: install-master-prime install-common-prime ins
|
||||
@@ -95,60 +95,47 @@ install: install-master-prime install-common-prime ins
|
||||
|
||||
install-pre: $(MAKEFILES)
|
||||
@$(CHECKUSER)
|
||||
@ -88,7 +88,7 @@
|
||||
|
||||
# Not ready to be installed yet
|
||||
# $(INSTALL) -m 0755 build/master/_bin/munin-gather $(LIBDIR)/
|
||||
@@ -159,36 +146,30 @@ install-node-plugins: install-plugins-prime
|
||||
@@ -158,36 +145,30 @@ install-node-plugins: install-plugins-prime
|
||||
install-plugins-prime: install-plugins build $(PLUGINS) $(MAKEFILES)
|
||||
@$(CHECKGROUP)
|
||||
|
||||
@ -136,7 +136,7 @@
|
||||
fi \
|
||||
done
|
||||
|
||||
@@ -199,14 +180,14 @@ install-plugins-java: build-plugins-java
|
||||
@@ -198,14 +179,14 @@ install-plugins-java: build-plugins-java
|
||||
install-async-prime: install-async
|
||||
|
||||
install-async:
|
||||
@ -155,7 +155,7 @@
|
||||
|
||||
|
||||
install-common-prime: build-common install-common
|
||||
@@ -519,7 +500,7 @@ t/install:
|
||||
@@ -518,7 +499,7 @@ t/install:
|
||||
|
||||
# This builds */Build from Build.PL
|
||||
%/Build: %/Build.PL
|
||||
@ -164,7 +164,7 @@
|
||||
|
||||
build-%: %/Build
|
||||
cd $* && $(PERL) Build
|
||||
@@ -535,6 +516,7 @@ install-%: %/Build
|
||||
@@ -534,6 +515,7 @@ install-%: %/Build
|
||||
--install_path script=$(BINDIR) \
|
||||
--install_path sbin=$(SBINDIR) \
|
||||
--install_path bindoc=$(MANDIR)/man1 \
|
||||
|
@ -1,6 +1,6 @@
|
||||
LICENSE= GPLv2
|
||||
|
||||
MUNIN_VERSION= 2.0.45
|
||||
MUNIN_VERSION= 2.0.47
|
||||
MUNIN_SITES= http://downloads.munin-monitoring.org/munin/stable/${MUNIN_VERSION}/
|
||||
DISTINFO_FILE= ${.CURDIR}/../../sysutils/munin-common/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../sysutils/munin-common/files
|
||||
|
@ -3,7 +3,6 @@
|
||||
|
||||
PORTNAME= munin
|
||||
PORTVERSION= ${MUNIN_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils perl5
|
||||
MASTER_SITES= ${MUNIN_SITES}
|
||||
PKGNAMESUFFIX= -master
|
||||
|
@ -3,7 +3,6 @@
|
||||
|
||||
PORTNAME= munin
|
||||
PORTVERSION= ${MUNIN_VERSION}
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= sysutils perl5
|
||||
MASTER_SITES= ${MUNIN_SITES}
|
||||
PKGNAMESUFFIX= -node
|
||||
@ -27,7 +26,7 @@ RUN_DEPENDS= p5-Cache-Cache>=0:devel/p5-Cache-Cache \
|
||||
|
||||
USES= gmake perl5 shebangfix cpe
|
||||
REINPLACE_ARGS= -i ""
|
||||
SHEBANG_FILES= node/bin/munindoc node/sbin/munin-node node/sbin/munin-sched \
|
||||
SHEBANG_FILES= node/bin/munindoc node/sbin/munin-node \
|
||||
node/sbin/munin-run node/sbin/munin-node-configure
|
||||
|
||||
.include "${.CURDIR}/../munin-common/munin.mk"
|
||||
@ -57,7 +56,7 @@ JAVA_BUILD= yes
|
||||
JAVA_RUN= yes
|
||||
|
||||
SUB_FILES= pkg-message plugins.conf
|
||||
USE_RC_SUBR= munin-asyncd munin-node munin-sched
|
||||
USE_RC_SUBR= munin-asyncd munin-node
|
||||
|
||||
PORTSCOUT= ignore:1
|
||||
|
||||
@ -84,7 +83,7 @@ post-install:
|
||||
${INSTALL_DATA} ${WRKDIR}/plugins.conf \
|
||||
${STAGEDIR}${ETCDIR}/plugins.conf.sample
|
||||
(cd ${WRKSRC}/node/blib/bindoc; \
|
||||
${INSTALL_MAN} munin-node-configure.1 munin-node.1 munin-run.1 munin-sched.1 munindoc.1 ${STAGEDIR}${MAN1PREFIX}/man/man1; \
|
||||
${INSTALL_MAN} munin-node-configure.1 munin-node.1 munin-run.1 munindoc.1 ${STAGEDIR}${MAN1PREFIX}/man/man1; \
|
||||
)
|
||||
(cd ${WRKSRC}/build/doc; \
|
||||
${INSTALL_MAN} munin-node.conf.5 ${STAGEDIR}${MAN5PREFIX}/man/man5; \
|
||||
|
@ -1,41 +0,0 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# PROVIDE: munin-sched
|
||||
# REQUIRE: DAEMON
|
||||
# BEFORE: cron
|
||||
# KEYWORD: shutdown
|
||||
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable munin-sched:
|
||||
# munin_sched_enable (bool): Set to "NO" by default.
|
||||
# Set it to "YES" to enable munin-sched
|
||||
# munin_sched_config (path): Set to "%%PREFIX%%/etc/munin/munin-node.conf" by default.
|
||||
#
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name=munin_sched
|
||||
desc="munin scheduler daemon"
|
||||
rcvar=munin_sched_enable
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
command="%%PREFIX%%/sbin/munin-sched"
|
||||
start_precmd=find_pidfile
|
||||
status_precmd=find_pidfile
|
||||
stop_precmd=find_pidfile
|
||||
|
||||
munin_sched_enable=${munin_sched_enable:-NO}
|
||||
munin_sched_config=${munin_sched_config:-"%%PREFIX%%/etc/munin/munin-node.conf"}
|
||||
|
||||
find_pidfile()
|
||||
{
|
||||
get_pidfile_from_conf pid_file $munin_sched_config
|
||||
pidfile="${_pidfile_from_conf%node*}sched"
|
||||
pidfile="${pidfile}${_pidfile_from_conf#*node}"
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
@ -15,7 +15,6 @@ bin/munindoc
|
||||
%%SITE_PERL%%/Munin/Node/Configure/PluginList.pm
|
||||
%%SITE_PERL%%/Munin/Node/Logger.pm
|
||||
%%SITE_PERL%%/Munin/Node/OS.pm
|
||||
%%SITE_PERL%%/Munin/Node/ProxySpooler.pm
|
||||
%%SITE_PERL%%/Munin/Node/SNMPConfig.pm
|
||||
%%SITE_PERL%%/Munin/Node/Server.pm
|
||||
%%SITE_PERL%%/Munin/Node/Service.pm
|
||||
@ -29,7 +28,6 @@ bin/munindoc
|
||||
man/man1/munin-node-configure.1.gz
|
||||
man/man1/munin-node.1.gz
|
||||
man/man1/munin-run.1.gz
|
||||
man/man1/munin-sched.1.gz
|
||||
man/man1/munindoc.1.gz
|
||||
man/man3/Munin::Node::Config.3.gz
|
||||
man/man3/Munin::Node::Configure::Debug.3.gz
|
||||
@ -39,7 +37,6 @@ man/man3/Munin::Node::Configure::Plugin.3.gz
|
||||
man/man3/Munin::Node::Configure::PluginList.3.gz
|
||||
man/man3/Munin::Node::Logger.3.gz
|
||||
man/man3/Munin::Node::OS.3.gz
|
||||
man/man3/Munin::Node::ProxySpooler.3.gz
|
||||
man/man3/Munin::Node::SNMPConfig.3.gz
|
||||
man/man3/Munin::Node::Server.3.gz
|
||||
man/man3/Munin::Node::Service.3.gz
|
||||
@ -55,7 +52,6 @@ man/man8/munin.8.gz
|
||||
sbin/munin-node
|
||||
sbin/munin-node-configure
|
||||
sbin/munin-run
|
||||
sbin/munin-sched
|
||||
%%DATADIR%%/munin-async
|
||||
%%DATADIR%%/munin-asyncd
|
||||
%%JAVA%%%%DATADIR%%/munin-jmx-plugins.jar
|
||||
|
Loading…
Reference in New Issue
Block a user