GNU Emacs Updates

editors/emacs:
 - Update to 24.5
 - Remove dependency on GCC for i386 platform, if the bug is fixed
   in the version in use
 - Remove upstreamed diff

editors/emacs-devel:
 - Update to git snapshot def0df01
 - Remove git revision from PORTVERSION, rather encode it in
   DISTNAME
 - Remove dependency on GCC for i386 platform, if the bug is fixed
   in the version in use
 - Fix portlint warnings

Mk/bsd.emacs.mk:
 - Update version number for editors/emacs
 - Remove deprecated block for emacs23

PR:		199553
This commit is contained in:
Ashish SHUKLA 2015-04-27 10:28:00 +00:00
parent 2371fc229a
commit 2893a8de0c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=384818
8 changed files with 40 additions and 86 deletions

View File

@ -63,27 +63,10 @@ EMACS_PORT_NAME?= emacs24
EMACS_MASTERDIR_PKGFILES?= NO
# Emacs-23.x
.if (${EMACS_PORT_NAME} == "emacs23")
EMACS_NAME= emacs
EMACS_VER= 23.4
EMACS_MAJOR_VER= 23
EMACS_LIBDIR?= share/${EMACS_NAME}
EMACS_LIBDIR_WITH_VER?= share/${EMACS_NAME}/${EMACS_VER}
EMACS_PORTSDIR= ${PORTSDIR}/editors/emacs
EMACS_COMMON_PORT= NO
EMACS_HAS_MULE= YES
EMACS_NO_SUBDIRSEL= NO
.if (${EMACS_MASTERDIR_PKGFILES} == "YES")
COMMENTFILE?= ${PKGDIR}/pkg-comment.${EMACS_PORT_NAME}
DESCR?= ${PKGDIR}/pkg-descr.${EMACS_PORT_NAME}
PLIST?= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
.endif
# Emacs-24.x
.elif (${EMACS_PORT_NAME} == "emacs24")
.if (${EMACS_PORT_NAME} == "emacs24")
EMACS_NAME= emacs
EMACS_VER= 24.4
EMACS_VER= 24.5
EMACS_MAJOR_VER= 24
EMACS_LIBDIR?= share/${EMACS_NAME}
EMACS_LIBDIR_WITH_VER?= share/${EMACS_NAME}/${EMACS_VER}
@ -118,7 +101,7 @@ PLIST?= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
check-makevars::
@${ECHO} "Makefile error: Bad value of EMACS_PORT_NAME: ${EMACS_PORT_NAME}."
@${ECHO} "Valid values are:"
@${ECHO} " Emacs family: emacs23 emacs24 emacs-devel"
@${ECHO} " Emacs family: emacs24 emacs-devel"
@${FALSE}
.endif

View File

@ -9,6 +9,7 @@ MASTER_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ashish
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-${PORTVERSION}.${GIT_REV}
MAINTAINER= ashish@FreeBSD.org
COMMENT= GNU editing macros
@ -22,13 +23,13 @@ CONFLICTS= emacs-19.* emacs21-[0-9]* emacs22-[0-9]* emacs23-[0-9]* \
emacs-nox11-[0-9]*
EMACS_VER= 25.0.50
EMACS_REV= 20150321.4a50af93
EMACS_REV= 20150427
GIT_REV= def0df01
GNU_CONFIGURE= yes
USES= cpe gmake makeinfo ncurses pkgconfig shebangfix tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INFO_PATH= ${DATADIR_REL}/info
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env autoheader:env
CPE_VENDOR= gnu
CPE_VERSION= ${EMACS_VER}
@ -71,7 +72,7 @@ M17N_DESC= M17N support for text-shaping
OTF_DESC= Opentype fonts suport
FILENOTIFY_DESC= File notification support
LTO_DESC= Enable link-time optimization (requires GCC 4.6+)
LLDB_DESC= Enable lldb support for GUD (from llvm.org)
LLDB_DESC= Enable lldb support for GUD (from llvm.org)
OPTIONS_SINGLE_X11= GTK2 GTK3 XAW XAW3D MOTIF
OPTIONS_SINGLE_SOUND= ALSA OSS
@ -173,9 +174,12 @@ FILENOTIFY_USE= GNOME=glib20
# clang is broken on i386 platform in -O2, due to use of alloca, and stack realignment
# and %esi as frame pointer register
# http://llvm.org/bugs/show_bug.cgi?id=18171
# fixed in r263312 (11-CURRENT), and fixed in r263765 (10-STABLE)
.if ${ARCH} == "i386"
.if (${OSVERSION} < 1000706) || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100015)
USE_GCC= any
.endif
.endif
DBUS_PTHREAD_LIBS= ${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{\!pg: %{pthread:||' -e 's|}.*$$||' || ${TRUE}
@ -236,8 +240,8 @@ post-install:
@${RM} -rf ${STAGEDIR}/var/games/emacs
.if ${PORT_OPTIONS:MSOURCES}
@${MKDIR} ${STAGEDIR}${DATADIR}/${EMACS_VER}/src
@${INSTALL_DATA} ${WRKSRC}/src/*.[ch] ${STAGEDIR}${DATADIR}/${EMACS_VER}/src
@${INSTALL_DATA} ${WRKSRC}/sources.el ${STAGEDIR}${DATADIR}/${EMACS_VER}/site-lisp/site-start.el
${INSTALL_DATA} ${WRKSRC}/src/*.[ch] ${STAGEDIR}${DATADIR}/${EMACS_VER}/src
${INSTALL_DATA} ${WRKSRC}/sources.el ${STAGEDIR}${DATADIR}/${EMACS_VER}/site-lisp/site-start.el
.endif
.if !defined(WITHOUT_X11)

View File

@ -1,2 +1,2 @@
SHA256 (emacs-25.0.50.20150321.4a50af93.tar.xz) = a0aadbf08666febec682901c3e925393e2bdb8c83ae71437b4bd7920e60c136f
SIZE (emacs-25.0.50.20150321.4a50af93.tar.xz) = 24789768
SHA256 (emacs-25.0.50.20150427.def0df01.tar.xz) = 7722b76e7e456c15e5809ef84bcbfc9a895502615dd23a64e0a25bd036979626
SIZE (emacs-25.0.50.20150427.def0df01.tar.xz) = 24842424

View File

@ -3636,6 +3636,8 @@ share/appdata/emacs.appdata.xml
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/cl-generic.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/cl-preloaded.el
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/cl-preloaded.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/cursor-sensor.el
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/cursor-sensor.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/eieio-compat.el
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/eieio-compat.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/inline.el

View File

@ -3,7 +3,6 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
PORTREVISION= 6
PORTEPOCH= 3
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@ -24,7 +23,7 @@ CONFLICTS= emacs-19.* emacs21-[0-9]* emacs22-[0-9]* emacs23-[0-9]* \
xemacs-devel-mule-[0-9]* \
emacs-devel-[0-9]*
EMACS_VER= 24.4
EMACS_VER= 24.5
GNU_CONFIGURE= yes
USES= cpe gmake makeinfo ncurses pkgconfig shebangfix tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
@ -179,9 +178,12 @@ FILENOTIFY_USE= GNOME=glib20
# clang is broken on i386 platform in -O2, due to use of alloca, and stack realignment
# and %esi as frame pointer register
# http://llvm.org/bugs/show_bug.cgi?id=18171
# fixed in r263312 (11-CURRENT), and fixed in r263765 (10-STABLE)
.if ${ARCH} == "i386"
.if (${OSVERSION} < 1000706) || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100015)
USE_GCC= any
.endif
.endif
DBUS_PTHREAD_LIBS= ${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{\!pg: %{pthread:||' -e 's|}.*$$||' || ${TRUE}

View File

@ -1,4 +1,4 @@
SHA256 (emacs-24.4.tar.xz) = 47e391170db4ca0a3c724530c7050655f6d573a711956b4cd84693c194a9d4fd
SIZE (emacs-24.4.tar.xz) = 39733124
SHA256 (emacs-24.5.tar.xz) = dd47d71dd2a526cf6b47cb49af793ec2e26af69a0951cc40e43ae290eacfc34e
SIZE (emacs-24.5.tar.xz) = 39759804
SHA256 (emacs24.4canna-20141030.diff.gz) = 3c49cbdf9bf822c8d682568b63328c959a79edafa2ac73aa4e5c2d27059fcfa0
SIZE (emacs24.4canna-20141030.diff.gz) = 31687

View File

@ -1,39 +0,0 @@
$FreeBSD$
From the commit r117653, bug #18858
=== modified file 'lisp/ChangeLog'
--- lisp/ChangeLog 2014-11-01 13:34:45 +0000
+++ lisp/ChangeLog 2014-11-01 14:08:00 +0000
@@ -1,3 +1,8 @@
+2014-11-01 Wolfgang Jenkner <wjenkner@inode.at>
+
+ * net/tramp-sh.el (tramp-send-command): Fix the case where the
+ remote-echo connection property is non-nil (bug#18858).
+
2014-11-01 Michael Albinus <michael.albinus@gmx.de>
Backport Tramp changes from trunk.
=== modified file 'lisp/net/tramp-sh.el'
--- lisp/net/tramp-sh.el 2014-11-01 13:34:45 +0000
+++ lisp/net/tramp-sh.el 2014-11-01 14:08:00 +0000
@@ -4769,6 +4769,17 @@
(when (tramp-get-connection-property p "remote-echo" nil)
;; We mark the command string that it can be erased in the output buffer.
(tramp-set-connection-property p "check-remote-echo" t)
+ ;; If we put `tramp-echo-mark' after a trailing newline (which
+ ;; is assumed to be unquoted) `tramp-send-string' doesn't see
+ ;; that newline and adds `tramp-rsh-end-of-line' right after
+ ;; `tramp-echo-mark', so the remote shell sees two consecutive
+ ;; trailing line endings and sends two prompts after executing
+ ;; the command, which confuses `tramp-wait-for-output'.
+ (when (and (not (string= command ""))
+ (string-equal (substring command -1) "\n"))
+ (setq command (substring command 0 -1)))
+ ;; No need to restore a trailing newline here since `tramp-send-string'
+ ;; makes sure that the string ends in `tramp-rsh-end-of-line', anyway.
(setq command (format "%s%s%s" tramp-echo-mark command tramp-echo-mark)))
;; Send the command.
(tramp-message vec 6 "%s" command)

View File

@ -1646,8 +1646,6 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lisp/warnings.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lock.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emacs-lock.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/crisp.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/crisp.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/cua-base.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/cua-base.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/cua-gmrk.el.gz
@ -1666,16 +1664,6 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/edt.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/keypad.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/keypad.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/tpu-edt.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/tpu-edt.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/tpu-extras.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/tpu-extras.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/tpu-mapper.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/tpu-mapper.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/vi.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/vi.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/vip.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/vip.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/viper-cmd.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/viper-cmd.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/viper-ex.el.gz
@ -1692,8 +1680,6 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/viper-util.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/viper.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/viper.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/ws-mode.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/emulation/ws-mode.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/env.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/env.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/epa-dired.el.gz
@ -2268,6 +2254,7 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/international/ucs-normalize.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/international/ucs-normalize.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/international/uni-bidi.el
%%DATADIR%%/%%EMACS_VER%%/lisp/international/uni-brackets.el
%%DATADIR%%/%%EMACS_VER%%/lisp/international/uni-category.el
%%DATADIR%%/%%EMACS_VER%%/lisp/international/uni-combining.el
%%DATADIR%%/%%EMACS_VER%%/lisp/international/uni-comment.el
@ -2848,10 +2835,14 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/awk-mode.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/awk-mode.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/bruce.el
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/cc-compat.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/cc-compat.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/cl-compat.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/cl-compat.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/complete.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/complete.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/crisp.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/crisp.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/cust-print.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/cust-print.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/erc-hecomplete.el.gz
@ -2930,8 +2921,20 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/sym-comp.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/terminal.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/terminal.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/tpu-edt.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/tpu-edt.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/tpu-extras.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/tpu-extras.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/tpu-mapper.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/tpu-mapper.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/vc-mcvs.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/vc-mcvs.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/vi.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/vi.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/vip.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/vip.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/ws-mode.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/ws-mode.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/xesam.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/xesam.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/obsolete/yow.el.gz
@ -3251,8 +3254,6 @@ share/applications/emacs.desktop
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-bytecomp.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-cmds.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-cmds.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-compat.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-compat.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-defs.el.gz
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-defs.elc
%%DATADIR%%/%%EMACS_VER%%/lisp/progmodes/cc-engine.el.gz
@ -4041,3 +4042,4 @@ share/icons/hicolor/32x32/apps/emacs.png
share/icons/hicolor/48x48/apps/emacs.png
share/icons/hicolor/scalable/apps/emacs.svg
share/icons/hicolor/scalable/mimetypes/emacs-document.svg
@dir %%DATADIR%%/%%EMACS_VER%%/lisp/emacs-parallel