o Fix build with gcc 3.4.x

o Switch to REINPLACE_CMD
o Tested on CURRENT-amd64 / CURRENT-i386 / 5.2.1REL-i386

Tested by	mux
This commit is contained in:
Michael Landin 2004-08-18 15:59:36 +00:00
parent 9ca785ab6d
commit 28755ce396
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116599
2 changed files with 19 additions and 1 deletions

View File

@ -20,6 +20,7 @@ RUN_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_REINPLACE= yes
USE_MOTIF= yes
USE_BISON= yes
USE_GMAKE= yes
@ -33,8 +34,9 @@ MAN1= psf.1 tatd.1 tcbd.1 tcm.1 tcmd.1 tcmdv.1 tcmt.1 tcpd.1 tcrd.1 \
post-patch:
@${RM} ${WRKSRC}/man/windex
@${CHMOD} 0644 ${WRKSRC}/lib/colorrgb.txt
@${REINPLACE_CMD} -e 's:gcc:g++:g' ${WRKSRC}/bin/makedepend.sh
post-install:
@${SED} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
@${REINPLACE_CMD} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1,16 @@
$FreeBSD$
--- src/sd/dv/function.h.orig Wed Aug 18 16:02:05 2004
+++ src/sd/dv/function.h Wed Aug 18 16:02:38 2004
@@ -19,8 +19,8 @@
// Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
// 02111-1307, USA.
//-----------------------------------------------------------------------------
-#ifndef _FUNCTION_H
-#define _FUNCTION_H
+#ifndef _FUNCTION_CLASS_H
+#define _FUNCTION_CLASS_H
#include "c1edge.h"
class ERGraph;