Support STAGEDIR.
This commit is contained in:
parent
4d6104c2e8
commit
2873bde872
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333882
@ -11,8 +11,6 @@ MASTER_SITE_SUBDIR=wes
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Refuse a login to a user, and make a note of it in syslog
|
||||
|
||||
PLIST_FILES= bin/nologin
|
||||
MAN8= nologin.8
|
||||
PLIST_FILES= bin/nologin man/man8/${PORTNAME}.8.gz
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.mk>
|
||||
|
12
sysutils/no-login/files/patch-Makefile
Normal file
12
sysutils/no-login/files/patch-Makefile
Normal file
@ -0,0 +1,12 @@
|
||||
--- Makefile.orig 2013-11-15 23:27:54.000000000 +0800
|
||||
+++ Makefile 2013-11-15 23:28:07.000000000 +0800
|
||||
@@ -30,7 +30,7 @@ all: nologin
|
||||
nologin: nologin.c
|
||||
|
||||
install:
|
||||
- install -c -o root -g bin -m 755 nologin $(PREFIX)/bin
|
||||
- install -c -o root -g wheel -m 444 nologin.8 $(PREFIX)/man/man8
|
||||
+ install -c -o root -g bin -m 755 nologin $(DESTDIR)$(PREFIX)/bin
|
||||
+ install -c -o root -g wheel -m 444 nologin.8 $(DESTDIR)$(PREFIX)/man/man8
|
||||
clean:
|
||||
-rm -f *.o *~ nologin
|
@ -10,12 +10,10 @@ MASTER_SITES= SF
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= SNMP based command line network printer management tool
|
||||
|
||||
MAN1= npadmin.1
|
||||
PLIST_FILES= bin/npadmin
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
NO_STAGE= yes
|
||||
PLIST_FILES= bin/npadmin man/man1/${PORTNAME}.1.gz
|
||||
|
||||
pre-configure:
|
||||
${RM} ${WRKSRC}/getopt.h ${WRKSRC}/getopt1.c
|
||||
|
||||
|
@ -9,17 +9,16 @@ MASTER_SITES= http://gregory.kokanosky.free.fr/v4/linux/
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Convert Nero .nrg CD-Image format to ISO
|
||||
|
||||
USE_GMAKE= yes
|
||||
USES= gmake
|
||||
|
||||
PLIST_FILES= bin/nrg2iso
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|gcc|${CC} ${CFLAGS}|' \
|
||||
${BUILD_WRKSRC}/${MAKEFILE}
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/nrg2iso ${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/nrg2iso ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
Loading…
Reference in New Issue
Block a user