Add p5-GnomePrint, it's perl binding to Gnomeprint library.

This commit is contained in:
Vanilla I. Shu 2001-03-12 08:57:18 +00:00
parent 027ed6b39d
commit 284ac44553
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39632
7 changed files with 59 additions and 0 deletions

View File

@ -74,6 +74,7 @@
SUBDIR += musixtex
SUBDIR += nenscript
SUBDIR += offix-printer
SUBDIR += p5-GnomePrint
SUBDIR += p5-Text-PDF
SUBDIR += pnm2ppa
SUBDIR += pclprint

View File

@ -0,0 +1,27 @@
# New ports collection makefile for: p5-GnomePrint
# Date created: 11 March 2001
# Whom: vanilla
#
# $FreeBSD$
#
PORTNAME= GnomePrint
PORTVERSION= 0.7005
CATEGORIES= print lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Gtk
PKGNAMEPREFIX= p5-
DISTNAME= Gtk-Perl-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gnome.pm:${PORTSDIR}/x11-toolkits/p5-Gnome \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk/Gdk/Pixbuf.pm:${PORTSDIR}/x11-toolkits/p5-GdkPixbuf
LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
gnomeprint.13:${PORTSDIR}/print/gnomeprint
USE_GNOME= yes
PERL_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Gtk-Perl-0.7005.tar.gz) = a1a1e13f1017e7dd005cc8bc426b09aa

View File

@ -0,0 +1,12 @@
--- Makefile.PL.orig Mon Mar 12 14:50:35 2001
+++ Makefile.PL Mon Mar 12 14:50:39 2001
@@ -1,9 +1,5 @@
use ExtUtils::MakeMaker;
use File::Basename;
-use blib '..';
-use blib '../Gnome';
-use blib '../GdkImlib';
-use blib '../GdkPixbuf';
use Cwd;
require '../Depends.pm';
require '../tools/gendefs.pl';

View File

@ -0,0 +1 @@
The Gnome Print module of Gtk-Perl

View File

@ -0,0 +1,3 @@
The Gnome Print widget module of Gtk-Perl (Gnome::Print namespace).
WWW: http://projects.prosa.it/gtkperl/

View File

@ -0,0 +1,14 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Types.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Install/Files.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Install/GnomePrintDefs.h
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Install/GnomePrintTypemap
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Install/PerlGnomePrintInt.h
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Install/pkg.typemap
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Print/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Print/Print.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Print/Print.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Print/autosplit.ix
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print/Install
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Print
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Print